Welcome Dialog

コミュニティへようこそ。

まったく新しい外観になりました。ツアーに参加して、アドビサポートコミュニティの最新情報をご覧ください


書き出した動画で特定の条件のトランジションがYouTubeなどに投稿した際反映されない。

New Here ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

スクリーンショット (6).png

実際に発生している部分の再生比較↓(写真の動画とは別ですが同じバグが発生しています。) https://twitter.com/by71396724/status/1453596044114026508

動画の開始部分など、クリップ間同士を繋げていない部分に付けたトランジションが動画サイトなどに投稿した時だけ反映されません。

書き出した動画を改めてpremiere proで確認しても、反映して書き出されている事が確認出来ます。

しかしYouTube側では何も適用されず、トランジションが無い部分と同じ状態になってしまいます。投稿後に不具合が発生してしまうため太刀打ちの仕様がありません。

 

alpha付きapple ProRes 4444XQ 16bpc+アルファ 48000hz 2ch 24bit スマートレンダリングコーデック有効 Media Encoder 22.0で書き出し

RTX3060ti NVDIAstudiodriver 471.41と、これが発生した為に更新して試した472.39双方で発生しています。premiere proのバージョンは確認した22.0と15.4~15.4.2全てで発生する事が確認出来ました。

何か解決方法などはありませんか?実はMedia EncoderやYouTubeのバグだったりしますか?

 

ちなみに添付ファイルの写真にchrome更新エラーが出ていますが、仕様変更の関係で出来なくなる事がある為手前のバージョンで更新を取りやめているだけです。

一旦最新にしてから試みてもこのバグは発生しました。

キーワード
エラーまたは問題, 書き出し

表示

99

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
replies 18 件の返信 18
Adobe Most Valuable Participants ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

お早うございます、康揚5C17さん

 

V2トラックの最初の橙色の部分のトランジションですか。Premiere Proから書き出した動画には反映されているが、YouTubeにアップロードした動画には反映されていないということですね。

 

>何か解決方法などはありませんか?実はMedia EncoderやYouTubeのバグだったりしますか?

Premiere ProのYouTubeのプリセット(下記)で書き出してみたらいかがでしょうか。これで正常なら、ご使用した形式・プリセットに問題があるかも知れません。

 

ご使用のPremiere ProはWindows版だと思いますので、

形式;H.264

プリセット;2Kシーケンス設定ならYouTube 1080p フル HD、4KならYouTube 2160p 4K Ultra HD

書き出しは、「キュー」からMediaEncoderを使用せず、「書き出し」をクリックして直接書き出します。

 

下記リンクも参考にされると良いと思います。

アップロードする動画におすすめのエンコード設定 - YouTube ヘルプ (google.com)

 

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
New Here ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

mp4のHDと4kのプリセットで、premiere proで直接書き出しした動画とMediaEncoderで書き出した動画、4つ全てでトランジションが適用される事が確認出来ました。

その後apple ProRes4444XQで書き出したら再びトランジションが適用されないバグが起きました。

 

4444XQは500Mbpsで、その負荷に耐えられていないのかなと思い、102Mbpsの422 LT 45Mbpsの422プロキシ 4K Ultra HDで300Mbpsを指定したmp4 3つの動画でも試しましたが、やはりProResでのみトランジションが適用されませんでした。

まだ例が少ないので詳細は分かりませんが、今回は使用した形式に問題がある系なバグのようです。

とりあえずは解決しましたが、やはり品質的にProResの方が良い為良ければ引き続きこちらを使い続けたいのです。apple ProRes MXF OP1aに何かバグ報告は出ていますか?

スクリーンショット (7).png

 

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
Adobe Most Valuable Participants ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

ProRes 4444XQでアルファが無視される(この場合トランジションが無視される)のは正常な動作なのですが、ProRss 422 LTでも症状が出るのは少し不可解です。

 

私の検証でも、422LTでは問題ありませんでした。冒頭から2秒のディゾルブを掛けた映像で試しています。

 

4444XQ

https://youtu.be/KDQgLeWpD7E 

 

422LT

https://youtu.be/4AqwTMct2-U 

 

可能でしたら、動画再生ソフトのVLCでアップロード前の映像をご覧いただくと、トランジションはどのようになってますでしょうか?

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
Adobe Most Valuable Participants ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

追記ですが、トランジション部分の「透明」の問題か否かの判断材料にするため、透明グリッドを表示する設定でご確認いただくとより分かりやすいのではないかと思います。

20211104_001.png

この画像は先ほどProResのMXFでアップしたYouTube映像のシーケンスなのですが、ディゾルブを入れて一見黒からフェードインしているように見える映像も、実際には透明から徐々に表れる映像となっています。

 

この徐々に表れる表現は、アルファチャンネルで元の映像(この場合はカラーバー)の表示濃度を制御して実現しているので、アルファ付きで書き出してYouTubeやアルファチャンネルを無視するプレーヤーで表示すると、いきなりカラーバーが表示されるということになります。

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
Adobe Most Valuable Participants ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

アルファがつかないProRes422HQで書き出して頂くといかがでしょうか。

おそらく「黒」だと思われている部分は「透明」で、ストレートマットなのでアルファを無視すると普通に動画が出ている(仕様的には正常)ということではないかと思います。

【追記】

おそらくできるだけ高画質にしたいというご希望で書き出し設定を選ばれているのではないかと思いますので一応ProRes422HQで、と書いてみましたが、、SDRでしたらYouTubeでの再エンコード(8bit 4:2:0)を考えますとProResはオーバースペックなので、ビットレートを高めにしたH.264でも十分なような気がいたします。

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
New Here ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

今回の動画は元が1920×1080のHDRで、音声が5.1ch Dolbydigital 460Kbpsです。

フルhdのmp4プリセットだと320KbpsのAACしか選択出来ず、4Kプリセットでは映像が引き延ばされた形になって、大きい画面で見たら下手をすると720pよりも低画質に見えるくらい見栄えが悪くなる、というなかなか面倒くさい物となっています。

MPEGの音声は相性が悪いのか無音の動画しか出来上がらないので使用出来ません。

そこでProResに出会い、これならば行けると思ったので使い始めたのですが、今回このような事が発生しました。

別の返信で表記しておりますが、それより下の422 LT 422プロキシでも発生したので、恐らく422HQでも同じことが発生してしまうと思われます。

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
Adobe Most Valuable Participants ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

入れ違いになってしまいましたが、このスレッドの表示上の少し上の返信にて、私もProRes MXFで書き出してYouTubeにアップした結果を載せてみました。

 

4444XQで書き出すと透明部分が「黒」ではなく「映像にアルファを掛けたもの」という扱いになりますので、アルファを無視するとそのまま映像が出てくるのでバグや不具合ではなく正常な動作になります。

(プリマルチプライされていない場合。)

 

アルファチャンネルが付かない422LTや422HQで、トランジション部分がYouTubeでのみ再現されないのは原理的に考えにくいので(トランジションがかかる前の映像も保持しているということになってしまうので……)、422LTで症状が出るのは少々不可解です。

その

422LTで書き出した映像を、Premiere ProやVLCなどのソフトで再生すると、トランジションは正常に出ていますでしょうか。

 

ちなみに、私はRec.709SDRで試していたので、HDRではまた異なる結果になるかもしれません。

業務の合間になるのですぐにはできないのですが、追って試してみようと思います。

 

ちなみに、YouTube公式ではこのような記載があります。

https://support.google.com/youtube/answer/7126552?hl=ja&ref_topic=9257439 

 

さすがに、4444XQはオーバースペックかと思いますので、ProRes 422でも十分ではないかと思います。

 

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
New Here ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

もう一回したら上手く出来ました・・・うーむ分からない。

https://youtu.be/poqp5N1Mrto

 

というか、4444XQではトランジションは無視されるんですか?私は今年の3月ごろから常に16bpc+アルファ4444XQで動画を投稿して来ました。ここ最近まではトランジションなども全て正常に適用されておりました。

今までの挙動こそが不具合だったという事なのでしょうか。

テストです。

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
Adobe Most Valuable Participants ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

>というか、4444XQではトランジションは無視されるんですか?

4444XQでもアルファをつけないで書き出し(その場合4が一つ減って444XQと表現することもあります)すると、こういった問題は起きないです。

また、アルファをつけるとトランジションが無視されるというよりは、トランジションの種類によってはアルファチャンネルの濃淡で実現しているものがあり、そういった種類のトランジションを使ってアルファ付きで書き出すと、アルファチャンネルを無視する環境では反映されない、ということになるかと思います。

 

>ここ最近まではトランジションなども全て正常に適用されておりました。

いますぐに検証できないのですが、もしかするとv22のアップデートでプリマルチプライなどPremiere Pro側で仕様変更があったかもしれません。

<追記>Premiere Pro 2021 (v15.4.1)で試してみましたが、同様の結果でした。<追記終わり>

 

しかしながら、もともとアルファチャンネルを使用できないYouTubeに対して、アルファ付きでアップロードするのは適切ではないと思います。

 

なお、まだきちんと検証しておりませんが、MXFのProResですとHDRのタグが付かないようです。v22ですと、HDR→SDRの変換が行われてSDRで書き出しされます。

 

ですので、HDRでアップロードなさる場合にはMXFではなくQuickTimeの方のProRes(movコンテナ)の方が適切かと思います。

 

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
New Here ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

上側の返信のやつを試してみました。

なんかSSの一部がかなり白くなりましたが、アルファから変えている事が確認出来ました。この部分をYouTubeが無視する為に発生していたんですね。

 

ついでにQuickTimeの出力画面を出しておりますが、こちらのProResを選択して「カラースペースを書き出し」の項目をRec.2100で出力すれば良いということであっておりますでしょうか、

HGLとPQどちらが良いかは後ほど調べて行く予定です。

スクリーンショット (9).png

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
New Here ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

違うw

HLG方式とPQ方式ですね。

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
Adobe Most Valuable Participants ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

急ぎ足でとりあえず試してみました。

 

Premiere ProのプリセットのXQ4444 HLGで書き出しています。

20211104_002.png

このプリセットでは8bit/chの設定になり、それが妥当か否かの検証はしていませんが、とりあえずそのまま書き出してYouTubeにアップして問題なく表示されました。

 

残念ながらいまHDRを確認できる環境ではないのですが、SDRのパソコンでの表示を見る限りは標準的なSDRだと思うので、全くでたらめな表示にはなっていないと思います。

 

以前はアルファ付きで問題が無かったという理由は分かりませんが、アルファ付きでのアップロードは仕様外の誤った方法という位置づけかと思いますので、あまり気にせず今後はアルファ無しでアップしていただければよいのではないかと思います。

(これまでは一見問題は無くても、ボケ足部分が汚くなっていたなどの可能性はあり得ると思います。)

 

https://youtu.be/dSv1lHcAFcA

 

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
Adobe Most Valuable Participants ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

すみません、返信のタイミングが入違ってしまいました。

 

おそらく撮影素材はHLGだと思いますので、シーケンス設定もHLGになさっているはずですので、HLGでの書き出しが適している状況かと思います。

 

HDRについては、十分仕組みをご理解いただいたうえで、編集環境内での各種設定が正しくないと成立しませんので、十分ご注意ください。

 

誤った設定でHLG素材を扱い、結果的にその誤ったことによる独特の映像効果を好まれて使われているケースも少なくないようなので、世の中的になかなか厄介な状況になっていると感じています。

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
Adobe Most Valuable Participants ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

たびたびスミマセン。プロブラムパネル、SDRだと透明グリッドを表示させると透明が市松模様になるのですが、HLGですと真っ白になりますね……。書き出しなど主な動作には問題は無いと思いますが、ちょっとしたバグかもしれません。

 

 

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
New Here ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

こちらで詳細統計情報を見たところ、colorの部分にBT2020と表示されており、HDRで投稿出来ている事が確認出来ました。

この設定ならば間違いなく最高品質で投稿出来るでしょう。

今後はアルファ関係には十分注意して制作したいと思います。

今回はありがとうございました。

スクリーンショット (10).png

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
Adobe Most Valuable Participants ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

ご確認ありがとうございます!

職場のパソコンでは確認できなかったので、助かりました。これなら大丈夫そうですね。

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
New Here ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

ひゃ、また入れ違いw

そんな使い方もあるんですね・・・何はともあれ映像の世界はどんどん広がっているようですね。

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
New Here ,
Nov 03, 2021 Nov 03, 2021

リンクをクリップボードにコピー

コピー完了

最新

はい。非常に良い書き出し方法に巡り合えました。

これならば敵は無いでしょう。

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines