• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Premier Pro Beta Lagging and Program Monitor is Glitching

Community Beginner ,
May 24, 2024 May 24, 2024

Copy link to clipboard

Copied

I'm using Premiere Pro Beta, version 24.6.0 BETA (build 2), and encountering numerous issues with lagging and glitches in the Program Monitor. The glitches typically appear after 20 to 30 minutes of starting the software, rather than at the beginning. Additionally, after exporting from a rendered timeline, the result is full of glitches - please refer to the attached images.

 

My original footage is in 4K, and the project involves a significant number of effects, primarily Lumetri Colors. Furthermore, I have a film grain footage overlaying the entire timeline, which raises the question if this could be the issue for glitches in the export, however the gliteches appear in Program Monitor even when the track with footage is off. 

 

I'm using a MacBook Pro (16-inch, 2019) with an 8-core Intel Core i9 processor and 32 GB of RAM, which should be sufficient for the task. I'm working on an external SSD hard drive with a USB 4 cable, formatted in APFS.

I've taken several steps to address the issue, including but the issues still presist

- creating proxies in H.264 QuickTime format

-regularly deleting cache files

-enabling Mercury Playback Engine GPU Acceleration

-designating 26GB of RAM for Premiere.

 

Any ideas what can be the issue?

Views

160

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 24, 2024 May 24, 2024

Copy link to clipboard

Copied

A small detail but still want to add : I put my playback on 1/4 and its still lagging !

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

I guess I have the same problem started like 3 months ago.  I have tried to reset the system of my MacBook, I have tried to reset also Premiere and also to take Premiere 1 previous version but nothing change. Still have the problem. Right now I'm using my old laptop 6 years old and works as fast as my macbook

447626886_10229653426871393_8602521817459140752_n.jpg

Screenshot 2024-05-19 alle 14.45.18.png

  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

Did you resolve?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 05, 2024 Jun 05, 2024

Copy link to clipboard

Copied

LATEST

Not sure to be honest, I did bring my laptop to apple store for basic cleaning, there was a lot of dust which was causeing overheating, which might have been the problem. is your laptop's fans go crazy as well even when its not doing anything heavy? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources