• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

BUG -Mercury Transmit will not use screen 2 in 3 screen setups on Windows

47 Votes
Community Beginner ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

When using Premiere Pro 13.1 on multiple monitors with Windows with 3 monitors attached, Mercury transmit will NOT allow Monitor 2 to be used for playback. When selecting Monitor two, Monitor 3 will automatically be selected andk keep monitor 1 selected also. This behaviour does NOT occur with 13.0.3. Selecting alternate render options does not fix the issue.
Bug Unresolved
TOPICS
Editing and playback

Views

9

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
18 Comments
LEGEND ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

I have this kind of problem

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Same. We run a 20 edit suite facility and are not able to roll back versions. This is becoming a huge problem.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

I have 3 monitors, one HD, one 4K and one HD beamer. Whatever i do, it will only display on my 4K monitor. And sometimes correct and sometimes zoomed in. I want to select my Beamer screen, but it doesn’t allow it.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Same problem. Running Premiere 13.1 on 3 monitors connected to an NVIDIA K4000 GPU on Windows 10 (HP Z820). Mercury Transmit will only show up on Monitor #3, but Monitor #2 is my Eizo color grading monitor. If I check Monitor #2 in Preferences >> Playback it switches to 3 on its own. I have the same problem in After Effects. It worked beautifully in the previous CC version, so I know my setup should not be the issue.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Same problem!!

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Hello,
Same problem (2 monitor) 1 main monitor and a second 4K DP Monitor. No more Dual Monitor working. Just did an upgrade to latest version of Premiere and NVidia Driver as always since many years... Cannot find a fix...

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Same issue Windows 10. Tried everything.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Our 15 seat facility is expiring this same setup.
For pros with dual monitors plus a client monitor, this is a huge problem. Editing with people in the room is a huge part of a commercial edit shop's day.
How could Adobe let this happen?
Please fix ASAP.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Same Problem here with 3 Screens.. Super anoying

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Three identical monitors. In version 13.0.3 everything works fine. Updated to 13.1.2. Premiere uses the settings of the previous version and Mercury works on the monitor I need. But keyboard shortcuts doesn't work (don't know why — same bug on few PC's). I reset settings (Alt + Shift + Click) and — Bam! — Transmit is stuck. On the monitor, which I do not need. Without the ability to change this.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Hello Adobe,Premiere 13.1 release is a mess. I use Premiere since the beginning of time (25 years) I had no serious issue since many years. Now I dont know what to do with all the bugs I have with Premiere, After Effects. Cannot use muti monitor anymore in Premiere. Mercury Transmit nothing. Program monitor is black. No visual playback in Ae when using Dynamic Link. I simply cannot complete my projects anymore. The reason why this situation happen is releted to ''AGILE Management''. Go to public fast without considering quality. AGILE is the worst modus operandi Management trends. And this can lead to lost of trust by users. I hope this trends will be abandon. AGILE is a excuse to generate ROI fast without taking care of quality. .......Collect Now FIX IT LATER. Since many years I was in the impression that Adobe was managing with care their updates & upgrades. Hope they will come fast with a clear & solid update to this situation.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

This should be fixed in 13.1.3 according to Adobe: DVAPR-4215679 - [Social Media] [Forums] Transmit output to 2nd (primary) monitor doesn't work if Premiere is running on secondary monitor. Preference can not be set.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Same Problem with a 3 Monitor Setup. I have no picture in the programm window. If I disable the third monitor in Windows, start Premiere, enable the monitor again, it works fine.
But this procedure is very annoing.

Please fix it!

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Happy New year everyone....this is still a problem in my setup.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Same issue here, it's only possible to to have one external monitor full screen playback at a time now, which is very frustrating. Not good for the professional suite environment. Get a wriggle on Adobe!

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Same here.

Votes

Translate

Translate

Report

Report
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

Same issue with 4 monitors Windows 10. just get a sound and no window when trying to use dynamic link. Using latest version of premiere 14.3 and after effects 17.1.1. Anyone have a solution?

Votes

Translate

Translate

Report

Report
Explorer ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

LATEST
I get this with all kinds of Premiere versions on MAC and PCs - I'm surprised when 3 monitors actually works!

I have found no clear logic how to avoid it but am usually able to solve it by 1. Putting an external fan blowing on the GPU 2. making sure the cables are up to date for 2K/4K etc whether you're using HDMI or DisplayPort 3. Using the monitors in "unscaled" mode 4. Playing with the port BUS the monitors are connected to (separate ones are a good idea) 5. playing with the display resolution 6. playing with the display arrangement 7. changing which display is plugged in to which port 7. Sticking with whatever works as much as possible.

As I said, It's crazy that the there is no resource for troubleshooting this from Adobe - it's been an issue in my workflows for 4 years now and many different machines and versions.

Votes

Translate

Translate

Report

Report