• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
3

CUDA / OpenCL acceleration breaks custom transitions

Community Beginner ,
Jun 17, 2023 Jun 17, 2023

Copy link to clipboard

Copied

Hello everyone! 

 

I'm trying to apply a custom transition which utilizes Transform, Mirror, Offset, Brightness & Contrast effects and some masking. All the aforementioned effects are GPU accelerated, which is nice, but the thing is that once I enable Mercury Playback Engine GPU Accelerated (both CUDA and OpenCL) this transition starts acting up. It's worth mentioning that I was able to reproduce this behavior on two different computers with different GPU vendors (Intel and Nvidia). 

 

Here's how it looks with Mercury Playback Engine Software Only: https://youtu.be/5cUu60DosmQ

And here's how it looks with Mercury Playback Engine GPU Accelerated: https://youtu.be/_GV-cR-Cqxc

 

Here's the project-file that I used as an example: https://drive.google.com/file/d/1rJSraxeXWsMV6VOZB6eTyFyP7hHa7mMf/view

 

Can someone recommend any workarounds other than switching to Software Only mode, 'cause that one is quite slow? I tried to apply these transitions onto the clips instead of adjustment layers, and I also tried nesting the clips, but that didn't help...

Bug Unresolved
TOPICS
Editing and playback , Effects , Export

Views

222

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
5 Comments
LEGEND ,
Jun 17, 2023 Jun 17, 2023

Copy link to clipboard

Copied

And which GPU are you using, and which driver is it using?

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 17, 2023 Jun 17, 2023

Copy link to clipboard

Copied

I have a rather dated GTX 1050 Ti in my desktop machine with NVIDIA Studio Driver 516.59.

I have a fairly recent (2021) Intel UHD Graphics with 32 EUs in my laptop. Not sure about the driver version on that one, as it's not with me right now... 

 

Can you reproduce my issue with GPU acceleration on your side? 

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 17, 2023 Jun 17, 2023

Copy link to clipboard

Copied

@RjL190365 is the person that knows the hard data on these.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jun 18, 2023 Jun 18, 2023

Copy link to clipboard

Copied

quote

@RjL190365 is the person that knows the hard data on these.

 

It would be great if they could share their opinion on this matter. 

 

I'd also greatly appreciate it if someone could try opening my example project on their systems and see how it works with and without GPU Acceleration (in File>Project Settings>General>Renderer). 

The whole ZIP-file is only 15MB in size and contains of only two still images from Adobe Stock and a Premiere Pro project file.

It's completely clean and safe to open: VirusTotal Analysis 

Votes

Translate

Translate

Report

Report
Community Expert ,
Jun 18, 2023 Jun 18, 2023

Copy link to clipboard

Copied

LATEST

@dr04e606 

 

I'm chiming in to say that I am able to reproduce the issue under Windows and macOS.  Unless the Renderer is set to Software only, it tweaks. 

Votes

Translate

Translate

Report

Report