• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

error in the option "space between subtitles"

New Here ,
Apr 12, 2023 Apr 12, 2023

Copy link to clipboard

Copied

the "space between subtitles" option does not work, it is not applying the frame spaces between the subtitles

 

 

JulianAndres22255830w1wj_0-1681358694275.pngJulianAndres22255830w1wj_1-1681358722108.png



Does anyone know any solution?

Bug Unresolved
TOPICS
Editing and playback

Views

202

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
1 Comment
Community Expert ,
Apr 13, 2023 Apr 13, 2023

Copy link to clipboard

Copied

LATEST

Julian,

 

I had not experimented with this. It does have an effect, but it appears to interact with other settings in the Create Captions dialogue. Also, even with gap set to zero, there are gaps between captions when there are pauses or gaps in the dialogue. (Some users have requested a setting so that there will NEVER be any gaps between captions.)

 

I don't have time to do the testing needed to reach any conclusions. So far, I created 5 caption streams from the same transcript. I set them like this:

 

  Total Range 1 2 3 4 5
Max Length in Characters 7 - 72 42 72 42 42 42
Minimum Duration in Seconds 1.2 - 6 1.2 6 3 3 3
Gap between captions (frames) 0 - 10 10 10 0 3 5
Lines Single vs Double   Single Single Single Single

Single

 

 

There were many gaps of more than the specified frames, which is what I would expect. V2 resulted in a most consistent gap of 10 frames between captions. V5  produced gaps close to 5 frames.

 

I also noted that the max number of characters appeared to have the highest priority. However, when the number of characters exceeded 50-something, captions wrapped to a second line even if set to single line. This is related to the text box size and font size. I created a style with the "Set Horizontal Size" set to 96, the max it allowed. Almost all of my captions then appeared on 1 line. I did not test it, but you could use such a style when creating the captions.

 

To do what you want, which PR does not appear to be doing, I would use my favorite Subtitle Edit, and apply the Tools -> "Apply minimum gap between subtitles..." I appears to use the "minimum milliseconds," and includes a convertor for frame rate and frames to give you the milliseconds.

 

Stan

 

 

Votes

Translate

Translate

Report

Report