• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
24

Premiere 2024 Ripple Delete Freezes Everything

Community Beginner ,
Oct 15, 2023 Oct 15, 2023

Copy link to clipboard

Copied

This is an issue i'm having with Premiere Pro 2024, as I have just updated my software. It seems that ripple deleting has just been absolutely blown out in this version, or at least for my project file. 

 

I use "Q" and "W" to ripple delete footage. It does this action but the playhead will stay at the last spot it was at for about 10 seconds, my PC fans will roar up, then the playhead goes back to it's expected spot at the cut I made. I have a pretty good system and it's NEVER done this before today and it's becoming an absolute PAIN and quite literally UNUSABLE. It'll work when ripple deleting around 1-3 seconds of footage but then starts lagging when ripple deleting anything over 10 seconds.

And please, don't suggest the "revert back to old version" as a "f i x". Project files cannot be reverted back to older years of Premiere.


PC specifications:
GPU: RTX 3070
CPU: Ryzen 9 5900X
RAM: 32GB
OS: Windows 10

Bug Unresolved
TOPICS
Editing and playback , Performance or Stability , User experience or interface

Views

4.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
replies 118 Replies 118
118 Comments
Adobe Employee ,
Sep 08, 2023 Sep 08, 2023

Copy link to clipboard

Copied

Moving it to Discussions

Votes

Translate

Translate

Report

Report
Explorer ,
Sep 08, 2023 Sep 08, 2023

Copy link to clipboard

Copied

Hmm I had this issue with 23.5 and just upgarded to 23.6 and it's still there.  Weird bug I guess 😕

Votes

Translate

Translate

Report

Report
Community Beginner ,
Sep 10, 2023 Sep 10, 2023

Copy link to clipboard

Copied

I have been having the same issue too! Have another forum query open and have followed all of the tips there but it hasn't fixed mine. 

 

When reverting to a previous PremierPro version, did your project carry on okay?

 

I've been working on something for months and really worried I'll corrupt or loose what I've got.

 

Votes

Translate

Translate

Report

Report
New Here ,
Sep 10, 2023 Sep 10, 2023

Copy link to clipboard

Copied

I didn't have any problems when I reverted to an earlier version, you shouldn't either.

 

Could probably just make a backup of the project somewhere then revert, should anything go wrong you can just return to the current version your project is working with and resume with the backup.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Sep 11, 2023 Sep 11, 2023

Copy link to clipboard

Copied

Sorry about the issue. Can you share system details (OS, CPU, RAM, GPU)? Which exact version of Premiere Pro did you have this problem? Could you provide a screen recording of the issue? 

Let us know. Happy to assist. Thanks. ^KR

Votes

Translate

Translate

Report

Report
Explorer ,
Sep 14, 2023 Sep 14, 2023

Copy link to clipboard

Copied

Does anyone have a valid workaround / fix for Ripple Delete causing lag of a few seconds.

I saw some users saying rolling back to 23.5 worked - but it has not for me.

Also suggested to start a new project, so I have but that has not fixed it either.

It is making my work very slow and is borderline unworkable.

Votes

Translate

Translate

Report

Report
New Here ,
Sep 17, 2023 Sep 17, 2023

Copy link to clipboard

Copied

I have encountered the same bug on an Alienware R15 equipped with an RTX 4090, 64GB of RAM, and a 1TB PCIe NVMe SSD. I don't believe the issue is hardware-related, as I've experienced the same bug on different workstations and across all versions after 22.0. Could someone from Adobe test this? The issue is straightforward: in a timeline with 40-50 clips, removing a gap between clips causes the program to freeze for 5-20 seconds, depending on the number of clips in the timeline.

Votes

Translate

Translate

Report

Report
Community Expert ,
Sep 17, 2023 Sep 17, 2023

Copy link to clipboard

Copied

I don't usually experience the slow performance reported over the last several years. Your test seemed straightforward, so I gave it a go.

 

I opened an older project in 23.6, probably started in PR 2022. 13-and-a-half-minute timeline, dozens of primarily mp4 clips, dozens of jpg's, a dozen or so graphics. Not big, but not tiny.

 

When I opened and accepted the "converting" to 23.6, all opened okay. Progress Dashboard still shows 10 more minutes to relink media. After it was done, there was a lot of "generating peak files." There are no gaps in the timeline. I have "duplicate frame markers" off. (Some users have reported that can have an effect on some slow performance situations.)

 

I created a gap by deleting a clip (video and audio) and a second audio clip in that spot. Ripple delete and Close gap both result in instant display of the change and the ability to click on another clip.

 

Turned on duplicate frame markers; no difference.

 

i7 11700K 3.6GHz 8 Core 16MB RAM 64.0 GB
Windows 10
NVIDIA RTX 3070, 8GB VRAM, Studio Driver 536.23

 

Stan

 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Sep 19, 2023 Sep 19, 2023

Copy link to clipboard

Copied

Hi @ricardo_lacombe,

I got your message. I apologize that the community was unable to solve your issue. At this time, please contact assisted support directly to help you find a solution to this problem. The chat pod is in the lower-right corner of the screen there. Ask for the “video queue” to reach our digital video specialists. I hope they can help you. Let us know what they say so that the community can stay informed and help others having trouble with the same situation.

 

Thanks,
Kevin

Votes

Translate

Translate

Report

Report
New Here ,
Oct 10, 2023 Oct 10, 2023

Copy link to clipboard

Copied

I had this exact problem today and reverting to an older version of Premiere instantly fixed it. No more lag when ripple deleting.

 

System:

Win10

i9-9900K

RTX2080Ti

64Gb RAM

 

-

 

Could it be that this is only happening on Windows 10?

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 12, 2023 Oct 12, 2023

Copy link to clipboard

Copied

I'm having the same issue of long lags when ripple delete (and also on copy/paste) on 23.3+ and 24.0.  Reverted to 23.2 works smoother.

I'm on macOS 13.6 with an Intel Core i9 iMac 2020.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 15, 2023 Oct 15, 2023

Copy link to clipboard

Copied

Please someone get a fix to this that isn't "Revert to old version" I updated the latest 2023 version to the 2024 version of Premiere Pro and this issue started. It wasn't an issue yesterday and my projects are all updated already.

Votes

Translate

Translate

Report

Report
Community Expert ,
Oct 15, 2023 Oct 15, 2023

Copy link to clipboard

Copied

Adobe by default does not change the original (v2023) file, so you should have that available.

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

Can you elaborate on this please?  If I make a fresh project file in Premiere 2024 rather than updating an old projectfile it will fix the issue?

Votes

Translate

Translate

Report

Report
Community Expert ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

Yes, you said "my projects are all updated already." 

 

I assumed you meant you started them in pp2024, and now the projects are updated to 2024. 

 

Premiere does not update the original, but makes a new project with a new name. Thus you were implying you can't return to 2023. 

 

Unless you purposely saved that new file overwritting the original, the original is still on your disk and available to you.

 

Try starting PP with no project, (use the regular PP icon) while holding down shift, and delete the cache, even if you already have. Then start a new project in 2024, and use the File/Import command to import the original 2023 project.

 

Let us know.

 

 

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

Okay got it I see what you are saying.   Will holding down shift and deleting the cache delete any of my preferences too or just remove the cache files only?

Thank you

Votes

Translate

Translate

Report

Report
Community Expert ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

If you are ok with setting the prefs back to stock, it's a good idea.

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

That would be too much hassle.  Could I save them and then reset and bring them back in?

Would holding shift reset the preferences?

 

Votes

Translate

Translate

Report

Report
Community Expert ,
Oct 16, 2023 Oct 16, 2023

Copy link to clipboard

Copied

Holding Shift gives you the opportunity to delete prefs. You have to check the box and press <OK>

 

%UserProfile%\Documents\Adobe\Premiere Pro\

 

Make a copy of the above folder. Paste that into file explorer. Reset the prefs using SHIFT when you start PP, if it doesn't help, reset them by copying the saved folders back.

 

Sometimes I make a movie of the prefs screen in an app. Just quickly clicking from tab to tab, and then when I need to reset them, I have the 10sec movie to refer to.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 19, 2023 Oct 19, 2023

Copy link to clipboard

Copied

Here the same issue. And the created project don't open on previous releases.
Wonderful experience with a complete project locked for this problem.

Votes

Translate

Translate

Report

Report
Community Expert ,
Oct 19, 2023 Oct 19, 2023

Copy link to clipboard

Copied

Yes, 23.5 worked fine for me without any hang, both 23.6 and 24.0 hang all the time for me, but gladly, the latest Beta (24.1 B59) is working for the last 24 hours without a single crash. Give it a try and please confirm if it works for you too.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 22, 2023 Oct 22, 2023

Copy link to clipboard

Copied

I have the same problem, it only happens when working with longer videos. The program will freeze for around 10 seconds everytime I try to ripple delete on the timeline before unfreezing.

Votes

Translate

Translate

Report

Report
Participant ,
Oct 23, 2023 Oct 23, 2023

Copy link to clipboard

Copied

Expericed and posted about issues with the Q and W ripple delete. I asked if they changed the shortcut because it didn't seem to be working.

 

 

Votes

Translate

Translate

Report

Report
New Here ,
Oct 23, 2023 Oct 23, 2023

Copy link to clipboard

Copied

I have also been having this issue. And I can not seem to find any cause of this, I was editing the same footage that I always do, and yet in the same project it just started happening one day. Hope this bug can be fixed as it is extremely annoying having to wait 10 seconds in between every edit.

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 28, 2023 Oct 28, 2023

Copy link to clipboard

Copied

Also having the same exact issue. even in PP24

Votes

Translate

Translate

Report

Report