• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

Premiere Pro Mask breaks linear interpolation btwn keyframes during undo. Extra mask node is created

Community Beginner ,
Mar 29, 2024 Mar 29, 2024

Copy link to clipboard

Copied

Video showing the issue that occurs is attached.

 

To replicate:

On the current version of Premiere Pro (V24.3),

Create new mask with pen tool or use the rectangle/circle automatic masks.

Add a keyframe to the mask path. Go any amount of frames forward and add a new keyframe to mask path.

Go in between each keyframe and manually add a node point to the current mask.

Press undo once.

 

An extra mask node is still present on the later keyframe(s) while not present on the previous keyframe, causing the mask to not interpolate positions between keyframes.

For some reason, pressing undo twice sometimes (all the times?) fixes the issue, but this is still an annoying bug because it isn't obvious something broke until you scrub through the timeline and see the lack of interpolation. This is an even bigger issue when a mask has dozens of nodes, and all of a sudden one keyframe section is permanantly different compared to the other.

Bug Unresolved

Views

88

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
2 Comments
Community Expert ,
Mar 29, 2024 Mar 29, 2024

Copy link to clipboard

Copied

Yes, I can confirm the bug. Pressing undo twice never fixes the issue on my side. Win 10, Pr 24.3 B59.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 30, 2024 Mar 30, 2024

Copy link to clipboard

Copied

LATEST

I also want to note that I believe this bug has existed for at least 3 years

Votes

Translate

Translate

Report

Report