• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

SRT Export Only Works from Caption Menu

New Here ,
Aug 07, 2023 Aug 07, 2023

Copy link to clipboard

Copied

Our editors noticed and I confirmed than when using the File -> Export -> Captions option to export SRTs from a timeline we only get the first 15 seconds of the captions, but when we export from the "Caption" window tool - we do get the full length. The File menu option allows us to turn off styling tags, whereas the Caption window does not, so it would be nice to have it working.

Bug Unresolved
TOPICS
Export

Views

134

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
3 Comments
Community Expert ,
Aug 07, 2023 Aug 07, 2023

Copy link to clipboard

Copied

Very odd. I don't recall anyone else mentioning this.

 

I tested in PR 23.5.0. I used a simple sequence with one video, transcribed, and created captions. I exported srt using File -> Export -> Captions, with and without styling, Text Tab -> 3 dots menu -> Export srt; and File -> Export -> Media with sidecar set and no styling. The full 2:25 sequence and 321 captions were exported in each instance.

 

What version of PR are you running? Same OS etc or various? Are you running teams/productions or similar?

 

Stan

 

Votes

Translate

Translate

Report

Report
New Here ,
Aug 07, 2023 Aug 07, 2023

Copy link to clipboard

Copied

My test was on PR 23.5.0 using Ventura 13.4.1 from a project created on latest Windows PR.

If I create caption tracks from scratch, I do not have that issue. If I import and copy from the current project's sequence into a new sequence in a totally new project, I do not see the issue their either. It could be some issue with the project/sequence itself, and it happens oddly after 15s on any of the longer sequences.

I stripped it down to just one short sequence in a copy of the project (where I still see the issue) if you are interestedin seeing it live: https://file.io/y8EcFeAvfAYY

Votes

Translate

Translate

Report

Report
Community Expert ,
Aug 08, 2023 Aug 08, 2023

Copy link to clipboard

Copied

LATEST

Wow. Thanks for the project file. Nice demo of the issue.

 

I can duplicate this from your sequence. File -> Export -> Captions exports only through the caption that ends between 15 and 16 seconds (as you saved, 00:00:15,765); Text Tab -> 3 dots menu -> Export srt includes the whole caption track.

 

Some reported that a music note at the beginning and end of a caption creates some type of problem. I could not replicate, and that did not fix anything.

 

Move the captions to the beginning of the sequence changed which captions exported, but still stopped at the same time point. (caption ending now at 16,141).

 

Duplicate sequence, delete caption track, select all captions in the original sequence, paste to duplicate: exports correctly.

 

@Kevin-Monahan 

 

Stan

 

 

Votes

Translate

Translate

Report

Report