• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

Text bug, can't type "ff" with Verdana font

Community Beginner ,
Sep 07, 2023 Sep 07, 2023

Copy link to clipboard

Copied

Writing any word with two lowercase f's such as "affect" or "effect" while using the font Verdana causes the text to disappear. It's the client's choice, the font, but this is the wierdest bug I've ever seen. I've been able to simple create a space and insert a single "f" on another text layer within the clip to cover it up, but am baffled. Have fun with that one!

Bug Unresolved
TOPICS
Graphics , User experience or interface

Views

327

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
9 Comments
Adobe Employee ,
Sep 07, 2023 Sep 07, 2023

Copy link to clipboard

Copied

ff is a common ligature set, so fonts that support those ligatures, like Minion Pro, will show the f's attached. But with a font like Verdana there is no ligature support so it should just handle them like separate characters. And of course the text should not go blank. Can you make a new project with just one text layer (and nothing else) using a few of these common ligature sets? And then send me that project?

fb ff fh fi fj fk fl ft

ffb ffh ffi ffj ffk ffl fft ffy
tt ti tti tf ttf
Does the same problem happen with other ligature sets?
What happens if you switch to a ligature font like Minion or Lato?
What Pr version and OS are you using?

Thanks in advance for your cooperation.

Votes

Translate

Translate

Report

Report
New Here ,
Sep 13, 2023 Sep 13, 2023

Copy link to clipboard

Copied

I'm here because I ran into the same issue with Minion Pro. My workaround was to type "f <space> f", then kern the space out. Is there a better way to handle this?

Also, this doesn't happen in After Effects, Photoshop, or InDesign when using Minion Pro. So why does it happen in Essential Graphics? 

 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Sep 13, 2023 Sep 13, 2023

Copy link to clipboard

Copied

@59impalaboy Premiere Pro, Photoshop and After Effects all have checkboxes to turn Ligatures on or off. The default for that setting may vary by app. In PrPro, the Ligatures checkbox is found in the Text Properties (wrench menu) in the EGP > Edit tab.

TextPropsLigatures.png

@johnc32787989 's problem was different because in that case the font was Verdana which does not support ligatures and text was disappearing when ff was entered. John, I forgot about that checkbox last time we chatted about this. Does that make any difference for you?

Votes

Translate

Translate

Report

Report
New Here ,
Sep 13, 2023 Sep 13, 2023

Copy link to clipboard

Copied

Thank you for that info, very helpful. 

It would nice if this was a Preference setting rather than a per-graphic setting. It would save a lot of time.

 

Thanks again!

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Sep 13, 2023 Sep 13, 2023

Copy link to clipboard

Copied

That's a good request. Note that there is a global prefs setting for other things... At the top of the EGP, there is a hamburger menu and in that menu is "Text Layer Preferences". Ligatures would have to be added there.

Also note that you can check Ligatures on/off for multiple selected text layers in the same Graphic. That's still not as powerful as a global preference, but it might help save some time.

Votes

Translate

Translate

Report

Report
New Here ,
Sep 13, 2023 Sep 13, 2023

Copy link to clipboard

Copied

Honestly, I'm not a big fan of Essential Graphics and ususally do all my text graphics in After Effects.

 

Thanks again for your help.

Votes

Translate

Translate

Report

Report
Community Expert ,
Sep 13, 2023 Sep 13, 2023

Copy link to clipboard

Copied

@59impalaboy @jstrawn,

 

See my comments here:

https://community.adobe.com/t5/premiere-pro-discussions/adding-caption-crash-premiere/m-p/13071437#M...

 

There is a global setting for regular graphics, but only for those added after the change. And you can't just edit text in an existing layer.

 

I though there was a global setting for captions, but not so. I could not find a way for a new caption track to inherit a "no ligatures" style, and creating a caption track style does not include the ligature setting. But you set a whole track at a time.

 

Stan

 

 

 

Votes

Translate

Translate

Report

Report
Enthusiast ,
Sep 14, 2023 Sep 14, 2023

Copy link to clipboard

Copied

As a work-around, there is a "Pro" version of Verdana that contains ligatures. I believe it's available with some Windows installs, or from MyFonts.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Sep 14, 2023 Sep 14, 2023

Copy link to clipboard

Copied

LATEST

Thanks @Stan Jones, I had forgotten about that Ligatures checkbox in the Graphics preference. This is why we try to always listen to our customers... they often know more about our products than we do!

Votes

Translate

Translate

Report

Report