• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Two closed captioning bugs

Explorer ,
Mar 28, 2024 Mar 28, 2024

Copy link to clipboard

Copied

  • 2 Issues: 1 Premiere keeps deleting in/out points when captioning and in the latest release untranscribed parts all show the same weird text until I tell it to transcribe those parts
  • Version 24.3.0 (Build 59)
  • Mac OS Sonoma 14.4.1
  • MacBook Pro 18,2 model number Z14X000HSLL/A
    • M1 Max
    • 10 core M1 Max
    • 64 GB
    • 8 TB
  • Video format: both Sony MXF camera original and files converted ProRes 422
  • Workflow details: Standard sequence, 05/15/30/60 second commercials
  • Steps to reproduce –
  • Issue 1: assuming a pre created sequence with audio that needs closed captions.
  • Open captions and graphics panel
  • Transcribe sequence, I don’t use the auto function
  • Double click text in the newly transcribed captions to make a correction
  • This is the moment when Premiere deletes my in/out points in my sequence, note that this has been happening since at least the version of Premiere immediately preceding Version 24.3.0 (Build 59)
  • Issue 2:
  • assuming a pre created sequence with audio that needs closed captions.
  • Open captions and graphics panel
  • Untranscribed parts show some variation of the following:
  • “You eat me. In you eat. Me. In.”
  • Has happened 6 times today right after the update to Version 24.3.0 (Build 59)
  • Across 6 different sequences, again auto transcription is not enabled
  • Expected result – no deleted in/out points or the strange transcriptions in places that are not already transcribed
  • Actual result -  I have reset all in/out points and when transcribing the untranscribed parts those odd “eat me” parts are gone. Screenshots attached including the correct transcription.

 

Bug Unresolved
TOPICS
Editing and playback

Views

224

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
6 Comments
Community Expert ,
Mar 30, 2024 Mar 30, 2024

Copy link to clipboard

Copied

@Barry-KOMOTV,

 

Issue 1 is a function of the "Automatically set In/Out points." If you have this on, whether using it to set in/outpoints or setting them manually in the timeline, when you click in the transcript, it will remove them.

 

If you are not using it to set the in/out points, just turn it off. It is hard to see whether it is on or not. Even when unselected, the 2 curly brackets look lit up. The sign that it is selected is that the background around it is greyer than the rest of the background.

 

Issue 2 is very odd. I always clear the media cache when I do any updates, and I wonder if it could be something like that.

 

Are the untranscribed parts separate clips? Are there any audio-only elements? Do any of the transcribed/untranscribed clips overlap? Is "Untranscribed sources" checked in the "Transcript view options"?

 

@Kerstin Ebert @alexander-riss Any thoughts?

 

Stan

 

Votes

Translate

Translate

Report

Report
Explorer ,
Mar 30, 2024 Mar 30, 2024

Copy link to clipboard

Copied

I see what you mean with those brackets, and clicking it seems to have worked. I never consiously selected those, but this all started in the previous release when all projects started doing this. Thanks for helping!

 

As for the odd words, they were just audio clips attached to their video, interview type clips all on audio 1. There is no overlap. There is a music track on 4. The text was showed on any clips Premiere thought were untranscribed. They all were untranscribed, which was also odd as I dont use auto transcription. So it seemd like Premiere transcribed a few clips only, and randomly. I do all captions at once and thsi project had 6 30 second sequences. Untranscribed text may have been selected, I didn't check that and I just unselected everything in the options while trying to figure out what I mention next.

 

I am also trying to get Premiere to stop segmenting the transcriptions and go back to providing them in a single paragraph again. It used to just show everything in one paragraph which made it very easy to just copy my script from a Word doc and paste it over to fix errors and get correct capitalization and punctuation. Its harder when there are several paragraphs. Any suggestions on that? I do a ton of captions so small things add up in time and clicks and I just want to streamline thgings.

Votes

Translate

Translate

Report

Report
Community Expert ,
Mar 31, 2024 Mar 31, 2024

Copy link to clipboard

Copied

Excellent regarding Issue 1.

 

I'm going to assume that something got messed up and created the odd text/transcripted/untranscripted pattern.Restart PR, create a new, simple project. Do your regular process except for the "trying to get Premiere to stop segmenting the transcriptions", and see if the problem recurs.

 

A troubleshooting rule of thumb: PR does odd things = reset preferences. I prefer, in order until finding a fix, I would first reset the workspace being used ("Reset to saved layout"), and then reset preferences (unless you have a lot of customization). Then, if this was a project started in an earlier version of PR, I would create a new project and import the old project (or just select sequences), and then create a new project and rebuild.

 

I will make a separate post regarding how to work in a single paragraph for correcting transcriptions.

 

Stan

 

Votes

Translate

Translate

Report

Report
Community Expert ,
Mar 31, 2024 Mar 31, 2024

Copy link to clipboard

Copied

> copy my script from a Word doc and paste it over to fix errors and get correct capitalization and punctuation.

 

It's magic time! You can use the "Import corrected transcript" to import a full transcription that is formatted as a single paragraph. I have only done this for a single clip sequence, and not for production material. So let us know if you try this.

 

I just tested in 24.3.0 and Beta 24.4.0.30, and this is still working. You can actually use this to import your own transcript, or from srt captions etc. You CANNOT add more content, use descriptive subtitles/music notes, change the transcription timecodes, or modify speaker information.

 

"Import corrected transcript" works for either Source media transcripts or for static/sequence transcripts. If you have a 3 clip sequence with source media transcriptions, and you want to correct the transcripts, you must correct them in source media view for each of the 3 separately. If you are working with a static transcript of the sequence, you import the corrected transcription in sequence view.

 

Your clip or sequence MUST have a PR created transcript that you want to "correct," because PR must have its own timecodes and speaker designations. Neither of those are updated by any changes in the corrected transcript.

 

For round-tripping a PR transcript to correct, you can export the PR transcript (as .txt), and be certain that you do not change any of the formatting. Or I use a macro in Notepad++ to modify the file to be imported. Each sentence of text is followed by a space - no return. So the entire transcript is a single paragraph, with a single return (line ending) at the end. When you import this, PR applies its timing and speaker designations.

 

If you start with your own version, you modify it to be in that format.

 

The usual disclaimer holds for being sure that your Word document does not introduce invisible characters. I would "save as" a text document (.txt), then work in a text editor to reduce to the single paragraph-only format.

 

Stan

 

Votes

Translate

Translate

Report

Report
Explorer ,
Apr 03, 2024 Apr 03, 2024

Copy link to clipboard

Copied

Stan,

Thanks for the help with this. I tried what you layed out and nothing I do seems to work. Import corrected transcript (txt)... is always grayed out no matter what I do. I imagine I am missing a step here. But that said the entire process adds several new steps and a new file to this process which would take longer than just copying and pasting.

 

Premiere used to display captions in a single paragraph- most of the time, even for 60 second spots. Now it makes multiple paragraphs most of the time. And for the life of me I can’t see why Premiere decides to make paragraphs where it does, it seems random. So when that single paragraph was there this was a simple process- CMD TAB to Word, select and copy the paragraph, then CMD TAB back to Premiere and double click the paragraph then CMD A to select all and CMD V to paste in the text. It was fast. Now I am doing this for each paragraph and I see no way to force Premiere to stop this segmentation of the script translation.

 

And that is what I am looking for as I do this all the time. And I really do not want an additional text document in the mix for each spot. I use a single master copy of the script to work from. For example, the project that generated the odd text errors has 6 different 30 second spots, so that then makes 6 separate text files to manage which I do not want. I have 1 master script for each project and there is more text in there than just 1 script, including multiple scripts often of different lengths, client provided notes plus notes for onscreen graphics and video all in 1 central location.

Votes

Translate

Translate

Report

Report
Explorer ,
Apr 03, 2024 Apr 03, 2024

Copy link to clipboard

Copied

LATEST

Stan,

 

I have since rebooted everything and deleted preferences and this far the odd text has not returned as I created captions for 2 other projects. So hopefully this is resolved. Thanks for the help here as well.

 

Votes

Translate

Translate

Report

Report