• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Unrealistic performance issues because of audio

Community Beginner ,
Oct 31, 2023 Oct 31, 2023

Copy link to clipboard

Copied

Hello everyone! I tried to sum up the issue I'm experiencing as shortly as possible. Please help!

 

Step 1.: I make a project on my computer, import everything, start editing, it runs perfectly. No fps drop, smooth playback, everything starts playing 0.01 sec after pressing the play button.

 

Step 2.: I copy the full project to my other PC. I finish the edit there.

 

Step 3.: I copy the full project back to my original PC. Now playback is at a maximum of 2 fps, and there is a 20s delay after I press the play button, UNLESS I delete all the audio from the audio layers. If I do that than it plays perfectly. So I either have to edit without audio (out of the question), or without ever pressing the play button (even more out of the question). When scrubbing, it's as smooth as it can get.

 

Additional info: The projects are made of roughly 500 GB of footage (h265 s-log3 4k 60fps and 30fps), but I use proxies (medium quality, h264). Yes, I copy the proxies as well. I tried partially deleting the audio, the performance issue disappears only if more than 80% of all audio is deleted from the timeline. I use the same Premiere Pro versions on both PC-s. I tried multiple versions as well. Windows 10.

 

I don't believe hardware specs are relevant here, but here we go:

PC 1: Ryzen 7 3700x, 32GB 3000Mhz RAM, Radeon 6700XT, I edit from HDD

PC 2: Asus ROG Gaming Laptop, intel i7-13650HX, 16GB RAM, nvidia RTX 4050, I edit from external HDD

Bug Unresolved
TOPICS
Editing and playback , Performance or Stability , Projects or collaboration , Sound

Views

190

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
6 Comments
Adobe Employee ,
Oct 31, 2023 Oct 31, 2023

Copy link to clipboard

Copied

This is a strange issue, I can make a few guesses that might help.
Try setting "Preferences>Audio Hardware>Default Input..." to "No Input" and see if that helps.

 

If that doesn't help, you should try deleting the media cache.  Hold "Shift" key when launching premiere snd select the option to delete the media cache.  Premiere will need to rebuild it for the current project, but it might help.

Please let us know if either of the above helps or not.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 31, 2023 Oct 31, 2023

Copy link to clipboard

Copied

Thanks for the quick answer!
I tried the first method, but unfortunately it made no difference.
I have also tried resetting my plugin caches (SHIFT+Launch), but had the same results.

Tried deleting all my audio peak files (so that Premiere has to regenerate them), media cache files and temporary files. No success.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 31, 2023 Oct 31, 2023

Copy link to clipboard

Copied

Can you post screen shots of Audio Hardware, Playback, and Media Cache preference pages from the computer that is having the issue?

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 01, 2023 Nov 01, 2023

Copy link to clipboard

Copied

Artboard 1.jpg

I have made screenshots for both affected PC-s, since the issue works back and forth as well, but the main PC is #01. I have tried different Latency values, from 30 ms to 500 ms, but it didn't do do anything to solve the issue.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 01, 2023 Nov 01, 2023

Copy link to clipboard

Copied

In the meanwhile I have managed to make some progress with the investigation. I don't think the issue is cache related.

I opened a project, selected all the audio from all the layers and did the following: right click - Remove Attributes - Effects (I always use Hard Limiter, Denoise, Lowpass) and clicked on Ok. It works perfectly after doing this. No playback delay.

Obviously, this is not ideal, I do need these effects. I tried narrowing it down to one, but it seems like it's not a particular sound effect that's causing the issue, but the quantity of them.

Overall this is still pretty weird, because it doesn't matter how many sound effects do I use, if I skip copying the project to another PC and back (Step 2 and 3), it has no impact on performance.

I could do a 'Render and replace' with all the audio selected, but than all of my fade transitions would be ruined and needed to be redone. Also not very ideal for 5 hour long projects with hundreds of clips.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 01, 2023 Nov 01, 2023

Copy link to clipboard

Copied

LATEST

Ok, that is good information.

Your set up looks all good, and you have the system running as you should.  

About the audio effects:  Audio effects use lot of CPU, as they always need to run in real time.  Each time you add an effect to a clip, it takes a little processing power away from the rest of the system.  Eventually, you just run out of processing power. 

 

I am assuming that the audio effects are added in the edit phase, when you are working on the faster Intel machine?  You might be hitting a two fold problem.  The Intel machine is just faster and has more cores to farm out CPU work and isn’t slowing down.  AND the intel machine has more GPU accretion for decoding the formats you are working with (HEVC and H264), so the video decoding is using the CPU and you are stressing the Ryzen system more with CPU video decode and realtime audio effects rendering.  I’m not 100 percent sure though and can only make a guess.


Here are a couple things you might try:

 

Toggle the setting “Preferences>Audio>”Use legacy audio effect playback pre-roll” on the machine that cannot playback.  Turning this on will cause Premiere to take longer to start playback when there are lots of audio effects running, but might reduce som e of the overhead.

 

You can consider organizing your project a little differently.  Each clip based audio effect will use some CPU, and with hundred of clips you can quickly start to eat up available CPU.  In Premiere, you can also use Track based audio effect.  And each clip on a track will run through that one instance of the audio effect.  This can save a ton of processing overhead, but you need to organize the project a little more cleanly.  For instance, you will want to dedicate a single track for all the dialog/voice from a specific person, and add audio effects to the Track in the Track Mixer.  All the clips will be processed using the same settings from the Track based effect.

 

Lastly, the Hard Limiter effects uses a lot more processing when you turn on the setting “True Peak” in the effect UI.  You really don’t need that setting turned on, and I would council you to not use a hard limiter on each clip anyway, and use strictly as a track effect, or only on the mix bus.

 

The above is just some things to try, and no single factor will probably fix this.

Votes

Translate

Translate

Report

Report