Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Avoid thin line around exported videos?

Engaged ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

Hi,

I keep getting a thin grey line around exported mp4 videos. This is what I do:

 

  1. I have an ordinary video in Premiere.
  2. On a track below it, I have a solid white image that is larger than the video in order to create a white frame around the video.
  3. When I export the video, including the white frame, there's an unwanted grey line around the white frame.

 

It is only visible in some applications, on white background, and only at some zoom settings, but it's there, so it can't be used for my purposes.

 

I tried replacing the white background image with a white color matte, but I still get the error. Frame size is set to the exact size of the white background.

 

The problem may be that mp4's don't have alpha channels.

 

So I've looked at alternatives, like exporting as Quicktime/Animation which does have an alpha option.

 

But I need an mp4 for the end result, and the only way I know to convert .mov > mp4 is using Adobe's online service, which will take a long time because the videos are around 8k. Plus, the resulting videos will obviously be degraded, too.

 

It would be great if anyone had any suggestions...

TOPICS
Error or problem, Export

Views

107

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Engaged , Oct 22, 2021 Oct 22, 2021
Latest report about the Thin Line Drama  I found what I, until further notice, believe might be the answer in this thread: https://community.adobe.com/t5/premiere-pro-discussions/mysterious-black-line-appears-after-render/td-p/9554246 According to Jim_Simon "MPEG needs dimensions evenly divisible by 8". Now, MPEG and mp4 are not the exact same, but I gave it a shot -- and the line completely and instantly disappeared for the first time, when I changed both horizontal and vertical frame size to ...

Likes

Translate

Translate
Engaged ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

Found a solution:

 

If I reduce the frame size with 5 pixels -- not 3 or 4, but 5 -- (both width and height), the line disappears!

 

In other words, Premiere's frame size needs to be smaller than a white image to avoid thin lines around it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

Okay, what I hoped were the solution turned out not to work after all:

 

Exported frames did not have the lines -- but the exported video unfortunately did.

 

So, back to square one...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

Exporting as Quicktime/Animation w/ alpha channel doeesn't work either: There's still a thin line, now at the right side of the movie...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

Hi sebastian2012a,

 

Sorry about the poor experience. Please share a screenshot of the exported video that has that thin line. Also, have you tried switching the Renderer to Mercury Playback Engine Software Only & checked if it's exporting properly?

 

Thanks,

Sumeet

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

Dear Sumeet,

Thank you very much for your reply -- I can't share screenshots as it's work for hire, but I would think the issue is pretty easy to reproduce:

 

Simply place, say, a 4k video on a larger white background (still/matte), set the frame size to that of the background and export. There will be lines.

 

But again, they are only visible in apps or on websites that have a white background, and at some zoom settings they are quite hard to see. Which I guess is why most people will never notice them.

 

On the bright side, after exporting a lot of short test sequences it seems that reducing both heigh and width by 9 pixels each (for an approx 6,000 x 6,000 frame) does remove the lines.

 

So a work-around might be to make the white background a bit larger to compensate for later reductions.

 

As for the engine, I've switched between CUDA and software only, but it didn't make a difference.

 

I'm currently rendering a full video and will report back when I've got the results...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

I can confirm that reducing frame size by 9 pixels, both height and width, for an approx 6,000 x 6000 video solves this issue.

 

So, that's actually semi-great after a very long day of experiments... 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

Hey Sebastian,

Glad you figured it out. Curious, though. Why would you need a 6K by 6K image? That's the odd thing to me. 🙂

 

Regards, 
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

Haha, thank you, good question: I'm making NFTs, which are often displayed in weird aspect ratios on white backgrounds in various marketplaces -- and end users sometimes expect high resolution files for private galleries, and such...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

Sorry to keep posting about this, but it turns out that the assumed solution only worked on two videos (which have almost the same size).

 

I'm now having the exact same issue with another video which is around 4,000 x 8,000 pixels, and no matter how much I change the frame size, that darn line, or lines, still appear in various sizes.

 

It's only visible when the video is displayed at 25% or more of its original size.

 

Just to see what happened, I tried to crop a bit off of the white background and, as expected, that made the lines much wider. So in order to do the opposite, I tried to scale up the white background image to get past whatever is causing the lines to appear, but that didn't change anything. Which in itself is a little peculiar, I think, because it seems to imply that the line isn't the black background sort of shining through, but perhaps caused by the rendering process itself. And then I don't think there's any solution.

 

What I really don't understand is why changing the frame size worked for the two first videos, but not for this...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

Another weird thing: If I reduce the frame size by more than 25 pixels, the line gets thicker.

 

I don't get it...

 

Perhaps there's a specific 'magic' amount of reduction that works for each aspect ratio, and perhaps I just happened to find that by chance for the first two videos.

 

Right now, I can't think of anything other than try to reduce frame size in tiny increments and hope one of them will work.

 

I don't think I mentioned that there are no lines when I use the Export frame option.

 

So, I could actually manually export each frame and import them as a sequence. There are less than a thousand frames per video so it would take less time than trying all these settings. Only thing is that Premiere might add that line again when rendering the imported sequence, since there's still that white frame around each still. And the quality is also lower; each single-exported frame is around 7mb, while each 'real' video frame is around 11mb.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 22, 2021 Oct 22, 2021

Copy link to clipboard

Copied

LATEST

Latest report about the Thin Line Drama 🙂

 

I found what I, until further notice, believe might be the answer in this thread: https://community.adobe.com/t5/premiere-pro-discussions/mysterious-black-line-appears-after-render/t...

 

According to Jim_Simon "MPEG needs dimensions evenly divisible by 8".

 

Now, MPEG and mp4 are not the exact same, but I gave it a shot -- and the line completely and instantly disappeared for the first time, when I changed both horizontal and vertical frame size to numbers that are evenly divisibly by 8 (which I'm embarrassed to say took too many attempts... 🙂

 

So, here's to hoping after a very, very long day... 🙂

 

EDIT: After uploading test video to various sites, things still look great. Wow, division by 8... 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines