Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


BRAW 2.1 does not allow metadata editing in Premiere

Community Beginner ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

I just updated both BRAW (to version 2.1) and Premiere (to version 15.2) and the raw tab in premiere no longer works. It says I'm using an outdated version of Premiere and need to update to version 15.4 - but I'm running 15.2, which is the most recent version. Curious if anyone else is running into this issue? Unclear if this is a mistake or if BRAW really won't work properly in Premiere until ver 15.4?

TOPICS
Editing, Error or problem, Formats

Views

252

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jun 25, 2021 Jun 25, 2021
Gharkawik, Sounds like the BMD plug-in is not yet supported for the current version of Premiere Pro. Try it in Premiere Pro Beta. That should work. Otherwise, you'll need to take up the issue with BMD since the format is not yet officially supported by Adobe. It's only accessible via plug-ins. Sorry. Thanks, Kevin

Likes

Translate

Translate
Adobe Employee ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

Gharkawik,

Sounds like the BMD plug-in is not yet supported for the current version of Premiere Pro. Try it in Premiere Pro Beta. That should work. Otherwise, you'll need to take up the issue with BMD since the format is not yet officially supported by Adobe. It's only accessible via plug-ins. Sorry.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 26, 2021 Jun 26, 2021

Copy link to clipboard

Copied

LATEST

Hi, I installed 2.1 and it works nicely with the beta version of Premiere Pro (15.4). I'm sure once Premiere Pro officially releases 15.4 the new update of the BRAW plug-in will work just as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines