Does Premiere CC2018 fix "wrong LUT problem"?

Participant ,
Apr 30, 2018 Apr 30, 2018

Copy link to clipboard

Copied

In Premiere CC 2017 if you apply a LUT from the creative folder, then add new LUTs to the creative folder and re-open your project, you get the wrong LUT.

In addition in Premiere CC 2017 if a colleague sends a project to you and he has different LUTs installed, when you open the project you'll get the wrong LUT (a random one, because Premiere uses a simply numeric array: that's so stupid).

I read something about this problem in the change log of CC 2018. So my question is: are LUTs now consistent in CC2018?

Did they fix this HUGE problem? Please don't tell me to apply LUT using "browse" because to be able to see the preview of the LUT inside Premiere is very important

The problem is here since CC 2016!!

Thanks

Alberto

Views

1.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , May 03, 2018 May 03, 2018
Ah, here is the cool part.  LUTs that are stored in these folders will get embedded into the project file when you use them.  So you can share the project with a colleague and all the LUTs will be present and be functioning for them even if they don't have the specific LUTs installed.  It will not install these LUTs onto the other person's system for them to use on additional clips, however.  It is therefore recommended that you send them the LUT with instructions on how to install it onto their...

Likes

Translate

Translate
May 03, 2018 May 03, 2018

Copy link to clipboard

Copied

Hi Alberto,

Did they fix this HUGE problem?

In Premiere Pro CC v12.1 & v12.1.1 you can now install custom LUT files & have them appear in the Lumetri Color panel. Premiere Pro scans the folders at launch and loads LUT files from these directories.

More information here.

Thanks,

Kulpreet Singh

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 03, 2018 May 03, 2018

Copy link to clipboard

Copied

Thank you. So now if I'm editing on 2 computers with different LUT installed, if a LUT is used and installed in both computers, I'll find it opening the project on both computers?

This was not working on previous versions. Please could you double check this? I would like to be sure before upgrading.

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 03, 2018 May 03, 2018

Copy link to clipboard

Copied

The problems you were experiencing before were caused by tampering with the LUTs within the application package - please do not do this. It was never advised or supported by Adobe engineers. This was never a bug on our end.  I know that there are several very official looking tutorials and instructions out there that tell you to do this, but it's still wrong and causes many problems. But we understand why people were doing this hack and we addressed that underlying workflow problem with a new feature that was introduced in 12.1.0.

Before you upgrade you should go into the application package and save your LUTs into another location for safe keeping.  When you upgrade those LUTs will be deleted because they are inside the application package.

Then upgrade to 12.1.1 and install your saved LUTs into the directories explained below.

But there is a big problem you are likely to run into - LUTs that have been applied in previous projects when you were using the hacked application package method will almost certainly have the wrong LUTs applied after you upgrade.  I'm very sorry to say that there is no automatic fix for this.  You will need to go through every clip in your project and reapply the correct LUT.  Using the method explained below will be future proof and you should never have to do this again.

Mac

  1. From the finder, use the Go menu to navigate to this directory: ~/Library/Application Support/Adobe/Common/
  2. Create a folder named LUTs
  3. Create two more folders inside the LUTs folder: Technical and Creative
  4. Copy technical conversion LUTs (often called camera LUTs) such as LOG to Rec709 into the Technical folder
  5. Copy creative LUTs such as day-for-night, B&W, or anything that is just a stylistic look into the Creative folder
  6. Restart PPro
  7. Technical LUTs show up in the Input LUT dropdown inside the Basic section in Lumetri
  8. Creative LUTs show up in the Look dropdown inside the Creative section in Lumetri

Windows equivalent directories:

~\AppData\Roaming\Adobe\Common\LUTs\Technical

~\AppData\Roaming\Adobe\Common\LUTs\Creative

This is a convenient and easy way to add as many LUTs as you like to the Lumetri dropdown menus and this will persist through updates - unless of course you delete or change this directory.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 03, 2018 May 03, 2018

Copy link to clipboard

Copied

Thank you franciscrossman!

But there is a big problem you are likely to run into - LUTs that have been applied in previous projects when you were using the hacked application package method will almost certainly have the wrong LUTs applied after you upgrade.

Yeah, I know, but I'm already getting this problem when I send a project to a colleague or when I install new LUT or when I upgrade to the next version of CC.

Good to know about the new approach (new LUTs folder). But still I have a question: what will happen on CC 12.1.0 when I'll send a project to a colleague? If he has a lut with the same name, it will be applied correctly, even if he has also other LUTs installed?

Thank you

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 03, 2018 May 03, 2018

Copy link to clipboard

Copied

Ah, here is the cool part.  LUTs that are stored in these folders will get embedded into the project file when you use them.  So you can share the project with a colleague and all the LUTs will be present and be functioning for them even if they don't have the specific LUTs installed.  It will not install these LUTs onto the other person's system for them to use on additional clips, however.  It is therefore recommended that you send them the LUT with instructions on how to install it onto their system.  Hope this helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
May 04, 2018 May 04, 2018

Copy link to clipboard

Copied

Wow francis!! This is amazing. Thank you a lot.

Nice feature. I think I'll love it if it works as you described.

So if I send a project with a LUT on an adjustment layer, my colleague can extend that adj above other clips or just copy and past a Lumetri color effect that has the LUT? Will the LUT be applied to other clips in these ways even if he hasn't the LUT?

Thanks

Alberto

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 06, 2018 May 06, 2018

Copy link to clipboard

Copied

Yes, that will work. I'm happy to help

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 06, 2018 May 06, 2018

Copy link to clipboard

Copied

And if you have a Library you store your LUTs in, anyone you give access to that Library has full access to those LUTs.

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 03, 2018 May 03, 2018

Copy link to clipboard

Copied

Past Francis' excellent comments, and from comments at NAB, I think he's one of the people behind the welcomed change ... you can store LUTs and Looks in Library folders. If your Library is shared to other folks in your company and/or project, then they can also have access to them.

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 22, 2021 Nov 22, 2021

Copy link to clipboard

Copied

I INSTALLED MY CORRCTLY. This is complete crap I put them in the technical and creative folder and I still get this issue this is a major flaw causing me now days and weeks as a traveling editor from my windows AND mac. I AM KEAVING YOU ADOBE. IS THERE AND ACTUAL FIX OR NOT. I NSTALLED EXACTLY AS YOU SAY AND I CAN PROVE IT DOES NOT WORK. driving me insane over here i make custom looks and do music videos alot of effects are based off of color and i am so pissed right now. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 22, 2021 Nov 22, 2021

Copy link to clipboard

Copied

I have never heard of anyone having issues if the LUTs are not in the program/package folders. Not one user.

 

So ... which folder tree are you using? As from your post, it doesn't matter if you're in the Technical and Creative folders if you're in the wrong folder location.

 

So ... a screen grab of the finder/explorer window showing the navigation to the folder would be most helpful.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 23, 2021 Nov 23, 2021

Copy link to clipboard

Copied

Example of my technical file path for mac. literally the creative AND technical both from my windows to mac are insane they are always mismatch definetly didnt wtch my confrence footage MONOCHROMATIC and I know for a fact landed the perfect color grade which I spent 6HOURS REBUILDING yesterday wasting my life away. Please let me know if I am missing somthing or wrong here. This happens on my windows as well. In program files.

Screen Shot 2021-11-23 at 10.33.44 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 23, 2021 Nov 23, 2021

Copy link to clipboard

Copied

No, that is not the place for you as a user, to add or remove LUTs. That is inside the Premiere Pro program/package files LUT folder, which again is accessed by relative position in the folder NOT by name!

 

Premiere, Ae, and Me all are installed with the exact same contents in those folders, and by design (for some reason I don't understand) access items in those folders by relative position in the folder when applied via the Basic and Creative tab LUT options. And so applying LUTs, if you've added things in to those folders, gets messed up royally.

 

Add a LUT named "Davids Deep Reds" to the Pr/LUTs Creative folder.  Use it on a clip in a project. In prep for another project, add a LUT called "Antwerp Green" to the same folder. Apply that.

 

Now relaunch Premiere, and go back to the first project. "Davids Deep Reds" is no longer the LUT being applied, because it is now one LUT 'farther' down the list of alphanumeric sorting. This is not the behavior any of us wants. But it is so easy to avoid.

 

And across the tons of complaints I've seen about Pr and Me messing up in applying LUTs, it is nearly always because people have put LUTs in the Pr/LUTs folder. And not in the places the chart below shows.

 

The following chart shows the locations that users should be using. As noted, Pr will scan for these folders at launch and load into it's short-term memory anything found there. And they will apply the LUTs in these folders based on the name of the LUT, not by place in the sorted folder. So you can add and remove LUTs and as long as the needed LUT is there, it will still be applied correctly.

 

For some also unknown reason ... which I have complained about in emails, this forum, and in person at every live NAB and MAX since they started this system ... they don't create all the folders for the users to use in the proper 'tree' structure. No user gets a Technical or Creative LUT folder on installation ... you always have to create those before adding your LUTs into them.

 

But some users, mostly to the Mac side but not entirely, for some unknown reason, don't even get the LUTs folder added by installation of Pr. So they have to add in the LUTs folder, then the Technical & Creative, then drop their LUTs in those folders.

 

Well, silly yes, but still it takes a few seconds to fix one time. And then works forever. I did this several years ago, and have not needed to change anything since. I park my LUTs in the Users/username/Appdata/Roaming/Adobe/Common/LUTs folders. Just 'cause when I started with this, that seemed easiest.

 

Now, really, the Program Files/Adobe/Common/LUTs folder is easier to get to, and the one I typically recommend. Either works. I have icons on the desktop for quick access to those folders for adding or removing LUTs.

 

Just avoid the Premiere Pro folder like the plague. Or ... it will feel like it.

 

Really, to me a far bigger problem with their LUT application is that when you create and add a LUT to the app, you have to close Premiere and relaunch before you can use it. They don't have any "refresh" feature which most apps do. They should, and I've also complained about that.

 

Neil

 

Lumetri LUTs Looks Findable Locations.PNG

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 24, 2021 Nov 24, 2021

Copy link to clipboard

Copied

LATEST

Neil you are a godsend!

 
I moved over to mac and then suped up my windows with a custom build and then dealing with a full reset (as we have to do at times with windows when the blue screen if death happens) I feel like I was doing it correctly at first like you said in actually creating the folders myself, this time around I didn't!  because I watched so many videos on it back in the day I totally wiped that from my brain in being the process thinking I had it right. For the M1 chip mac and reassociation to OS  I don't know their backend as well so just as a 90's button masher does found my way there. Thank you so much for letting me know! I thought I was going crazy over here. I will make sure to re-install fresh to get whatever customizations done wiped then MAKE sure I'm not going full blonde on the backend as I have done and create the proper folders for that in the right spot! LOL 
 
Don't get me started, I agree about the refresh as well as the mogert system they have being kinda wonky and the freaking AE rotoscope brush 2 (at the time of writing this) just CRASH and BURNING on the M1 chip mac - also if your curious CONFIRMED from Reg Giant support themselves saying NO they do not work with Mac M1 if anyone is curious or racking their brains on that one. 
 
Thank you so much again for taking the time out to help and follow up on this, much appreciated!
 
Best,
 
Hope Taylor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines