• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
6

Dynamic link Issue, broken, not working Adobe Premiere Pro 2022 (WITH SOLUTION)

Community Beginner ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Adobe had a new major update of their softwares (Adobe Premiere Pro 2022, AE 2022 and Media Encoder 2022)

 

After this update I got a major problem that freezed Adobe Premiere with After Effects comp (Dynamic Link not working) 

 

You can find some solutions here :
https://community.adobe.com/t5/premiere-pro-discussions/dynamic-link-broken-with-premiere-cc2020-upd...

 

Unfortunately none of them worked for me, probably because I'm on a Mac.

 

So here what I've done that worked for me.

 

First some context. 
Computer : Macbook Pro M1
Adobe Premiere Pro 2021 project with After effects 2021 Animations and sounds integrated with Dynamic Link.

 

After the update to 2022 versions, opening Adobe Premiere will freeze AE animations, will load indefinitely, or simply crash (need to force quit)

 

Solution
1- Quit all the apps

 

2- Kill the Dynamic link manager from Activity Monitor. Search for dynamiclinkmanager, click on it and then on the cross button to close / quit the app (this one is important)

 

3- Open finder then go to documents > Adobe and rename the folder dynamiclinkmediaserver to dynamiclinkmediaserver OLD (this step seems working on windows)

 

4- In finder open libraries (click on GO located on the top menu, click on alt button on keyboard) once in libraires > Application Support > Adobe and rename the folder dynamiclinkmediaserver to dynamiclinkmediaserver OLD

 

5- Turn off your mac and boot it.

 

6- Open Adobe Premiere and create a new project. Do not open the original project!

 

7- Click on file > import > entire project (choose your old project 2021, 2019 whatever)


The loading process may take longer than usual, it seems there's a conversion process from old to 2022

For me I had to do all these steps. I tried without step 3, 4 or 7 it didn't work. Not my first battle with buggy Adobe stuff.

 

Hopes it will help. Sorry for the mistakes, English is not my native language.

 

Wish you all the best from the Alps 🙂

 

Adam

TOPICS
Crash , Error or problem , Freeze or hang , How to

Views

27.7K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Nov 05, 2021 Nov 05, 2021

My original solution was a little off, but it looks like you guys are finding it. You neeed to go to AE Preferences, Memory & Perfromance tab, an UNCHECK "Enable Multi-Frame Rendering". I misstated it earlier. 

Votes

Translate

Translate
Community Beginner ,
Jan 11, 2022 Jan 11, 2022

Copy link to clipboard

Copied

This worked for me on Premiere 22.1.2/AE 22.1.1 Thank You! All of the other solutions weren't working(although I did disable multiframe rendering on AE as well)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Jan 11, 2022 Jan 11, 2022

Copy link to clipboard

Copied

Thank you for responding and helping many millions of users on iMac. I have no problems on Win 11. My respects. If Kevin is here, please check what is on your car and whether it is suitable for recommendation to the whole community.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 26, 2023 Jan 26, 2023

Copy link to clipboard

Copied

Simply quiting Premiere and AE and restarting works every time foe me.    I shouldn't have to do that and it leads to a lot of wasted time. Nothing else listed here works for me.  I've had multiframe off for months, doesn't help.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 27, 2023 Jan 27, 2023

Copy link to clipboard

Copied

LATEST

One more thing, quitting dynamiclinkserver in Activity Monitor (in Utilities folder) on Mac, fixes the linking process for me, WITHOUT having to restart.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines