Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Dynamic Link not connecting between Pr and AE

Community Beginner ,
Nov 06, 2021 Nov 06, 2021

Copy link to clipboard

Copied

I have been having an on/off issue with Premiere and Dynamic Link recently, and it has just happened again, seemingly randomly.

If I try to import an AE project sequence into Premiere via Dynamic Link - either by direct importing, using Media Browser or File>Dynamic Link, then it will only allow import IF that project is open in After Effects.

 

If I try to import a sequence from another AE project that isn't open then it wont connect and if I try, it just makes Premiere hang, then crash. 


This is extrememly frustrating as I often have projects that link to multiple AF projects. 

Is is a bug that needs fixing or is there something I am not doing??

 

Thanks

James

TOPICS
Crash, Effects and Titles, Error or problem, Freeze or hang, Import

Views

91

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 06, 2021 Nov 06, 2021

Copy link to clipboard

Copied

Note: I'm using brand new updated CC 2022. However I have had this issue randomly for the last year or so in previous version.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 06, 2021 Nov 06, 2021

Copy link to clipboard

Copied

Did you check the FAQs for this forum? There's one there about an issue with Pr/Ae in Dynamic link if the multi-frame rendering in Ae is turned on. That might be the issue. They are working on a fix but it ain't out yet.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

Hi Neil.

I checked this out and turned off multi-frame rendering. Same issue happens. The linked AE clips inside my Premiere timeline just show "media pending" and wont connect. If I try to relink it, Premiere crashes. I have to make sure the specific AE project is open before opening Premiere, then the clips are linked. I have many Premiere projects where I have 2-3 different AE graphics projects dynamic linked so this will be untanable. 

 

Anything else I can try??
Thanks

 

James

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

Hi,

I have de same problem... no answers yet...

Pablo

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

If the multi-frame rendering off doesn't fix your ills, then ... at least it sounds like if you open Ae first and the comps you can work. Some are not able to.

 

And we'll just have to wait for a fix if you need to finish a project in 2022. For others, work in the 2021 version if having this issue with 2022 until they get it sorted.

 

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

LATEST

Obvious question but needs answering: Did you attempt to save both the Ae and Pr projects while Ae was open and everything was linked? I'm not sure you can get away with versioning the Ae project in this scenario, but I would certainly version the Pr project.

If that doesn't work, try creating a new project in Pr and importing the old one into it. Try it with Ae open and closed, with things linked or unlinked, to cover all your bases.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

Same issue here with the Apple Silicon version, also experiencing frequent crashes.

Best,
Leo

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines