EXPORT VIDEO GLITCHES IN LATEST PREMIERE PRO 2018

New Here ,
Apr 13, 2018 Apr 13, 2018

Copy link to clipboard

Copied

When I export media at a higher quality, after selecting preset Vimeo 1080 then selecting attributes like VBR,2 pass, render at maximum depth and use maximum render quality I get a few frames that have glitches, weird colour changes? SEE attached pics.

So in the images below the good image on top is preset Vimeo 1080, the second mage below it is preset Vimeo 1080 plus all the other higher quality attributes mentioned above!

It doesn't happen if i just select a preset by itself like Vimeo 1080 and none of the other attributes mentioned above...so whats causing this?GLITCH1.jpgGLITCH2.jpg

Views

10.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Apr 13, 2018 Apr 13, 2018

Copy link to clipboard

Copied

Bug confirmed

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 14, 2018 Apr 14, 2018

Copy link to clipboard

Copied

what does that mean Bug confirmed?...how does that fix the problem?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 14, 2018 Apr 14, 2018

Copy link to clipboard

Copied

Don't use those options unless you have to. Is there a specific reason you need those? Doubtful, personally.

If you have a GPU, don't bother with Max Bit Depth ... ever. It's supposedly over-ridden with GPU's, but occasionally when people have it checked, they get weird stuff. Don't know why.

Maximum Render Quality ... if you're doing a lot of resizing media on the timeline, can occasionally be of help. Otherwise, it's not. And yes, it can occasionally create glitches also.

2-pass processing ... very rarely is that of any use, and it does significantly slow down exports. Again, only use that option if for some reason your export otherwise isn't useful.

And really ... exporting for Vimeo, none of those three (even if visibly useful in a pro-monitor setup) will be noticed by the users.

So ... just don't use them. I doubt any of them is of any use to your export.

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Apr 15, 2018 Apr 15, 2018

Copy link to clipboard

Copied

With my answer I just wanted to say that I think your problem depents on a bug and that there will be no fix unless the program is fixed at that point. The "solution" in this case is just to do it another way. I think the thoughts of Neil Haugen are helpful.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 01, 2018 Jul 01, 2018

Copy link to clipboard

Copied

Has there been a fix to this issue?I have been experiencing this problem in all my exported files lately and do not know what is the cause. Side note: my video exports require a 2-pass and export at maximum depth.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 01, 2018 Jul 01, 2018

Copy link to clipboard

Copied

Why do they require 2-pass and max depth?

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 08, 2018 Jul 08, 2018

Copy link to clipboard

Copied

I'm having the same issue as well. After finding out how to export videos with a higher quality, I was bummed to find these purple glitches and I'm having slowed down shots. I hope Adobe fixes these bugs soon, because the quality just isn't all that great after uploading the videos to YouTube. Defeats the whole purpose of shooting HD.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 08, 2018 Jul 08, 2018

Copy link to clipboard

Copied

How are you setting for "exporting at higher quality" to get that?

The two things that mainly affect quality of exported video files are frame-size (so it's not viewed up-scaled after export) and bit-rate of the export. 1080 or up frame-size takes care of that, and bit-rate helps up to a point, then becomes extraneous file size.

Neither causes any issue for the file for quality however.

IF you are referring to Max Render Q and Max Bit Depth, well ... both are off by default for a reason. They only help in a very few situations, and can cause issues at other times. And they will probably increase render time. Neither will do anything to increase quality for a YouTube upload that I can think of.

Here's a link to the export options ...

Understanding render options in Adobe Premiere Pro - Blog - Digital Rebellion

And note, it starts with the following ...

Adobe Premiere Pro's export dialog features several rendering options that are not widely understood. All of them are switched off by default because they either degrade quality or increase rendering times, however they can all be useful in particular situations.

Max bit depth is useful if you're doing a lot of 32-bit specialized work in the export, or are getting banding, and need the extra precision, although if you have a usable GPU anything you can get from this of assistance is probably already being done and this doesn't help. It can (in my experience) induce artifacts and weirdness.

Max Render is only related to resizing, doesn't help on anything else, and yes, in my experience, can cause artifacting and weird stuff.

Also, these were created back in a time when most computers did not have a GPU really as a separate partner in the processing chain. Now that many laptops even have a significant installed GPU, they are of some use in some laptops, but not in most desktops.

Especially when doing exports for Vimeo/YouTube.

I leave them both off all the time, and have no trouble whatever with any exports, let alone ones for internet viewing. And I'm a picky sot.

So ... what really is your problem for YouTube/Vimeo uploads that you're trying to fix?

Do you have a monitor that is properly calibrated for sRGB/Rec709 work? Do you know what your monitor is set for? Do you understand color spaces and device 'screens'?

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 09, 2018 Jul 09, 2018

Copy link to clipboard

Copied

I'm trying to fix the purple glitches. I found a guide on YouTube how to export HD 1080p videos for YouTube, and the results were much different than what I was doing before. I exported with a higher max bit rate and under CBR and got a cleaner, better quality video. Anything less shows fuzzier pixels. Which is fine at this point, because I don't think anyone cares. Either way, I decided to leave rendering at a high bit rate checked off and the purple glitches are gone. I also turned down the bitrate. The glitches popped up over certain transitions, and I needed them. My iMac is much older so maybe it can't process this information properly, so I'm going to avoid anything "fancy" until I get an upgrade.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 09, 2018 Jul 09, 2018

Copy link to clipboard

Copied

So what bitrates were you using before, and now?

And which transitions? That sort of thing is helpful to mention so that other people reading this thread can see how much of this affects them. Which transitions cause issues at certain times, that sort of thing.

And of course, trouble-shooting.

Plus a screen-grab showing the "purple glitches" would be very useful.

Neil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 11, 2019 Jan 11, 2019

Copy link to clipboard

Copied

Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 12, 2018 Oct 12, 2018

Copy link to clipboard

Copied

I had this problem too with my slowed down video clips. They were exported as green-and/or-purple-glitchy-lined videos.

I tried many different exporting options. What worked for me was 1) rendering everything, 2) exporting as format: H.264, preset: High quality 1080 HD, then for the time interpolation: frame blending, then once I queued everything, in the Adobe Media Encoder, I changed the Renderer from Mercury Playback Engine GPU Acceleration (OpenCL) to the Mercury Playback Software Only.

This worked for me. Honestly, I didn't take the time to see which component made the difference, but I think the interpolation option you use is a big part of it.

Good luck,

I hope you figured things out!

-E

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 12, 2018 Oct 12, 2018

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2019 Jan 08, 2019

Copy link to clipboard

Copied

I am getting a similar problem but I can also see this "bug" before I render the video out. I have double and triple checked that my sequence resolution and video match. The original video has no issues playing outside of Premiere but once I bring the video into Premiere the resolution shrinks, then it will either crop the full video (in a way that it was as if the original source was cropped), give the "bug" effect shown, or play fine for a short period. This is all while the file is sitting on my timeline and it follows into the exported work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2019 Jan 08, 2019

Copy link to clipboard

Copied

This is what I am seeing. The video frame is set to the same resolution as the source but imports like this and then gives me all of these visual issues.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 08, 2019 Jan 08, 2019

Copy link to clipboard

Copied

What is that media? And what is your Project settings option for Mercury Acceleration? And ... your GPU?

Download MediaInfo, after installing ... drag/drop a file onto the app's icon on your desktop ... when it opens, use the menu options to get to Tree view, and make a screen grab ... drag/drop that into your reply box showing the Video section of MediaInfo's Tree view like this ...

Neil

MediaInfo TreeView.PNG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2022 Mar 25, 2022

Copy link to clipboard

Copied

LATEST

Hi! My solution was to export as HEVC (H.265) and then 'match source - high bitrate'. Not sure why, but this worked for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines