• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Eyedropper not working in Premiere Pro CC 2017.1.2, Mac in ultra key, titler, others

Community Beginner ,
Jul 14, 2017 Jul 14, 2017

Copy link to clipboard

Copied

iMac, late 2015 build, OSX Sierra, Premiere Pro 2017.1.2

Eyedropper tool does not work in Ultra Key, which makes keying rather difficult.

When you click on the background, the dropper just picks a dark grey color.  If I mouse around quickly, the color picker selection box next to the dropper glimers the right green but very briefly, and not in a way that you can select it.

It's the same whether or not Im using a second monitor.

I tried unchecking "displays have separate spaces" in Mission control preferences, following a suggestion I found elsewhere. Nope.

I spent 3 hours working with Bhaskar Das of adobe tech support, who had me uninstall the entire Creative Suite and do a clean reinstall, to no avail.

The eyedropper works in after effects and photoshop.

The workaround that I found elsewhere is not good, but it kind of works:  Screenshot the background, take that to photoshop, eyedropper it there, copy and paste the hex color value the the color picker in ultra key.  It's pretty lame. I would love it if this nice expensive software worked properly. Any ideas or help?

Views

6.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 14, 2017 Jul 14, 2017

Copy link to clipboard

Copied

Try holding down Command (Mac) or Control (Windows) when you use the eyedropper. This picks a range of 5 x 5 range of pixels.

Hopefully this helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 17, 2017 Jul 17, 2017

Copy link to clipboard

Copied

I had tried that, that makes a weird grayish color, it looks like a heavily desaturated version of the real green. Comparing the 5x5 sample in PP Ultra Key  to a screen grabbed photoshop color picker dropper of the same area, it looks like its the same color, but desaturated by 19 points on the HSB scale.  How weird.... sort of a workaround, I gguess.   Beef up the S by 19 points and use the PP dropper sample. Not a real fix (hi there Adobe folks) but will probably get me through this project.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Aug 09, 2017 Aug 09, 2017

Copy link to clipboard

Copied

Any updates on the problem? Because I have the same trouble, exactly the way you describe them. I am running macOS Sierra 10.12.4 with an AMD Radeon R9 M390 2048MB graphic card using premiere pro cc 2017.1.2. This is a big issue to me. A work around is not really acceptable for a decent work flow with gear like that. Help, please, help! Anybody?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 09, 2017 Aug 09, 2017

Copy link to clipboard

Copied

This has been an issue the the mac in the past.

Trash preference and plugin cache by holding down shift+alt while opening Premiere.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2017 Sep 08, 2017

Copy link to clipboard

Copied

I tried using the COMMAND button at the same time as the Eye Dropper button and that worked for me. So, hold down the COMMAND button on the Mac, click on the eye dropper, and select the color you want to get rid of.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 29, 2017 Dec 29, 2017

Copy link to clipboard

Copied

This is how I solved the issue with "my" setup on Windows 10, Fall Creator's Update.

PC is a Surface Book.  The monitor is 3000 X 2000 resolution.  Two additional monitors are native 1920 X 1080. I noted that Premiere worked normally on the SB monitor, and not the extended monitors.  I changed the main display from the Surface Book to one of the 1920 X 1080 monitors and keying worked as expected.

Having a lot of experience with Windows 10, I observed "oddities" that suggested there were scaling issues and that appears to be the case.  MAC users?  Don't have any experience, but suggest that scaling is scaling and recommend you try something similar.  Pretty sure it will work if I explained this right.  There are numerous programs by many different authors that don't scale as expected.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 22, 2019 Nov 22, 2019

Copy link to clipboard

Copied

Thank you -I am using Windows 10, and I could not get the eyedropper to do what it's supposed to do. Very frustrating. The second monitor (a TV) is a different aspect ratio, so when I moved the window back to the computer it worked!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 20, 2023 Jan 20, 2023

Copy link to clipboard

Copied

LATEST

Thanks so much for this! It totally fixed my problem. I never would have thought this was the issue.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 27, 2018 Jan 27, 2018

Copy link to clipboard

Copied

I have the same issue but in Windows 10... I've tried resetting primary monitors, using ctrl etc. but no fix. Any other solutions to try?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 06, 2018 Feb 06, 2018

Copy link to clipboard

Copied

Having the same issue in Windows 10. Even switching to a single monitor does not fix the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 01, 2018 Mar 01, 2018

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 01, 2018 Apr 01, 2018

Copy link to clipboard

Copied

Macbook Pro, 2017 (touchbar), OSX Sierra, Premiere Pro 2018 12.0.1

I spent many days troubleshooting this persistent bug myself across several versions of Premiere Pro: with and without a second monitor attached, holding shift, etc. Finally, what made the eyedropper tool work again in Ultra (and other effects) was setting the cursor to the smallest size possible in:

System Preferences>Accessibility>Display. Drag the "Cursor size" slider all the way to the left to "Normal" (OSX's default setting).

BTW, I can reproduce/fix the eyedropper tool bug consistently in my MBP by using the method mentioned above.

Hope this helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 17, 2018 May 17, 2018

Copy link to clipboard

Copied

THANK YOU THANK YOU THANK YOU

I have been struggling with this issue for almost 6 months. And this was the problem for me. Going into accessibility and resetting cursor size back down to the smallest/normal size immediately fixed it for me.

For six months I would have to screen shot my premier work space, load up the image in photoshop. Use photoshop to pick the color and get the rgb code for the color. Then go back to premiere pro and type in the hex code into the color picker. SIX MONTHS!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 21, 2019 May 21, 2019

Copy link to clipboard

Copied

Thanks, gracias ya mi Color Picker funciona al 100%

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 16, 2018 May 16, 2018

Copy link to clipboard

Copied

MacPro (late2013), OSX High Sierra, Dell 4K Monitor, Premiere Pro 12.1.1

Stroboscopic's cursor size fix worked for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines