Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Font in Premiere not working/broken/makes symbols instead of letters

Community Beginner ,
Aug 26, 2021 Aug 26, 2021

Copy link to clipboard

Copied

Dear Community

I am very confused: My font in Premiere seems broken. I can type letters like f,t,i,s but if i want to type a n,w,o it makes it into strange symbols and shapes. This morning it was all good, even thoough it was missing fonts. But that shouldnt be a problem as its just replaced with the standard font. Then i rendered a video and at the same time i copied my project to a stick. I couldnt find any help in the internet, but tbh i dont realy know what i am even searching for.

Here i just used a simple title:

 

asd5FB2_0-1629986126599.png

 

Has anyone encountered that before or knows how to fix it?

I tried to restart my computer, but it didnt help.

Thank you very much

 

TOPICS
Editing, Effects and Titles, Error or problem

Views

61

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Aug 26, 2021 Aug 26, 2021
Acad Xref  is not Adobe. Looks like it's a font from AutoCAD. Might be the reason you are having issues.

Likes

Translate

Translate
Community Beginner ,
Aug 26, 2021 Aug 26, 2021

Copy link to clipboard

Copied

Here the screenshot.

Hardware: Microsoft Surface Pro 6

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 26, 2021 Aug 26, 2021

Copy link to clipboard

Copied

Which font are you using

Have you tried a different font?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 26, 2021 Aug 26, 2021

Copy link to clipboard

Copied

I am using Acad Eref, the Adobe standard. Other Fonts are working. Thank you very much. That helped to circle the problem

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 26, 2021 Aug 26, 2021

Copy link to clipboard

Copied

Try reinstalling the font.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 26, 2021 Aug 26, 2021

Copy link to clipboard

Copied

I tried doing that and restarting the pc again, but it didnt work. The font works fine in word. Reinstalling Adobe Premiere also didnt help. On another PC with a clean adobe install its working. The same file on my computer with reinstalled Adobe Premiere is not working. Do you have any other suggestions?

It seems its something with my computer and with adobe premiere in combination.

I am using Win 10 pro btw

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 26, 2021 Aug 26, 2021

Copy link to clipboard

Copied

Acad Xref  is not Adobe.

Looks like it's a font from AutoCAD.

Might be the reason you are having issues.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 26, 2021 Aug 26, 2021

Copy link to clipboard

Copied

LATEST

I see. I changed the font now, so my problem is solved. Thanks a lot for your time and effort.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines