Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


GPU RAM maxes out, performance is not good, even unusable at times

Community Beginner ,
Jul 01, 2021 Jul 01, 2021

Copy link to clipboard

Copied

I read alot about people complaining that PPro doesn't use the GPU as much... but I'm getting a very weird behaviour from a new machine I just got and put it through it's paces for the first time today. 

2019 Mac Pro 12 Core

32GB RAM

AMD Radeon Pro W5700X 16GB

Afterburner Card

1 TB SSD

Promise Pegasus32 32TB Thunderbolt 3 (1200 Mb/s Read Write)

Dedicated Media Cache on a fast 1TB SSD

Enable hardware acceleration decoding is ON

Mercury Playback Engine GPU Acceleration is METAL

RAM available to Adobe apps is 14GB, and optimized for Performance

Blackmagic Design Decklink Studio 4K PCIe card in correct lane, drives a 2K reference monitor and a 4K LG TV. Latest Desktop Video driver installed v12.1

 

Just got this machine, put it to use on a fast paced pitch rip video. Mostly MP4's and a splattering of ProRes. I know, H264 is not a great codec for NLEs, but it's a rip film for advertising.

Performance gets bogged down when I notice on iStat Menus that my GPU's RAM is pretty much maxed out, generally 80-100% used. All cards are installed in correct PCIe lanes.  After a restart of the program, it takes about 10-20 minutes to max out. Video playback is sluggish and sometimes not at all. I have to stop, start, move the playhead around, and eventually it catches up. The whole program seems slow to respond to input, as if it's overheating or something. Temps are normal for CPU, around 106F depending, but the GPU, even when Premiere is open but idle, is around 124F, and the GPU RAM stays full.

In the attached photo, you can see on the left of the large chart where it went to 100% and I had to shut down PPro. It was unusable. To the right is where it was when I restarted and just played the timeline a few times, moved a few things around, and then left it idling. I also included an image of the past 24 hours so you can see how many times I've had to restart at 100%. RAM usage seems like alot, and the only thing that I can attribute the poor performance to. It also seemed unhappy with some 8K Prores 422 files, where it would do the weirdest things with it, when, honestly should be a walk in the park for this machine. 

Not sure if: 

1) Is this normal?

2) GPU is bunk?

3) Afterburner card is bunk?

4) Is it a Premiere thing? I've looked at all possible settings.

Any insight is welcome. 

Thanks!

Screen Shot 2021-07-01 at 7.54.32 PM redacted.png

Screen Shot 2021-07-01 at 8.13.38 PM.png

 

TOPICS
Crash, Editing, Freeze or hang, Hardware or GPU, Performance

Views

134

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jul 02, 2021 Jul 02, 2021
I've narrowed down one of the culprits, the 8K ProRes 422 files from the animator are corrupt. So scratch that one off the list. I trashed preferences and started over. I've tested the system with ProRes 4444 4K files, multiple streams, etc, and PPro handles them fine. GPU RAM is still maxing out though with this one project from yesterday, which was started in 2020 and upgraded to 2021. I started a fresh 2021 project and imported ProRes 4444 4K files. GPU maxed out at around 50-60% in 10 min. I...

Likes

Translate

Translate
Advisor ,
Jul 01, 2021 Jul 01, 2021

Copy link to clipboard

Copied

Keep in mind the 2019 Mac Pro is a bit of an oddity. Below is a demonstration of what a basic PC can do when tweaked out. For the record my PC has 32 GB of RAM. I also use use an internal RAID and the Intensity Shuttle. Keep in mind my system has Quick Sync and Nvenc yours does not. That being said 8K Pro Res might bog down a lot of systems. Try playing back the Pro Res at 1/4 resolution. You could take out the BMD PCIE card and see if that helps. It is not a cure but a basic troubleshooting procedure. Last but not least can you  playback the 8K Pro Res using FCPX or Resolve? It would not hurt to invest in either programs for troubleshooting purposes. 

https://www.youtube.com/watch?v=1L-erwmRxAU


This video demonstrates how to enable GPU acceleration and GPU encoding and decoding. It also shows how to enable Intel's Quick Sync.RTX 2070 https://amzn.to...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 02, 2021 Jul 02, 2021

Copy link to clipboard

Copied

I've narrowed down one of the culprits, the 8K ProRes 422 files from the animator are corrupt. So scratch that one off the list. 

I trashed preferences and started over. I've tested the system with ProRes 4444 4K files, multiple streams, etc, and PPro handles them fine. GPU RAM is still maxing out though with this one project from yesterday, which was started in 2020 and upgraded to 2021. I started a fresh 2021 project and imported ProRes 4444 4K files. GPU maxed out at around 50-60% in 10 min. In Resolve, the GPU is around the same. 

This could be a case of version migration in PPro, preferences, etc. So far, performance seems acceptable, but today's a down day and I won't know until I get started again on Tuesday in real world situations. Will respond back next week. Thanks for your time. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 02, 2021 Jul 02, 2021

Copy link to clipboard

Copied

Decided to try my test - started a new 2021 PPro project and imported an XML of the sequence. Not including the corrupt ProRes files. 

As usual, it starts out fine, as the GPU RAM fills up. I did some things and then left it idle for while. Currently the GPU RAM is at 80% full and staying that way. Performance is okay, but a bit laggy. As I edit, it gets worse. Maybe this is normal, but Resolve didn't get that high with 4K ProRes 4444 files, multiple streams, only staying at 50% usage and still getting full framerate. 

If Adobe could chime in with some thoughts that would be great!

Screen Shot 2021-07-02 at 10.40.22 AM.png

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 07, 2021 Jul 07, 2021

Copy link to clipboard

Copied

LATEST

Another update. Started a new project today. All media is ProRes 422 Proxy and WAV files. 

Took a while to get to this point, but I'm maxing out my GPU RAM at 100%. And the only thing I've done is watch down takes, and dragged one clip to the timeline.

Screen Shot 2021-07-07 at 4.45.44 PM_redacted.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines