H264 Exports Sounds Starts A Little Out Of Sync ! Help !

New Here ,
Jan 24, 2022 Jan 24, 2022

Copy link to clipboard

Copied

Hello,

 

   I am having a real issue here ! I did a small video that loops perfectly regarding video & audio. It is flawless. However, once i export it in H264 MP4 format, the sound starts a little after, as the export adds a little silence at the start. So my movie now has a click sound when looping.

 

If i export it in Apple Pro Res 22, no issues. It is when i export in H264. I used Final Cut Pro, Adobe Premiere, and even Handbrake (osx) to convert my perfect Pro Res 22 version into an H264 video, same issue happens.

 

The video footage i am using is at 24 fps. My exports are 24fps as well. I tried all other fps, same issue. Any solution to my problem ?

 

Please find attached what the audio looks like when correct, and after film export. A little silence is added.

 

Additional info, if i export in MPEG 2, this issue does not appear. However, i need the video to be in 1080p with low size...

 

Thanks for helping out.

Cheers,

Alex.

 

 

Screenshot 2022-01-24 at 16.16.00.pngScreenshot 2022-01-24 at 16.14.29.png

 

TOPICS
Audio , Export , Formats

Views

94

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 24, 2022 Jan 24, 2022

Copy link to clipboard

Copied

Sorry to ask this, Alex: can't you just use the ProRes file for your purposes? It's pretty universal. You can upload it to YouTube, etc. What's the issue? Let me know.

Regards,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 25, 2022 Jan 25, 2022

Copy link to clipboard

Copied

Hello Kevin,

 

   I need my file to be less than a 100 MB, plus the .mov format is not compatible with my purpouse. It needs to be an .mp4. So unless there is a solution, i am stuck...

 

Regards,

Alex.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 25, 2022 Jan 25, 2022

Copy link to clipboard

Copied

Can you try to queue it in Media Encoder and then render it? And have you tried "Replace with After Effects composition"? I had that problem once too and that did the trick to export it out of After Effects for me. You can also try to roll back a version of Premiere Pro and then try it again.

 

And if that all fails, you can try to import the exported video, slice up the audio to cover the silence and then copy and paste that into the original sequence (under the original track) where the silence part would be if you export it. Maybe that will work.

 

It's not a fix but a temporary solution 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 28, 2022 Jan 28, 2022

Copy link to clipboard

Copied

Hi Willy,

 

   Thanks for your input, and sorry for the late response. Unfortunately, this didn't change anything. And i can't even slice the audio because the end is missing, so my flawless audio loop won't work.

 

It isn't evern about VLC or any other player as i imported the video in Cubase (audio DAW) and the audio part is clearly not in sync.

 

I wonder if this isn't an issue in the core of the H264 encoding. I have this issue in all programs i used. FInalc Cut, Adobe Premiere and Hanbrake if i export the Pro Res file into MP4. Everytime the video is encoded in H264 i get this issue...

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 25, 2022 Jan 25, 2022

Copy link to clipboard

Copied

This thread also talks about exported video out of sync.

https://community.adobe.com/t5/premiere-pro-discussions/audio-out-of-sync-when-exporting-h-264/td-p/...

 

Maybe try VLC media player and see if the video itself is really out of sync or the player.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 28, 2022 Jan 28, 2022

Copy link to clipboard

Copied

quote

The video footage i am using is at 24 fps. My exports are 24fps as well. I tried all other fps, same issue. Any solution to my problem ?


By @Alex_Audio

 

-- Where does the source footage come from, video camera, screen recording, cellphone, or?

-- What are the audio properties on the audio placed on the timeline, .wav or .mp3? (If wav, 16-bit 48 KHz or?)

-- Are your Sequence Settings set to 24 fps or 23.976 or anything else? (Sequence > Sequence Settings)

-- Post a screen dump of your export settings.

 

I am on Windows and can export H.264 as .mp4 from a 24 fps timeline with .wav audio @ 16-bit, 48 KHz in Premiere Pro and the imported file is in sync and does not have any silence at the start and loops without issues.

 

Averdahl_0-1643377347307.png

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

Hi Averdahl,

 

   Thanks for your post. The video i am using is a stock footage video at 24 fps with no sound. The audio file i am using is 48Khz and 16 Bits. On my export settings i am using the same exact settings as the original files regarding video and sound. When the output is Pro Res, the sound is fine. As soon as it is H264, the sound start a little after. Whatever video program i end up using. Even if i convert the perfect Pro Res video using Handbrake to H264, the sound moves...

 

It is not distinguichable by ear, so trying with VLC won't change anything. I need the audio loop to be perfect. I am a sound engineer, so when importing the video into my audio workstation, i can clearly see the sound not in sync, so my flawless loop cannot work.

 

I also tried another video from stocks. This time a 60 FPS, same exact issue when exporting in H264 in 60 FPS. I just can't get what is going wrong.

A friend of mine that is an movie editor told me about looking into possible key frames. But i tried changing all kind of settings, nothing works...

 

Here is a picture of my settings.

 

Cheers,

Alex.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

quote

As soon as it is H264, the sound start a little after. Whatever video program i end up using. Even if i convert the perfect Pro Res video using Handbrake to H264, the sound moves...

 

By @Alex_Audio

 

I did new testings today based on your Export Settings and here on Windows the audio starts perfectly from the very beginning, but here the last frame is dead silent... The opposite to what you have but with the same result in the end, iow a loop that is not perfect. I missed that yesterday...

 

This happens in all encoders i have tested. Since it´s an audio issue i got a tad better result by changing the Audio  Format Settings under the Audio tab in the Export Settings dialog from AAC to MPEG. Those are the only two options. Better, but far from perfect though.

 

But when i tried it in the payware app (Windows only) TMPGEnc Movie Plug-in AVC for Premiere Pro i can choose to export H.264 video with PCM audio and this give me a perfect result. The clip to the left in the image is the end of the clip. The clip to the right is the start of the clip. This gives me a perfect loop. (PCM audio is what you see in ProRes.)

 

Sadly the native H.264 exporter in Premiere Pro cannot export H.264 with PCM audio.

 

So, hunt for a third party encoder app that allows to export H.264 with PCM audio instead of compressed audio since compressed audio in the renders is the issue here. Maybe Apple Compressor is capable of that?

 

 

Averdahl_1-1643466843214.png

 

This is what i see when using the plug-in:

Averdahl_2-1643467172837.png

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 30, 2022 Jan 30, 2022

Copy link to clipboard

Copied

LATEST

Thanks ! I will look into that, this can be a solution. Cheers 🙂

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines