Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


How can I fix blurry still images in Premiere Pro?

Community Beginner ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

Hi, I am Caillin. So I have been working on a project in Premiere Pro, using still images (logos for companies) and I have come across a common issue with any image I have used. The resolution on the image gets lower when the video is playing.

I asked a professional a couple of days ago and he said that it was just because I had not rendered the video yet. So I rendered it and the image was still blurry. I also needed the images to take up almost the entire size of the screen.

I have some images below. Image 1 shows the video when it is paused in Premiere Pro CC. Image 2 shows the end result (rendered) and also when the video is playing in Premiere. Some things to note are that this was also a problem in the 2017 version of Premiere. Not just 2018 versions. I am on a Windows 10 laptop with 12GB of RAM. That should be enough info. If you need anymore, just ask.

I guess what I would really like to know is if there is anything that can stop this error from happening that anyone would know about.

Thankyou.

Views

46.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

LEGEND , Oct 22, 2017 Oct 22, 2017
Click the wrench in the lower right corner of the Program Monitor and from the drop down menu choose Playback Resolution > Full.MtD

Likes

Translate

Translate
Community Beginner ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

MACRON.PNGHere is the image when paused...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

MACRON BLUR.PNGHere is the rendered/playing version.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

Make sure playback is set to full.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

How exactly do I do that?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

Click the wrench in the lower right corner of the Program Monitor and from the drop down menu choose Playback Resolution > Full.

MtD

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

Thankyou. I will try that after rendered.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

Thankyou Ann Bens and Meg The Dog. That helped alot. I find it weird that the playback resolution effects the rendered version, but thankyou. I thought that the playback resolution only affected the preview.. guess not. Thankyou.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

Render is making playback smoother.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 06, 2018 Oct 06, 2018

Copy link to clipboard

Copied

This exact same thing is happening to me, yet the solution here is not working at all

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 11, 2020 Feb 11, 2020

Copy link to clipboard

Copied

Unfortunately, I am having the same problem. I rendered and replaced the photos and I set playback resolution to full.  When I stop the video, the photo is in perfect focus but when I play the video, it is blurry. What am I doing wrong?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2020 Mar 29, 2020

Copy link to clipboard

Copied

Right, I'm also facing the same problem. when video is playing during editing it's blurry but when I pause it, still photos become clear. Even if after rendering result is same, blurry photos !

Kindly help

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 28, 2020 May 28, 2020

Copy link to clipboard

Copied

My wife and I were having the same problem. We also checked the high quality playback box, after clicking on the wrench and that fixed it for us. Plus, what the other people had said.

Hope that helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 25, 2019 Sep 25, 2019

Copy link to clipboard

Copied

In case someone has this issue again, I fixed disable option in preferences - media - default media scaling - NONE

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 07, 2020 Jun 07, 2020

Copy link to clipboard

Copied

Can someone please help me. When i scale a logo down in premiere it gets blurry and when I scale it back up the logo quality is fine. Even with the playback set to full.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 02, 2020 Dec 02, 2020

Copy link to clipboard

Copied

If this is the same issue I'm experiencing I went to 'view' and clicked on 'High Quality Playback' I hope it fixed it and whomever has problems. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

Also, if you have an adjustment layer, sometimes that will blur out an image. Move the image around to a different position, and that also may solve the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

I had the same issue and I fixed it by,

-Right clicking the image on the preview

-Clicking Playback Resolution on the drop down menu, click full

-Clicking Paused Resolution on the drop down menu, click full

-And I have High Quality Playback on the drop down menu on 

-Works June 18th, 2021

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 02, 2021 Sep 02, 2021

Copy link to clipboard

Copied

I was able to fix this by checking the box 'Use maximum render quality' in the export settings screen.

 

Hope this helps for some of you

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 03, 2021 Oct 03, 2021

Copy link to clipboard

Copied

annoyingly, Ive followed the steps of every comment on this page and still have this issue. someone please help

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 04, 2021 Oct 04, 2021

Copy link to clipboard

Copied

Hello there!
Be sure to check your sequence frame size.
Under Sequence> Sequence Settings, check if Editing Mode is "Custom" and on Frame Size type 1920 x 1080.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

LATEST

I had the same 'blurry' rendering problem and I too tried all the suggestions below, but to no avail.

 

So I did the following, which rendered the logo perfectly in the Premier Pro playback and when I exported the final video.

 

I had created the logo in Illustrator and changed the colour space to RGB and saved as a standard AI file.

 

When I placed the logo into Premier I scaled it up and then the 'blur' would occur. So I scaled it up in Illustrator, saved it, then dropped it into Premier again. I repeated this several times, until I was happy with the sizing from Illustrator. This method ment I did not have to resize the logo in Premier and thus avoided the 'blur'.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines