M1 iMac - Premiere doesn't have GoPro Cineform Codec

New Here ,
Aug 03, 2021 Aug 03, 2021

Copy link to clipboard

Copied

Hey there! 

 

I'm working on a large television show, with several dozen thousand files - so when things go offline, it's a huge pain. I recently tried to migrate to the new update of Premiere Pro, which is natively compatible on M1 Macs (which I've been working on the entire time, using the Intel version of the software). I checked with my co-worker before migrating, and they said that the new software version is working great. They are working on a Mac Pro with Intel based chips. 

 

However, whenever I open the M1 version of Premiere, it gives me an error message that the "files use unsupported file type CFHD". After some cyber sleuthing, I figured out that the error message was indicating that the GoPro Cineform codec (which all 28,000 files have been transcoded into for proxies) doesn't work with the software. The crazy thing is, they were natively generated from Premiere, and work completely fine in the Intel version of the software (which I can launch through the Creative Cloud). 

 

Changing the codec isn't an option, as we're fairly far into the project at this point. I tried manually installling the codec by downloading some software from GoPro, and it didn't seem to fix anything. I quit and restarted, and uninstalled and reinstalled, and I'm completely at a loss. I'm certain it's just that the codec hasn't been added into the M1 version of the software yet. Any thoughts?

 

TIA 

Bailey

TOPICS
Editing , Error or problem , Hardware or GPU

Views

2.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Sep 01, 2021 Sep 01, 2021

I was able to fix the issue by installing an older version of premiere. Not only did my footage not load but none of my RedGiant plugins worked. They all had "offline" next to them. The older version is slower but at least everything works the way its supposed to.

Likes

Translate

Translate
New Here ,
Aug 05, 2021 Aug 05, 2021

Copy link to clipboard

Copied

Got in touch with a support person that pointed me to this article: apparently the CFHD codec compatibility issue is a known problem that will likely be mitigated in future versions.

 

Posting this here for anyone else having the same issue. 

https://helpx.adobe.com/tr/premiere-pro/kb/premierepro-and-macos-big-sur.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

I was able to fix the issue by installing an older version of premiere. Not only did my footage not load but none of my RedGiant plugins worked. They all had "offline" next to them. The older version is slower but at least everything works the way its supposed to.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 12, 2021 Oct 12, 2021

Copy link to clipboard

Copied

Has anyone found a comprable proxy file for the M1 Macs that are as fast as the GoPro Cineform? 

 

Thanks, 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 12, 2021 Oct 12, 2021

Copy link to clipboard

Copied

ProRes 422 Proxy, perhaps?

 

I admittedly don't have an M1 Mac myself, but I tend to lean towards ProRes whenever Mac workflows are involved. It may just be superstition at this point, and may not have any tangible difference though, just my line of thinking.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 08, 2021 Dec 08, 2021

Copy link to clipboard

Copied

I'm having the same issue since upgrading.  I just figured out that you can "open intel" using the *** button next to the Open button in the Creative Cloud interface.  Seems to relink the footage and work.  Haven't done much with it (and it's obviously not as easy as double clicking the file), but wanted to pass it on.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 09, 2021 Dec 09, 2021

Copy link to clipboard

Copied

Thanks, hopefully that will solve the OP's problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 20, 2021 Dec 20, 2021

Copy link to clipboard

Copied

One heads up.  This method of opening the Intel version through Creative Cloud has been working fine.  However, when exporting I have found that I need to do one at a time from Premiere.  When batch exporting to Media Encoder the errors come back.  Going forward, I will avoid Cineform it's just a couple projects that I had done a media manager version in Cineform that require this special work flow.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 23, 2022 Jun 23, 2022

Copy link to clipboard

Copied

Thank you so much. This solution worked for me!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

LATEST

Thank you so much! You saved the day, this solution worked for me as well!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

I had the same problem. I solved it when I launched the Premiere via Rosetta.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 27, 2022 Mar 27, 2022

Copy link to clipboard

Copied

Same problem. This is annoying.  Adobe claims M1 native silicon support, but didn't update the codecs.

 

We're also running a show with most of the VFX and Colorist files in Cineform.  

 

This means we cannot use the latest generation of macs.  Running under Rosetta 2 is comparable to running an older machine.

 

Adobe should have at least predicted this and wrote the code to auto convert media to a working format instead of tossing out a "general importer error."  That's the laziest thing I've ever seen.  

 

FYI, Resolve imported all of our project assets and still runs Apple silicon native.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 23, 2022 May 23, 2022

Copy link to clipboard

Copied

Working solution as of May, 2022 directly from Adobe support: Please open the application folder > There you will see the Premiere Pro folder. Open that folder and then inside that you will see Premiere Pro (application) > Right click on Premiere Pro > Get info > Select Rosetta mode there and then relaunch your application.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 25, 2022 May 25, 2022

Copy link to clipboard

Copied

Thank you !

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines