Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Mercury Cuda activated in project settings but not for rendering

Explorer ,
May 07, 2018 May 07, 2018

Copy link to clipboard

Copied

Hello there,

I got a quick question regarding the cuda topic. I have a GTX 1060 running and seems to work for video playbavck since i have activated the Mercury Cuda option in the project settings. But unfortunately when i start exporting in den output settings it says "software only" and i cant select cuda since the option is greyed out.

So cuda works for playback but rendering always runs software only.

In the export window it gives you a output summary, thats were it tells me "software only".

Can anyone check if you have the some thing showing up?

I have inserted two screenshots to illustrate what i mean.

Thanks a lot!

Valentin

156.JPG

157.JPG

Views

5.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 07, 2018 May 07, 2018

Copy link to clipboard

Copied

try using VBR 1 instead of 2 for now, this was dealt with in previous posts, Adobe will fix it soon ...

Bitrate setting : VBR 1 Pass

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 07, 2018 May 07, 2018

Copy link to clipboard

Copied

The explanation I read was that the Export setting doesn't use CUDA, it uses Intel QuickSync.  But it only does that when your CPU's built-in Intel video chip is driving the display, which will disallow the selection of CUDA for effects processing.

In other words, you can't have both.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 07, 2018 May 07, 2018

Copy link to clipboard

Copied

Hello Jim,

Thanks for the explanation. I have seen that problem happen to a lot of people online. They have the onboard graphics activated. But i have deactivated my intel HD4600 onboard graphics in the bios and have my gtx1060 selected as my primary and only graphics card.
it doesnt even show me the onboard graphic card in task manager.
My screen is also connected to the gtx1060.

Any explanation for this scenario?

Thank you in advance.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 07, 2018 May 07, 2018

Copy link to clipboard

Copied

That "rendering settings" section of the export settings has absolutely nothing to do at all whatsoever with the MPE CUDA hardware rendering setting. The settings in the "rendering settings" box operate during (read: in the middle of) encoding, while the settings in the MPE GPU acceleration section work before the video gets encoded. Get it?

If the "performance" setting within the "Rendering settings" portion of the Export window is greyed out and locked to the Software only mode, this means that you're using either only the discrete GPU or your system's integrated Intel GPU is too old to support Adobe's implementation of the Intel Quick Sync feature. Adobe only supports the 6th-generation (Skylake) or later Intel CPUs with integrated Intel HD or UHD or Iris Graphics 500- (but not the older Broadwell-era 5000-) or 600-series IGPs. You have only a 4th-generation (Haswell) Intel i7 CPU, which is too old to support Adobe's implementation of Quick Sync even if you have the IGP enabled.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

Hey,

thanks for the explanation. Still, i dont get why i cant use my GTX1060 for video rendering? Why doesnt it use my GPU (GTX 1060) at all when it is the only GPU activated in my system? 4k timeline with four 4k clips in it. two reversed, 2 with luts and gaussian blur and still 0% GPU usage while rendering? I have a GTX1060, so why should i render software only?

When i activate the onboard intel HD in my system as well, so both beeing activated, I can select "Hardware accaleration" in the export tab and it uses my Intel 4th gen onboard to do the rendering. Still 0% usage of the 1060.


So i deactived the intel Onboard again to force the system to use the GTX1060. Still no luck. Hardware acceleration greyed out in the export tab... I have used my GTX1060 before for rendering with premiere very often. So i dont get what the problem is?...

So there is currently no way i can use my GTX1060 with premiere pro for rendering? When i queue the render to media encoder it forwards the information to not use the GTX1060.

Appreciate any help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

can you share your system specs please ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

and what operating system and what build ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

My system:

Windows 10 Pro

10.0.16299 Build 16299

Intel i7 4970K

ASRock Z97 Extreme6

DDR3 Kingsten HyperfuryX 4x8GB 1866Mhz

Gigabyte GTX1060 6GB OC Windforce

GPU Driver: Geforce 397.31

Nvidia 24.21.13.9731

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

check this out please :

No GTX 1060!?!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

Thanks, i have read this post. Stiil dont get it. I have applied a ton of effects that use GPU acceleration, still no use of the card. 1% usage when rendering or playback of the timeline with 4k clips with gpu accelerated effects?

in previous versions of CC i had a gpu usage of like 40% when rendering heavy projects. Its not using the GPU very little it isnt using it at all since you cant even select hardware acceleration in export settings. it is only using software only (CPU)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

If you have done a driver update it might be an issue so please try to

uninstall the driver and let Windows detect download and install it again

please

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

I will give it a try thanks.

So your encoding option in export settings is greyed out as well?

what gpu usage are you getting when exporting a heavy project?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

Might want to read this on what cuda does and does not do.

It is an old article but still valid.

CUDA, OpenCL, Mercury Playback Engine, and Adobe Premiere Pro | Creative Cloud blog by Adobe

And read RJL post again.

The Encoding Settings option is not for the nvidia card.

What you are seeing in your export is correct.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

alright thanks. so it seems to be normal. but does it make any sense to activate both cards, so the encoding option is not greyed out any more? or do i lose the cuda for timeline playback?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

I have just done an experiment.

I deactived to onboard graphics and had my monitor plugged in the graphics card. for the second try i activated the intel onboard graphocs and had the monitor plugged into it.

Started premiere, cuda enabled and did a render.

VBR1 , 30sec 4k timeline four 4k clips l´playing at the same time. 2 reversed, 2 gaussian blur, 2 adjustment layers with lumetri color correction and a lut.

GTX 1060 only activated: (export render setting: software only because greyed out): 8:04min

GTX1060 and Intel HD4600 activated. Export render setting: software only: 3.11min

GTX1060 and intel HD4600 activated: export render setting: hardware accelerated: 3:10min

The only thing i noticed is that in task manager it used the intel hd for video encoding and 3D and the 1060 only 15% for copying.

Usage of the intel hd was 86%, gtx1060 about 25% when used together.

when had only the GTX1060 activated it was only used 5%...

So whats the deal? how am i supposed to set up my system? Why does it let the Intel HD do all the work? GTX1060 would be much faster.

I have reinstalled all Nvidia drivers by windows detects.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

what happens if you export with 'Match Sequence Settings' ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

GPU render.JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 07, 2018 May 07, 2018

Copy link to clipboard

Copied

did you update your Video Card to the latest driver ?

Did you try to export with bitrate set to VBR 1 pass ?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

Hello Carlos,

Video Card drivers are up to date, i tried setting it to vbr1 but unfortunately it doesnt change anything, still render without the use of my GTX1060, even if i make a 4k timeline with four 4k clips in it, reverse some, add effects...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

Hi there!

I have the exact same issue, with the H.264 codec only. H.264 BlueRay uses GPU acceleration, HEVC (H.265) just the same, and not a single Preset in H.264 is using GPU acceleration. I can only work in "software only".

I'm on an ASUS ROG with a 1070 and 32GB RAM, which is quite enough to render simple screencasts with a few FX (RedGiant, NewBlueFX) which are all GPU accelerated.

VBR 1 pass didn't solve anything. nVidia Drivers are up to date. Windows is up to date. All drivers are official and perfectly working. The OS installation is pristine, clean and fully functional.

NERHLti.png

On a 2 minutes video it's not THAT hindering, but surely makes a difference when rendering 12-18 hours of content.

Is there any official answer on this? I need to export in H.264 and I'm speechless about this happening on such a simple task.

Am I missing something? May I force that codec in some way?

It happens on an empty project as well. This really leaves me with a bitter taste.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

GPU render.JPG

check these settings please

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

I checked all settings like you guys... same issue with cc 2018

on match sequence settings GPU acceleration works, so

export using match sequence at high quality, then do your

H.264 from the matched export, and you will save all this time

until the issue is fixed, should we file a bug report ?

I tested on both Macos and Windows 7 ultimate with service pack 1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

same export settings (H.264 CBR) on windows 7 ultimate with service pack 1

but on my previous version of Premiere 2017, everything works fine

2017 GPU.JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 08, 2018 May 08, 2018

Copy link to clipboard

Copied

Well, I'm using this workaround:

https://github.com/Vouk/voukoder/releases

and in 5 minutes I was up and running:

DBchI84.png

Worked as a charm, rendering at some points even at 4x real video speed and over, with MAXIMUM level of customization. (even 2 pass rendering).

I also found around these 2 alternative solutions:

http://www.efxi.ru/more/nvenc_pascal.html

https://vk.com/topic-84786662_33382363?post=5454

At the moment, everything "works for me"

Hope it helps!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines