• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

No 'Embed in Output File' option for captions (Premiere Pro 14.9 and earlier).

New Here ,
Jun 05, 2017 Jun 05, 2017

Copy link to clipboard

Copied

Hi

When I go to export my video with captions, I don't seem to have the option to embed in output file?

captions.jpg 

Any ideas?

Im trying to export it as an mp4?

 

Thanks

TOPICS
Editing

Views

2.4K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Engaged , Jun 05, 2017 Jun 05, 2017

Choose QuickTime as your Export Format and choose h.264 as your codec.

When it spits out an .mov, change the extension to .mp4.

Votes

Translate

Translate
Engaged ,
Jun 05, 2017 Jun 05, 2017

Copy link to clipboard

Copied

Choose QuickTime as your Export Format and choose h.264 as your codec.

When it spits out an .mov, change the extension to .mp4.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 05, 2017 Jun 05, 2017

Copy link to clipboard

Copied

Thanks very much!

I am not sure what the problem is, I have tried on my laptop and the option is available without changing any settings, so I think it must be the computer I was using?

I will try your solution when I go back to using the other computer.

Thanks for your help.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 05, 2018 Apr 05, 2018

Copy link to clipboard

Copied

Im having the same issue. But even when I choose QuickTime, I still do not have the Embed in Output File option Screen Shot 2018-04-05 at 3.14.09 PM.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 18, 2020 Apr 18, 2020

Copy link to clipboard

Copied

Same problem, your solution is not helping. Quicktime format does not offer h.264 option as a codec. Still cannot embed a thing

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 04, 2021 Oct 04, 2021

Copy link to clipboard

Copied

This is absolutely not a correct answer.  This tells us how to output an h.264 mp4 and ZERO about embedding captions. When I've selected QuickTime as my export format, I still DO NOT get an option to embed. None, sidecar file, or burn in. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 04, 2021 Oct 04, 2021

Copy link to clipboard

Copied

Matt5CA4, I think the "answerer" was implying that you could then embed captions in that quicktime/H.264 file. I don't know if that was ever correct. I no longer have PR 2017 installed and cannot test since the H.264 code was no longer available after then.

 

The other factor is that you must, of course, be using a closed caption format (e.g. 608/708) for the embed option to be available.

 

Stan

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 29, 2017 Nov 29, 2017

Copy link to clipboard

Copied

When I try that, there is no option for h264 using QT format?

Screenshot 2017-11-29 12.53.07.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 18, 2020 Apr 18, 2020

Copy link to clipboard

Copied

Somnambulist, 

 

This is an old thread. Adobe removed H.264 in a Quicktime wrapper. (I think 2017 was the last to have it, and  no longer available for download.)

 

Some users have reported that Handbrake will add add embedded captions to H.264.

 

Stan

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 10, 2020 Jul 10, 2020

Copy link to clipboard

Copied

It seems to me that Adobe is trying to push their users away from their software. They ended Encore which I used all the time. They ended support to capture DV (only HDV). Now I cannot export captions. Thankfully with Final Cut Pro and other apps like those from Affinity I'm almost ready to go Adobe free.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2024 Feb 02, 2024

Copy link to clipboard

Copied

LATEST

Ok I know why! It depends on the format of you CC track in the sequence. Go to the bottom of the dropdown menu Sequence > Captions > add new caption track... 
Then in the box you can chose the right format which will give you the option when exporting media.

emilb6210863_0-1706893661176.png

Cheers!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines