Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Photoshop layers not importing correctly to Premiere Pro CC

Community Beginner ,
Apr 05, 2019 Apr 05, 2019

Copy link to clipboard

Copied

Recently, the PSD files I import into Premiere Pro CC are not rendering or displaying correctly. Some layers include part or all of other layers. I am typically working with transparent backgrounds and have been unable to import clean layers and use them in any sequences.

All apps are up-to-date, running with OS 10.14.14 on an iMac (Retina 5K, 27-inch, Late 2014)

The only solution has been to export them as PNGs - whereby I lose the ability to update them as my project moves along.

One of my top three reasons for sticking with the Adobe "suite" was to take advantage of these applications working together.

Views

2.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 05, 2019 Apr 05, 2019

Copy link to clipboard

Copied

What option are you choosing when you import the PSD files?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 05, 2019 Apr 05, 2019

Copy link to clipboard

Copied

I choose import individual layers - but most of the layers, once imported, include part (or all) of the content from every layer. I have attempted to toggle "select none" then "select all" and re-import with the same result.

This has happened with more than one PSD file. I will often create a layered PSD that's 1000x1000 @ 200ppi and import it into a 1920x1080 sequence.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 05, 2019 Apr 05, 2019

Copy link to clipboard

Copied

First dpi has no meaning in video.

I would make the psd 1920x1080 and if many layers import as a sequence.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 08, 2019 Apr 08, 2019

Copy link to clipboard

Copied

This reply to my identical post on Creative Cow Forum, solved my issue:

"First thing I check is make sure all Photoshop elements and all layers are RGB 8-bit, not CMYK or something else. For video work, they have to be RGB 8-bit.

I've been tripped up by stuff being in CMYK colorspace. Changing it to RGB in Photoshop, before import into PPro, fixed the issue."

My PSDs were RGB-16 bit ...once I changed them to 8-bit they imported and updated as they should.

Thanks, Jon Doughtie, from Creative Cow / Adobe Premiere Pro Forum

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 19, 2019 Aug 19, 2019

Copy link to clipboard

Copied

So my files are from my Ipad - i suspect perhaps it might have something to do with that

Seeing as my files are RGB 8 bit already - I therefore neednt change a thing - however the import of all individual layers selected is always reduced to 2 layers maybe 3 max being imported?

Are there layer limits?

Are there Premiere Settings to reconfigure?

Please help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

I've followed these recommendations and my layers still are showing a white background. My photoshop file is RGB and 8/bit. In premiere pro, ignore alpha transparency is NOT checked. I have be researching all of the forums but everything I try still shows up with a white background. Let me know what else I can try. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

I am having the same issue.... its not supposed to work like this. I wonder if its from a new update?
Even TEXT Layers are coming in with WHITE backgrounds!

headTrix, Inc. | Adobe Certified Training & Consulting
Consulting | Design | Development | Training

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

Hey geeks,

Check your Photoshop project is on a artboard,If it is yes....right click on the artboard and select ungroup from the art board. I have got this same issue and it solved for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 22, 2021 Sep 22, 2021

Copy link to clipboard

Copied

This worked for me! The Artboard is at the top of the layer stack—right-click for the ungroup option. Thanks wise one.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 06, 2021 Oct 06, 2021

Copy link to clipboard

Copied

LATEST

THANKS, it worked for me too. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines