• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Playback extremely lagging and Exporting painfully slowing down for Vertical Format in Premiere 2021

Community Beginner ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

MY SITUATION:

Hi all. For my job, I receive three one-minute sequences from a finished show cut for the web made up of videos and images (particularly images purchased from Getty Images that have sizes ranging from 2400x3600 to 4500x3000 and between 3MB to 9MB — More on these later) with effects, scaling, resizing, movements, transitions, and graphic overlays.  I have to combine them into one three-minute VERTICAL 1080x1920 version of this show for Snapchat. 

 

My project in Premiere is big with 21 sequences (media, music, SFX, graphics, etc.)  in it so far, but it’s not huge. It takes a bit to open it, but I’m hoping this isn’t causing any of the following problems because I need to have access to sequences and media I have used in previous weeks.

 

The issues I am having are PLAYBACK and EXPORTING.

 1.  FIRST ISSUE: PLAYBACK

-For playback, when I receive the 1920x1080 HORIZONTAL sequences of the original show from the editors, playing it down (with videos and images) has minimal issues and mostly is fine. When I copy and paste the exact sequence into a 1080x1920 VERTICAL format, I experience a huge amount of lag and "media pending" messages almost exclusively with the Getty images over 3 MB. Any video of any size and any image UNDER 3 MB plays fine in both HORIZONTAL and VERTICAL formats, but the images over 3 MB in a 1080x1920 sequence just come to a raging halt.  A few colleagues have told me this happens frequently with images in a vertical format.  I don’t understand why.  It’s also puzzling to me because 3 MB doesn’t seem like that large to cause an issue and why would it play fine in a HORIZONTAL format? Does anyone have similar issues with the playback of images in a vertical format?

 

Some things I have done to improve playback:

-I delete media cache files often.

-I have resolution preview playback set to 1/4 (it won’t go lower to 1/8)

-I have High Quality Playback turned off.

-I’ve seen where people suggest turning off Global FX to improve playback.  I can’t turn off Global FX button as my job is literally to resize, scale, and add effects.

 

COMPUTER SPECS:

-MacBook Pro (Retina, 15-inch, Mid 2015)

-MacOS Big Sur 11.6.5

-Processor: 2.8 GHz Quad-Core Intel Core i7

-Memory: 16 GB 1600 MHz DDR3

-Graphics: Intel Iris Pro 1536 MB

-I have 120.35 GB available of 500 GB on the laptop and scratch disks are set to an external drive.

 

PREMIERE INFO:

-Premiere Pro 2021 v.15.4.1 (Build 6)

-Of the 16 GB for RAM, 13 GB is set for Premiere

-Optimize Rendering is for Memory   (not Performance)

-Autosave is set for every 10 minutes with a max number of 20 versions.

-Renderer: Mercury Playback Engine Software Only   (when I used Mercury Playback Engine GPU Acceleration (Metal), I had issues)

 

2.  SECOND ISSUE: EXPORTING

-The second bigger issue I have is exporting - irrespective of whether its out of Premiere or Media Encoder. (I usually just export out of Premiere because there doesn't seem to be a difference) When I started 21 weeks ago, exporting the 3-minute vertical sequence went from taking 25 minutes (which I thought was excessive) to almost 90 minutes now. 

 

I know that one of the suggestions is going to be to render the sequence, especially because the sequences are mostly yellow and red, with very little green. I understand that, but here's the issue with that - I need to edit and export this show in a quick turnaround and editing/reformatting alone takes up most of my time, leaving little time to export.  Rendering seems to take TWICE the time of exporting, sometimes 2 or 3 hours, while exporting at 90 minutes, while excruciatingly long, is still less than 2 or 3 hours.  If someone can suggest how to render in the background while I can still edit the other parts of the show, I'd love to know how to do that. 


Can anyone tell me why exporting is getting slower and slower and how to get it to a time that is something manageable? What am I doing wrong?  

Below I have listed all of my Premiere settings for the sequences and exporting:

-I have checked and unchecked Use Maximum Render Quality as well as Use Previews and neither seem to have a difference. 

-I’ve tried exporting the sequence as its own project and exporting from there and that doesn’t make a difference.

 

SEQUENCE SETTINGS:

-29.97 (Drop-Frame Timecode)

-1080 x 1920 (vertical editing) 9:16

-Square pixels

-No Fields (Progressive Scan)

-Rec.709

-Preview File Format: Quicktime

Codec: Apple ProRes 422LT

 

EXPORT SETTINGS: 

-H.264

-Encoding Settings: Performance: Hardware Encoding

-Bitrate Encoding: VBR, 1 pass

-Target Bitrate: 25.05

-Audio Codec: AAC

-Sample Rate: 4800 Hz

 

Any help is appreciated. The exporting situation is the worst. 

Thank you, Erika

TOPICS
Editing , Export , Formats , Freeze or hang , Performance

Views

83

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

Some suggestions

Optimize for perfomance not memory.

Uncheck max render and depth.

Turn off hardware encoding

Try CBR

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

Thank you for the response, Ann!
I tried all of those at once and separately and in certain combinations and the export times got worse,  almost to two hours. 
-Erika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

The fact that you have the GPU turned off as your renderer is going to slow everything down in the software from the regular operation to the export times. It's not a long-term solve to keep that setting off. It's more for troubleshooting to see if you have an issue with your GPU, which maybe you do. Were it a Windows machine you can try new drivers. I'm not sure if you get any control of that on a Mac. I'm pretty sure it just happens along with regular hardware updates. The GPU also handles real-time scaling, so if you are recomposing things to fit the new sequence now you are asking the GPU to do the work, but it's turned off, so all that goes to the CPU for processing now and that stuff will generally need to be timeline rendered.

 

Rendering your timeline prior to exporting does nothing unless you use it as a particular workflow. It's an odd myth that rendering your timeline will make the export go faster. They are two completely different things and unless you use the previews in the export, it won't touch them, so you're basically just waiting twice as long. Where it does help is if you use a Smart Rendering workflow, which means you'd render your timeline to a video codec like ProRes 422 (LT is fine, which I see in your settings) and then you'd use both the Match Sequence Settings checkbox as well as the Use Previews checkbox when you export, and you'll export to the same codec that's set up in your Sequence Settings for the Video Preview (the ProRes). That can export faster.  

 

Your hardware is unfortunately getting a bit long in the tooth, and you are extra crippling yourself by disabling the GPU as the renderer for the software. Make sure to use optimized media where possible, as that is just as important if not more so than your hardware when it comes to performance and stability. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 09, 2022 Aug 09, 2022

Copy link to clipboard

Copied

Truly appreciate it, Phillip! (and fellow Harvey. Ha.)
I'm terrible on the tech side and come from Avid on top of it and will 100% concede that perhaps I need a new computer for this, but I worked through what you wrote and it appears that if I optimize the media for the timeline (particularly the large images), render the sequence with the GPU on, turn OFF the GPU to export (as it was giving me errors with every export), export with my export settings (I tried Match Sequence Settings, but the export is bigger than what my employer wants) and additionally check Use Previews, it seems like, I daresay, it's sort of working with a reasonable export time. I will report back as I am going to try this out a few times on a few different sequences, but I thank you for your time and insight!

-Erika 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 09, 2022 Aug 09, 2022

Copy link to clipboard

Copied

LATEST

When you export to a high quality intermediate codec like ProRes, that is what is called a master or archival version. It's not a delivery format. And although some clients do request masters as part of the deliverables, you would not provide that file as the delivery codec. You would take the ProRes and compress an H264/5 from that from that.  

Creating a master first is part of many professional workflows, again not only because a spec sheet may require it, but because it's a stable way to encode your sequence, especially when you have a lot of compositing or a lot of effects involved, or are simply troubleshooting. It's easier for your computer to encode to a format that is intraframe first - every frame exists independently - rather than trying to take a complex edit and compress it directly into a complex, temporally compressed (compressed over time) video codec like H264/5. That's why you will often separate the two.

TL;DR: Make an H264 from the ProRes you exported. Get rid of the ProRes if you want.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines