Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Premiere 2020 no video playback, only audio

New Here ,
Apr 29, 2020 Apr 29, 2020

Copy link to clipboard

Copied

Hello everybody,

My problem: 
Premiere 2020 only plays audio, but no video (either just black or one picture) in my source monitor, program monitor and media browser inside of Premiere. The previous (2019) version worked smoothly with no issues. Occasionally when I open a new project and import a video, it works for while and then gets back to the issue. Pre-render doesn't help. 

My specs: 
MacOS Mojave on Mid 2012 MacBook Pro with 2.5 GHz Intel i5, Intel HD Graphics 4000 1536 MB, 16GB RAM and an SSD.

Cany anybody help me with this please?

TOPICS
Error or problem, Freeze or hang, Performance

Views

235

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 29, 2020 Apr 29, 2020

Copy link to clipboard

Copied

Your machine might be underpowered for 2020.

Adobe Premiere Pro CC System Requirements

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 30, 2020 Apr 30, 2020

Copy link to clipboard

Copied

Uh oh, that's no good 😕 I wish I could go back to the 2019 version. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 30, 2020 Apr 30, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 30, 2020 Apr 30, 2020

Copy link to clipboard

Copied

Hi JakubPodesva,

 

Please try to clear cache and check if the preview is restored. If it's still not working try switching the Renderer to Mercury Playback Engine Software Only and check if it's working properly. Let us know if it helps.

 

Thanks,

Sumeet

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 01, 2021 Nov 01, 2021

Copy link to clipboard

Copied

it doesnt help.

Creative Cloud software states that the newest version (version installed in my comp) is in fact compatible.

But is it really? when i cant even play back the video in the timeline, which is the whole point of video editing..

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 01, 2021 Nov 01, 2021

Copy link to clipboard

Copied

LATEST

Im having this same issue with my mac, even though the Adobe Creative software states that it is compatible with my Computer:

Macbook Pro 2018 13"

2.3Ghz QuadCore Intel i5

16GB 2133MHz LPDDR3

Intel Iris Plus Graphics 655 1536 MB

 

no video scubbing, only audio in timeline playback.

The whole point of having Adobe Premier editing is to "EDIT"

I'm guessing adobe missed that.

 

Now the videos play fine in other Application, including FinalCut.

So what gives? Definitely a software problem not hardware (an inferior software problem)

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines