Premiere 22.2 Software Lagging?

Explorer ,
Feb 15, 2022 Feb 15, 2022

Copy link to clipboard

Copied

Hey Guys,

 

For some reason, Premiere has been very unresponsive and slow as of late. my mouse clicks are delayed while trying to work in the timeline and sometimes even go unregistered. I have all other apps closed, and 16gb of free memory available while working so don't think that is the issue. I have cleared all cache and have plenty of disk space available. I have never had this issue before in the years I have been using premiere on this machine and am finding it incredibly frustrating and hard to work on with the current input delays. The video is playing back fine. Any help or thoughts would be greatly appreciated.

 

I am working on a 2017 27-inch iMac OS 11.6 Big Sur. 32gb of memory and Radeon Pro 580 8GB graphics. 

 

I know a fix could be to update to the latest OS but I'm concerned with this being a 5-year-old mac that it will begin to die as apple products do when trying to run the most current OS. Thoughts?

TOPICS
Error or problem , Performance

Views

147

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 19, 2022 Feb 19, 2022

Copy link to clipboard

Copied

Hi there,

 

We're sorry to hear about this. Are you still experiencing this issue? If so, have you tried resetting app preferences to isolate any preference corruption issue that might be causing the app to misbehave?

 

Thanks,

Sumeet

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 25, 2022 Feb 25, 2022

Copy link to clipboard

Copied

LATEST

Hello,

 

I have been having the exact same issues for about a month with no solution. I have a updated MacBook Pro and still having the same issue. I've tried all the basic trouble shooting and nothing has fixed it. When clearing preferences, I fixed the problem for about 48 hours but then it started again.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines