• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Premiere is lagging on a decent computer

New Here ,
Feb 16, 2024 Feb 16, 2024

Copy link to clipboard

Copied

I have an editing PC a year ago specifically for editing in Premiere Pro, and everything worked smoothly.
Sometime, about six months ago, Premiere began to lag. Occasionally, when scrubbing the timeline or clicking on anything, the response time can vary from 0.5 seconds to 10 seconds. Additionally, when playing the footage, sometimes the audio starts playing but the video doesn't react. Task Manager shows that neither the CPU, GPU, RAM, nor the discs ever exceed 50% usage. There are no other background apps consuming significant resources. I have already tried removing Premiere plugins, reinstalling Premiere, and updating the GPU driver. GPU and CPU temperature and other specs are in normal range. I bought a new Kingston KC3000 and moved all the footage to the new SSD, and still the same issues.

CPU: AMD Ryzen 9 5900X 3.7 GHz 12-Core Processor
MB: Gigabyte X570S AORUS ELITE AX ATX AM4 Motherboard
GPU: MSI VENTUS 2X OC GeForce RTX 3060 Ti 8 GB Video Card
RAM: Corsair Vengeance LPX 64 GB (2 x 32 GB) DDR4-3200 CL16 Memory
System disc: Samsung 970 Evo Plus 0.5TB M.2-2280 PCIe NVME SSD
Cache disc: Kingston KC3000 2.048 TB M.2-2280 PCIe 4.0 X4 NVME SSD
Footage: 2x Kingston KC3000 4.096 TB M.2-2280 PCIe 4.0 X4 NVME SSD (one with adapter)
OP: Windows 10

Do you have any ideas on what to look for next or how to resolve the issue? Thank you in advance.

Views

116

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 29, 2024 Feb 29, 2024

Copy link to clipboard

Copied

LATEST

Hi Erki24341987wqox!

Thanks for writing in. Have you already tried deleting cache files? Can you try switching Default Input to No Input? Edit > Preferences > Audio Hardware. If you're using screen recorded footage, you can try transcoding the files to avoid performance related issues. You can use HandBrake for transcoding.

 

Let us know.

Thanks,

KR

 

 

Moved to discussions.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines