• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Premiere Not Interpreting Alpha Transparency ProRes 4444

Community Beginner ,
Nov 07, 2012 Nov 07, 2012

Copy link to clipboard

Copied

Hello,

I've imported a graphic, ProRes 4444 with an alpha channel but Premiere 6.0.2 is not reading the transparency.  When I lay it on top of another clip the transparent part shows as black rather than being transparent and showing the layer underneath.  It seems like the same error is happening in After Effects.

Final Cut 7 reads the transparency fine.  I read that the same problem was happening on earlier versions of Premiere and After Effects. 

I'm working with a Mac Pro, NVIDIA Quadro 4000, Lion.  

Any suggestions?

Thanks!

Gerry

Views

103.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Nov 08, 2012 Nov 08, 2012

Copy link to clipboard

Copied

1. In the Project panel right-click (Ctrl+click) the footage, choose Modify -> Interpret Footage... and make sure that Ignore Alpha Channel is unchecked.

2. If the above doesn't help, and a footage transparent background looks black, just set clip's Blend Mode in the Timeline to Screen (it's within Opacity property).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2012 Nov 08, 2012

Copy link to clipboard

Copied

Thanks for the reply.

Ignore Alpha is unchecked.

Setting blend mode to screen won't have  the same result as having the opacity work properly, it will change the appearance of the graphics.

Thanks,

Gerry

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Nov 08, 2012 Nov 08, 2012

Copy link to clipboard

Copied

Then try the following:

- duplicate your footage with lost alpha on the track above;

- nest both copies of your footage;

- inside the nested sequence set Blend Mode of the clip on upper track to Divide - that will create Luma Matte;

- place your footage with lost alpha below the nested sequence inside your main timeline, apply Track Matte Key effect on it and set Composite Using to Matte Luma - that's not perfect but somehow works.

Composite with Alpha:

PrPro. Alpha Test 01.jpg

Composite with the above Luma Matte:

PrPro. Alpha Test 02.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2012 Nov 08, 2012

Copy link to clipboard

Copied

Hi,

Thanks for your reply but I'm looking for an answer from Adobe on this possible bug, not a workaround since I can get it to work perfectly as expected in Final Cut.  The graphic has black in it in any case.

Thanks!

Gerry

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 08, 2012 Nov 08, 2012

Copy link to clipboard

Copied

Are you sure that the very same file exhibits transparency in FCP but not Premiere Pro? It sounds like you don't have an alpha channel in that file.

I just created a file with alpha, exported it from Premiere Pro CS6 with the ProRes 4444 codec and it works as expected when imported back into Premiere Pro or After Effects. Where was the file created? How was the file exported? If it was exported from AME, was it exported with 32bit color? Was the render at maximum bit depth checkbox checked? If exported from QuickTime did you have the Millions of Colors+ option enabled?

Screen shot 2012-11-08 at 4.54.37 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2012 Nov 08, 2012

Copy link to clipboard

Copied

Hey Kevin,

Thanks a lot for replying.  I didn't create the graphics, I'll get the info you wanted from the graphics guy.  The opacity definetely worked in FCP, I put the graphic over a color solid:screenshot15.jpg

In Premiere:

screenshot16.jpg

Thanks!

Gerry

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2012 Nov 08, 2012

Copy link to clipboard

Copied

Hi Kevin,

The graphic was created in Motion 5, there is no option for millions of colors +

Thanks!

Gerrt

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 08, 2012 Nov 08, 2012

Copy link to clipboard

Copied

there is no option for millions of colors +

Without that +, you don't get the alpha channel.  It seems you might have 444, not a genuine 4444.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2012 Nov 08, 2012

Copy link to clipboard

Copied

Hi Jim.

Seems there is an alpha channel in FCP.

Thanks!

Gerry

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Nov 09, 2012 Nov 09, 2012

Copy link to clipboard

Copied

Try to import your footage into After Effects and see if Alpha channel is properly interpreted with either Straight or Premultiplied options under Interpret Footage -> Main... -> Alpha settings - the bug is claimed being fixed.

In either case file a bug report.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 09, 2012 Nov 09, 2012

Copy link to clipboard

Copied

As I suspected, the graphic was not exported with an alpha channel. It appears that Apple has changed the export dialog box. For export, choose ProRes 4444. Then go to the render tab and choose Color > Color + Alpha as described in this video:

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2012 Nov 09, 2012

Copy link to clipboard

Copied

Kevin,

How can you come to that conclusion when there clearly is an alpha channel, I even showed you visual proof?  I'm

Perplexed by that. 

I also converted to graphic to animation codec in compressor and brought into Premiere and the alpha works.

Gerry

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 09, 2012 Nov 09, 2012

Copy link to clipboard

Copied

Yes, the Animation codec will also export with an alpha channel, as you found out. It's a much, much larger file size over ProRes 4444, however.

I came to the conclusion when I saw your Motion project inside FCP7 with the alpha. I'm assuming it's not a rendered file, but the Motion file sitting on the Timeline. Yes? When viewed this way the alpha channel is interpreted automatically when used in a FCP project. When you export the file, the alpha is lost unless you do so with an alpha channel. That's all I'm saying. No matter, it looks like you fixed it.

BTW, I was on the FCP team for FCS1 and FCS3 at Apple, so I'm very interested in these cross platform topics.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2012 Nov 09, 2012

Copy link to clipboard

Copied

Hi Kevin,

That is the rendered QuickTime in FCP, not the Motion project.

I didnt solve it. I did a workaround which makes my big client and graphic artist very skeptical of Premiere, which I have been trying to promote.  Also gives me more work and bigger files. Trying to champion premiere and getting this response is very disappointing especially after the frustration with all the xdcam ex glitches that took so long to fix.

I also received this same skepticism/denial when I first reported the xdcam bug and an RGB bug. I would think that perhaps that would give me a tiny but if credibility rather than assuming its a user error on my part without really trying to dig deeper in your part.  Why

Assume it's a motion project in FCP?  I didn't say that.

You don't seem interested in finding out if there really is a problem from your reply and questions.

I know there was a bug in the past with After effects when the transparency wasn't on the first frame of the rendered Prores 4444.

My file is Prores 4444, there is an alpha channel, it doesn't work in Premiere.  

Gerry

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 09, 2012 Nov 09, 2012

Copy link to clipboard

Copied

Out of curiosity, have you tried Kevin's instructions from post 11 yet?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2012 Nov 09, 2012

Copy link to clipboard

Copied

Hi Kevin,

Thanks for your reply.

Just received another graphic from the same graphics artist.  This time the tranparency was one the first frame of the exported graphic and Premiere sees it and it works as expected. The first file I had problems with only had transparency at the end of the clip.  I read in some old posts that there was a bug in a previous version of After Effects where the alpha channel in ProRes 4444 was not working if the first frame had no transparency.  Perhaps this is the same issue.

I'm getting another export of the original file with the issues to double check the result in Premiere and will update you on the result, and pass along any files that you need.  There is a slightly different menu option to export in the latest Motion version not reflected in the Youtube tutorial, one to use "Same as project," which is what the graphic artist uses and I want to narrow down if this is causing the issue.


Thanks!

Gerry

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2012 Nov 09, 2012

Copy link to clipboard

Copied

Hi Everyone,

I double confirmed the correct settings were being used to export in Motion, the alpha is read in FCP and not Premiere, will send files to Kevin.  Premiere seems to read the transparancy when it is at the beginning of the clip, but if it is not on the first frame it ignores it.  Thanks everyone for your feedback.

Thanks!

Gerry

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 13, 2012 Nov 13, 2012

Copy link to clipboard

Copied

Gerry,

Indeed, it appears that he alpha channel exists in FCP, but not in After Effects or Premeire Pro. How strange! I'll file be sending this to the teams right away. Thanks so much for sending me the files.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 09, 2013 Jan 09, 2013

Copy link to clipboard

Copied

Hi Kevin,

I am having the same problem as Gerry.  Did the team give you the solution?

Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 09, 2013 Jan 09, 2013

Copy link to clipboard

Copied

I don't think so. Please file a bug report: http://www.adobe.com/go/wish

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 09, 2013 Jan 09, 2013

Copy link to clipboard

Copied

Well,

Okay, the Adobe team did not respond to a Staff member who submitted a legitimate and substantial bug almost 2 months ago...will me filing a bug report make any difference?

PLEASE can anyone else on this forum help me?  Did anyone else find the solution??? Would really appreciate your help.

Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 09, 2013 Jan 09, 2013

Copy link to clipboard

Copied

"Substantial" is often defined by how many people submit the same bug report, so yes...it can make a difference.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 09, 2013 Jan 09, 2013

Copy link to clipboard

Copied

Okay thank you for your advice and for responding and I will make note of that.

Transparency problems seem to be a long standing issue through many incarnations of Premiere Pro CS.  I just read a review of CS6 where the professional reviewer brings this up as 1 of the issues that they cannot believe ADOBE has yet AGAIN not fully addressed in CS6.

In the meantime I have a deadline.

Has ANYONE found a solution to this problem???

Please Help!!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 09, 2013 Jan 09, 2013

Copy link to clipboard

Copied

Hi Duleen,

As mentioned above in the thread, I converted the files

to Animation codec, which has an alpha channel, which creates a much larger file size.

I find it surprising that this issue hasn't been addressed, seems to me using ProRes 4444 graphics would be pretty common among professional editors.

Gerry

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines