Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Premiere Pro 15.0 can't get my loupedeck+ to connect

New Here ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

Can anyone help?

 

Did the new update and now I can't get my loupedeck+ to connect.

TOPICS
Error or problem

Views

679

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

Hi Jay,

Update the Loupedeck software, it's fixed this issue for others. Let us know if it works.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

Tried that, then uninstalled and re-installed. Then unistalled Premiere and Loupedeck and then re-installed both. Tried with new and old projects. Nothing worked. I'm assuming Loupedeck will need to make a new update for the new version of Premiere. I'll be sticking with Premiere14.9 for now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

Sorry about that, Jay. I'll keep my ears open for other alternatives or workarounds.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 26, 2021 Mar 26, 2021

Copy link to clipboard

Copied

just gotta say this outloud.  Kevin is an incredible resource on this forum with superhuman patience.  (Kevin, I expect that you give me a "like" for this post).  Much more patience then I have, but then again, I'm not an adobe employee...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 12, 2021 May 12, 2021

Copy link to clipboard

Copied

LATEST

Hi,

I just did a complete uninstall and reinstall of the loupedeck+ drivers for the Premiere Pro 15.1 version. Don't forget to add it in the Preferences/Control Surface/Device Class.

Hope this help.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines