Premiere Pro 15.0 won't export an SRT file

New Here ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

I updated to PP v15.0 specifically so I could try the captions workflow.

Now I'm done with the captions (for a video 01:38:54 long) but it won't export an SRT file although it will export a TXT file (which have no timecodes). I go through all the usual dialog boxes but the file just isn't there when I'm done.

TOPICS
Export

Views

1.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Trino, 

 

How specifically are you trying to export? It is working for me. I used the Captions tab in the Export media. You can also export srt from the Text Panel (Captions). Click on the 3 dots -> Export SRT file.

 

The text file with no timecodes sou8nds like you are exporting a transcript.

 

Stan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Hello Stan,

I've been using the Export to SRT File option in the Text Panel of the Captions Tab.

I also don't have the option to export captions from the file menu as it used to be in previous versions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Screen Shot 1.jpegScreen Shot 2.jpegScreen Shot 3.jpeg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Yes, that should work. I'm Windows 10. I wonder if that is an issue. I would file a bug report.

https://adobe-video.uservoice.com/forums/911233-premiere-pro

 

Yes, the File -> Export -> Captions option is gone.

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Yes, it should work. I click Save, the dialog box closes (often with the spinning color wheel following) but then I look for the file in the destination folder and there's nothing.

Exporting a text file in the same way works just fine though, so likely a bug.

Moreover, exporting it as a sidecar to a MOV file didn't help either.

I'll keep trying.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 26, 2021 Apr 26, 2021

Copy link to clipboard

Copied

I'm not sure if this will apply to your situation but I had the exact same problem.  For some reason it wasn't exporting properly because I had 2 caption tracks.  One was empty and muted, but for some reason or another that screwed everything up.  I deleted the empty track and it worked after that, but it was really annoying that it was a problem in the first place.  I'm not sure if you have more than one track, but that was my issue and I was having the same result (I'd go to export and literally no file would get made).  Hope that helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 26, 2021 Apr 26, 2021

Copy link to clipboard

Copied

Nevermind, I spoke to soon.  4 out of my 6 sequences worked.....no explanation why.  This is really annoying.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

Nick, thanks for reporting. Yes, frustrating.

 

You are exporting srt from the Export Media settings? Or from the Text Panel? Or both?

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

I'm doing it from the text/captions panel -  the "..." in the corner.  I ended up getting the remainder of the files by literally copying everything > making a new sequence > pasting > and then it co-operated.  Unfortunatley I couldn't pinpoint what the issue was or why anything I did even worked.  On the first round of exports only 1 out of 6 sequences were able to export an srt (each sequences settings were also identical).  Then after deleting the empty caption tracks I got 4 of the 6 to work and the final two worked by making new sequences.  

I should also add that I'm on a Mac, OS 11.3, and premiere 15.1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

Thanks for reporting. Congrats on persistence and creativity!

 

I reported an unrelated caption bug the other day, which I could replicate consistently. But Adobe staff couldn't replicate it. I sent my project file, the one video file, and the srt I was using. Staff could see the problem.

 

In the meantime, I reset my preferences (related to another test I was doing for a user), and then reset the Captions workspace. Now I can't create the bug I saw before. 

 

So for odd caption issues that seem inconsistent, I need to remember to recommend resetting the captions workspace, and if that doesn't help, resetting preferences. It is a tried and true method for fixing a lot of oddities.

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 27, 2022 Jun 27, 2022

Copy link to clipboard

Copied

LATEST

This happend to me as well - the issue was the empty caption. I had one empty caption and the sequence wouldn't export as .srt, but would as .txt. Adding text to the empty caption solved this problem. Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 15, 2021 Jun 15, 2021

Copy link to clipboard

Copied

I'm on 15.2 and encountered the same issue. My first caption was blank where there was just graphics on screen before any audio was captioned. I deleted that so that the first caption has words in it and the .SRT exported successfully. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 02, 2022 May 02, 2022

Copy link to clipboard

Copied

Hi everyone. I'm encountering the same issue. It's extremely frustrating. Anyone found a solution yet? 

 

Two issues after updating Premiere Pro: 
- I get a horrible error in some captions for no reason, and there's no way to solve it (I've Googled it)

- Second issue, it's IMPOSSIBLE to export the captions. I've tried using the export panel, using the three dots next to the captions, using the sequence option from the panel. It seems like the file is saved and then when I look for it it's not there.

 

If anyone could send any information it'd be of great help. I make a living out of edits and it's terribly frustrating to not be able to advance forward because of polatform issues, most of all when it's a premium app like Premiere, that we can't not use. 

 

Thanks

 

Maca

 

 

Screen Shot 2022-05-02 at 18.27.02.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 02, 2022 May 02, 2022

Copy link to clipboard

Copied

Maca, this is an old thread. Some of the issues here will not apply to the newest release.

 

What specific version of PR are you using? The latest release version is 22.3.1.

 

For each type of export you tried, are you sure there was no file? Look carefully at the directory you selected for the export. No file at all vs an empty file etc are important in troubleshooting this.

 

Are you saying that the low-level exception error is due to captions? I don't recall this being an issue before.

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 02, 2022 May 02, 2022

Copy link to clipboard

Copied

Hi Stan, how are you? thanks for your quick reply. I am currently using 22.3.1

 

The error I get is while creating the captions, on certain lines. This happened once a long time ago, maybe it was a year ago. And I tried everything to solve it and there was no way. I ended up waiting for a while and with an update it stopped happening. 


About the file, it's not exported. And actually, with this file I can't export at all, not captions nor the media. I'll attach the files. I don't know what's wrong but I had never had this in the past. My settings haven't changed. 

 

Thanks

 

Maca

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 03, 2022 May 03, 2022

Copy link to clipboard

Copied

Maca,

 

I'm well; thanks for asking! Other than editing frustration, how are you? lol.

 

Odd problems. I can see that, in your screenshot of File -> Export, the currently highlighted panel is the Text panel. When I do that, I have the option to export captions.

 

I would try resetting the workspace(s) you are using. Also reset preferences.

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 03, 2022 May 03, 2022

Copy link to clipboard

Copied

Hi Stan! we all are frustrated about editing haha

 

I talked to a friend that fixes Premiere and he finally found the issue. Apparently the fonts were causing the issues. I was using the ones that came with the srt and then changed it to Lucida Grande. When I finally put it to Arial, I could export it fine. 

 

Hope this helps for someone else too!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines