Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Premiere Pro 15.4 Windows - Preview goes black suddenly

New Here ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

I have been using Premiere Pro for few months now - up until recenty never had this issue.

While editing 4k video - the preview window goes black, the sound is still there but nothing is visible until I restart the app = then it works for few minutes until it breaks again.

Using Mercury Playback Engine GPU Accceleration (CUDA), newest Nvidia drivers, RTX 3070 GPU.

Preview works when switching to software rendered - but its not possible to work with this - performance is atrocious here.

 

I have tried already resetting the app preferences and deleting the media cache database - no improvement.

Have found some older similar thread on same issues from early 2021, 2020 and so one - but no real solution.

 

Whats wrong with this software??? Any ideas who to fix this?

Thanks in advance

TOPICS
Crash, Editing, Error or problem, Freeze or hang, Hardware or GPU, Performance

Views

60

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Aug 20, 2021 Aug 20, 2021
Thanks for the suggestion. I am a gamer too and would prefer to keep Game Ready Drivers installed, swapping between both of them is again not really an option. But I have found a solution myself - disabling Nvidia Geforce Expierience's 'In-Game Overlay' option solved the issue - no more black screen on the preview window and that with Game Ready drivers still installed.

Likes

Translate

Translate
Adobe Employee ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear about this. Are you using the Game Ready driver or the Studio driver for RTX 3070? In case you are using the Game Ready driver, please install the latest Studio driver (v471.68) & check if it's working properly.

 

Thanks,

Sumeet

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 20, 2021 Aug 20, 2021

Copy link to clipboard

Copied

LATEST

Thanks for the suggestion. I am a gamer too and would prefer to keep Game Ready Drivers installed, swapping between both of them is again not really an option.

 

But I have found a solution myself - disabling Nvidia Geforce Expierience's 'In-Game Overlay' option solved the issue - no more black screen on the preview window and that with Game Ready drivers still installed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines