Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Premiere Pro 2021 freezes on start

Community Beginner ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

Hi there
I’m having problems with Premiere Pro 2021.
MacOS Big Sur 11.2.3 on an iMac Pro 2017 (32 GB RAM)

All of a sudden Premiere won’t open any old project and will freeze upon setting up a new project. I haven’t experienced any problems with Premiere lately so I am kind of lost right now.
Premiere Pro loads until the Open or New Project screen. I can jump to the projects folder on my hard drives create new folders etc, I can name a new project but as soon as I go on, I get to see the spinning beachball. Tried it half a dozen times with different locations for the new project I am working on but to no avail.
On opening an old project I get a message that the project needs to be converted but as soon as I click OK Premiere Pro freezes again (spinning beachball).
What is wrong? This is especially unnerving since I need to work on an urgent project right now.

TOPICS
Freeze or hang, Hardware or GPU

Views

304

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

Try making a new project and dragging the project that's crashing into the new project

Can you also please try these rebooting steps:

FAQ: How to reset (trash) preferences.

FAQ: Clearing Cache Method Premiere Pro v14 « DAV's TechTable

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 28, 2021 Apr 28, 2021

Copy link to clipboard

Copied

Hi Joelle
thanks for the advice, unfortunately it does not wark at all (the second links seems to be broken, since I get redirected at www.adobe.com).
I do not get the opening screen after clearing the cache and resetting the prefs but no matter whether I try to open an existing project or create a new one, Premiere Pro 15.1 freezes (spinning beachball). If I instead try to open a new production, the same thing happens.
Things I tried yesterday:
uninstalling 15.1 and installing the older version Premiere Pro 2020 (14.9) – to no avail

installing the Premiere Pro 2021 Beta – to no avail

And to my utter enjoyment, AE won’t start either now. Great.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Apr 28, 2021 Apr 28, 2021

Copy link to clipboard

Copied

Have you tried:

  • clearing caches?
  • removing plugins?
  • restarting?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 28, 2021 Apr 28, 2021

Copy link to clipboard

Copied

Yes, yes and yes. Tried all that, but it did not help.

I did however find a clue what might cause the problem, only I don’t know how to fix it: Just out of curiosity I tried opening the apps under another user and that worked. The problem here is that I lost *all* prefs for things that I need in order to work (like vpn connections, etc.) and would have to trace all these infos down again.

Is there an easyer way to fix that? Any idea, dear people?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 25, 2021 Jun 25, 2021

Copy link to clipboard

Copied

LATEST

I had a fix – or kind of – but the problem somehow keeps coming up every couple of weeks.
The sollution was a rather »dirty« one, since I deleted »User->Library->Application support« and »User->Library->Prefrences« and replaced them with older ones from a Time Maschine Backup. The backup was from a time when AE and Premiere where still working propperly. Of course that did reset all my other prefs too.
As I said, that worked for a couple of weeks. But the problems came back, yet I have no clue, why.

Anyway, what I could verify is, that it must have something to do with the user rights. I did check in »Safety & Privacy«, if the permissions are set correctly and they where.
To see if user rights or permissions have to do with the problem I Created a new user (with admin rights), logged into that user and both, AE and Premiere Pro, started up immediately without any problems.
I then did, what I described earlier, and installed the backup of the permissions and application support folders and the apps stated working again – with the downside of having to set my prefs on all other programs back to where I wanted them. It should not nenessecary, though, to do that, since it requires a lot of work.
But there must be an easier way to fix that problem. Also, why does the problem reaccure? I haven’t changed anything in the meantime.
Any ideas? The problem is still urgent, as you saw.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines