Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Premiere Pro 2022 CEP Host Version

Explorer ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

I have a CEP panel that I'm getting ready to release. Everything works well in debug mode in Premiere Pro 2022 but when I package and try to install, it says it's not compatible with the current version of Premiere and shows it's only compatible with Premiere Pro 2021.

 

In my manifest.xml file I have:

	<ExecutionEnvironment>
		<HostList>
			<Host Name="PPRO" Version="[15.0,99.9]"/>
		</HostList>
		<LocaleList>
			<Locale Code="All" />
		</LocaleList>
		<RequiredRuntimeList>
			<RequiredRuntime Name="CSXS" Version="10.0" />
		</RequiredRuntimeList>
	</ExecutionEnvironment>

Based on the CEP 11.1 Cookbook: I think Premiere Pro 2021 is the Host PPRO 15, and it's my understanding that adding 99.9 will make it compatible with all future versions, correct?

But no matter what I put in the Host Version (I've tried 15.0, 16.0, 21.0, and 22.0) I just can't get it to be recognized as compatible with Premiere Pro 2022.

 

I've also tried messing with the CSXS Version as well, but no luck.

 

I'm using the latest versions of AE Scripts ZXP Installer and ZXPInstaller and Anastasiy's Extension Manager. They all fail.

 

Am I missing something? How do I make sure users can install it on the latest version of Premiere?

TOPICS
SDK

Views

181

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Nov 08, 2021 Nov 08, 2021
Well it looks as though I jumped the gun...Since I started this thread, ZXP Installer released a new version that has "better compatibility with 2022 versions" and "CEP 11" support.ZXP Installer - aescripts + aeplugins - aescripts.com

Likes

Translate

Translate
Adobe Employee ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

I recommend testing what happens when you remove the maximum supported version, like so: 

 

Instead of : 

<Host Name="PPRO" Version="[15.0,99.9]"/>

Try: 


<
Host Name="PPRO" Version="15.0" />

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

Same issue, even with only "15.0" listed:

zxp install fail.jpg

 

Is it possible there's a remnant of my extension still somewhere messing things up? I've made sure it's cleared from the following locations:

C:\Program Files\Adobe\Adobe Premiere Pro 2022\CEP\extensions

C:\Program Files\Common Files\Adobe\CEP\extensions

C:\Users\caleb\AppData\Roaming\Adobe\CEP\extensions

 

Now that I'm browsing random files, I just ran across this file:

C:\Users\caleb\AppData\Roaming\Adobe\Extension Manager CC\Log\EMCL.log

And it contains log info dated today. Does this mean anything?

11/02/21 07:47:12:239 | [WARN] |  | ExManCmd | EMCL |  |  |  | 2460 | Failed to get version from file path "C:\Program Files\Adobe\Adobe After Effects 2022\Support Files"!
11/02/21 07:47:12:239 | [WARN] |  | ExManCmd | EMCL |  |  |  | 2460 | Failed to get version from file path "C:\Program Files\Adobe\Adobe Media Encoder 2022"!
11/02/21 07:47:12:239 | [WARN] |  | ExManCmd | EMCL |  |  |  | 2460 | Failed to get version from file path "C:\Program Files\Adobe\Adobe Audition 2022"!
11/02/21 07:47:12:239 | [WARN] |  | ExManCmd | EMCL |  |  |  | 2460 | Failed to get version from file path "C:\Program Files\Adobe\Adobe Bridge 2022"!
11/02/21 07:47:12:239 | [WARN] |  | ExManCmd | EMCL |  |  |  | 2460 | Failed to get version from file path "C:\Program Files (x86)\Adobe\Adobe ExtendScript Toolkit CC"!
11/02/21 07:47:12:239 | [WARN] |  | ExManCmd | EMCL |  |  |  | 2460 | Failed to get version from file path "C:\Program Files\Adobe\Adobe Illustrator 2022\Support Files\Contents\Windows"!
11/02/21 07:47:12:239 | [WARN] |  | ExManCmd | EMCL |  |  |  | 2460 | Failed to get version from file path "C:\Program Files\Adobe\Adobe Photoshop 2022"!
11/02/21 07:47:12:240 | [WARN] |  | ExManCmd | EMCL |  |  |  | 2460 | Failed to get version from file path "C:\Program Files\Adobe\Adobe Premiere Pro 2022"!
11/02/21 07:47:12:542 | [WARN] |  | ExManCmd |  |  |  |  | 2460 | Failed to fetch default user. Any accounts on the system? Status is 73
11/02/21 07:47:12:972 | [ERROR] |  | ExManCmd | EMCL |  |  |  | 2460 | No products this CEP extension supports installed.
11/02/21 07:47:12:974 | [ERROR] |  | ExManCmd | EMCL |  |  |  | 2460 | Failed initial installation attempt, reinitializing product list, status = -403!
11/02/21 07:47:13:479 | [WARN] |  | ExManCmd | EMCL |  |  |  | 2460 | Failed to get version from file path "C:\Program Files\Adobe\Adobe After Effects 2022\Support Files"!
11/02/21 07:47:13:479 | [WARN] |  | ExManCmd | EMCL |  |  |  | 2460 | Failed to get version from file path "C:\Program Files\Adobe\Adobe Media Encoder 2022"!
11/02/21 07:47:13:479 | [WARN] |  | ExManCmd | EMCL |  |  |  | 2460 | Failed to get version from file path "C:\Program Files\Adobe\Adobe Audition 2022"!
11/02/21 07:47:13:479 | [WARN] |  | ExManCmd | EMCL |  |  |  | 2460 | Failed to get version from file path "C:\Program Files\Adobe\Adobe Bridge 2022"!
11/02/21 07:47:13:479 | [WARN] |  | ExManCmd | EMCL |  |  |  | 2460 | Failed to get version from file path "C:\Program Files (x86)\Adobe\Adobe ExtendScript Toolkit CC"!
11/02/21 07:47:13:479 | [WARN] |  | ExManCmd | EMCL |  |  |  | 2460 | Failed to get version from file path "C:\Program Files\Adobe\Adobe Illustrator 2022\Support Files\Contents\Windows"!
11/02/21 07:47:13:480 | [WARN] |  | ExManCmd | EMCL |  |  |  | 2460 | Failed to get version from file path "C:\Program Files\Adobe\Adobe Photoshop 2022"!
11/02/21 07:47:13:480 | [WARN] |  | ExManCmd | EMCL |  |  |  | 2460 | Failed to get version from file path "C:\Program Files\Adobe\Adobe Premiere Pro 2022"!
11/02/21 07:47:13:501 | [ERROR] |  | ExManCmd | EMCL |  |  |  | 2460 | Product list reinitialized - about to retry install
11/02/21 07:47:13:506 | [ERROR] |  | ExManCmd | EMCL |  |  |  | 2460 | No products this CEP extension supports installed.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

Send me your .zxp; bbb@adobe.com

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

If it's any consolation, your extension installs and loads fine on MacOS, PPro beta and release.

What versions of PPro are installed on the machine, where you're seeing the failure? 

I can't get it to install on Windows, using ExManCmd. [ZXPInstaller.com, and Anastasiy's installer, are simply GUI wrappers around ExManCmd...] 

Does your extension contain any Windows-specific components?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

I have the release Premiere 2022 (22.0.0 build 169) and selected for previous versions to be removed when installing.

 

I don't believe there are any Windows-specific components. I just emailed the non-binary jsx file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

Weird! 

I've asked for input from the Extensibility team.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

Could you send me any logs, from


C:\Users\<username>\AppData\Roaming\Adobe\UPI\Log
C:\Users\<username>\AppData\Local\Temp\CreativeCloud\ACC

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

Just emailed them to you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

Any update from the Extensibility team?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

Yep; zero issues encountered, while installing your .zxp.

[sigh]

They ask that you try the Unified Plugin Installer Agent (UPIA), successor to ExManCmd, and see whether it's more succeessful. (Their testing succeeded with both UPIA, and ExManCmd).

 

UPIA: https://helpx.adobe.com/creative-cloud/help/working-from-the-command-line.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

LATEST

Well it looks as though I jumped the gun...

Since I started this thread, ZXP Installer released a new version that has "better compatibility with 2022 versions" and "CEP 11" support.

ZXP Installer - aescripts + aeplugins - aescripts.com

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines