Premiere Pro Adding Artifacts to Footage in Playback Window and Export, only on PC

Community Beginner ,
Sep 26, 2021 Sep 26, 2021

Copy link to clipboard

Copied

I have Adobe Premiere Pro through my University and no one has been able to solve this problem. I was hoping you could help me fix the playback and export issues on my Premiere Pro. It works perfectly fine on my MacBook Pro but when I use Premiere on my PC it adds little black dots throughout the whole video. It does it to any clips that I import and it shows up in the playback window and in the export. The dots must be a problem with my Premiere on my PC because when I moved the file back to my MacBook Pro they were gone. Regardless, when I playback the video on my PC they show up and they also show up if I export from my PC. I have attached the video that I exported from my PC to show the artifacts.

TOPICS
Editing , Error or problem , Export , Hardware or GPU , Performance

Views

1.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Sep 26, 2021 Sep 26, 2021
Is there anything else that I can try?  By @defaultki6qlaikap78
Yes, in Premiere Pro, go to File > Project Settings > General and set the Renderer to Software Only.

Likes

Translate

Translate
Adobe Community Professional ,
Sep 26, 2021 Sep 26, 2021

Copy link to clipboard

Copied

quote

The dots must be a problem with my Premiere on my PC because when I moved the file back to my MacBook Pro they were gone.


By @defaultki6qlaikap78

 

It seems like an issue with drivers to the GPU. Download the latest drivers from either Nvidia or AMD depending on the brand of your GPU. If Nvidia, use the Studio Driver.

 

The quick fix is to go to Edit > Preferences > Media and uncheck "H.264/HVEC hardware acellerated decoding..." and then restart Premiere Pro.

 

Download Drivers | NVIDIA

AMD Drivers and Support

 

decoding.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 26, 2021 Sep 26, 2021

Copy link to clipboard

Copied

The drivers didn't work.  Neither did the quick fix. I have xfx Radeon R9 290x GPU. I also have i5 8600k CPU. Is there anything else that I can try? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 26, 2021 Sep 26, 2021

Copy link to clipboard

Copied

quote

Is there anything else that I can try? 


By @defaultki6qlaikap78

 

Yes, in Premiere Pro, go to File > Project Settings > General and set the Renderer to Software Only.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 26, 2021 Sep 26, 2021

Copy link to clipboard

Copied

That works, thank you. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 14, 2022 Apr 14, 2022

Copy link to clipboard

Copied

LATEST

This worked for me, thank you!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 12, 2022 Jan 12, 2022

Copy link to clipboard

Copied

I noticed for the for time today I am seeing artifacts in my Premier pro renderings, I previously thought was coming from over zooming post  or slowing the frames down, but nope... I have snow scenes where the master file out of camera is pristien, the trimmed and rendered ( without luts or any light effects added, no zooming or fps changes )  has created noise ,  its un usable now that I see it. 

 

I did the change in setting , edit, render to software only... that didnt fix it. 

How do I best report this to Adobe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines