• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Premiere Pro CC 2022 is Too Slow!

New Here ,
Feb 19, 2022 Feb 19, 2022

Copy link to clipboard

Copied

Today, I have realized, in my laptop (MacBook air 2020 m1 - 16 GB ram) premiere pro being slow. It is so slow that it is practically unusable to me.  Just trying to play my timeline with simple unmodified videos is not possible anymore as the lag is too much. In the past, I can use the app easily but right now when I am using premiere pro I'm gonna crazy! Because it's too slow and it is freezing frequently! would it do because of the new version? what can I do?

 

Thanks!

TOPICS
Freeze or hang , Hardware or GPU , Performance

Views

3.0K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 19, 2022 Feb 19, 2022

Copy link to clipboard

Copied

and also I am using the latest version -22.2-

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 19, 2022 Jul 19, 2022

Copy link to clipboard

Copied

Hi, alepeinador,

Sorry for your issues. Is there anything I can do to help smooth your workflow? I don't have much trouble editing with the current version. Perhaps I can help. If you don't like the UI, you can work around it. If you have performance problems, you can also work around those. Let me know.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 19, 2022 Jul 19, 2022

Copy link to clipboard

Copied

I'm not sure about the version released today, but adding multiple effects to clips hass made it opperate slower than the versions that came out last year. I have been praticing making hologram videos, and sometimes it slows down, sometimes it won't open the source media files... there have been a plethora of issues with this recent update and I may have to revert back to an ealier version that worked better for the videos I am trying to make. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 25, 2022 Jul 25, 2022

Copy link to clipboard

Copied

Hi Azita,

Sorry! What kind of footage is it? Is it 10-bit 4:2:2 HEVC or similar? Can you try making proxies? Let me know!

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 19, 2022 Feb 19, 2022

Copy link to clipboard

Copied

Hi there!

Sorry to hear that, Does this happen on a specific project? Have you tried resetting preferences and deleting cache files?

 

Let us know.

Thanks,

Kartika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 24, 2022 Apr 24, 2022

Copy link to clipboard

Copied

I have done both of these things and it's still unusably slow. I'm about to download finalcut because waiting 30 seconds for every single tiny timeline edit to load is ridiculous. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 29, 2022 Jun 29, 2022

Copy link to clipboard

Copied

have the same problems too. cleaned cache and resetted preferences... nothing. The last update slowed my machine infinitely and its a lenovo legion 7 so no way it is the software

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 31, 2022 Aug 31, 2022

Copy link to clipboard

Copied

experiencing the same exact issues right now. so frustrating. I cant even add text to my footage without getting the beachball spin or it just crashing/freezing. I have youtube/googled all of the cache clearing, preference resetting, proxy making DIY fixes but none of them are working. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 01, 2022 Sep 01, 2022

Copy link to clipboard

Copied

Hi Taylor,

That doesn't sound normal. Sorry! Maybe it's a bad sequence or project file. 

 

What happens if you work in a new sequence? Any better? If that doesn't work, see if you have the same performance issues in a new project. You can give us your system specs and the media you are working with, and we can help you with designing a workflow for you.

 

Finally, you might try deleting the media cache with all projects closed. You can also reset preferences, the "fix-all" for weird behavior.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 24, 2022 Apr 24, 2022

Copy link to clipboard

Copied

Hey Mfu! I think we need more information. I have used the Macbook Air 2020 M1 and had no issues after long term use. I am now using the Mac Studio Max (64gb RAM). Again, I have had 0 issues with the project loading and overall minimal issues. I want to note that the latest version is actually 22.3, and I saw improvements from 22.2. 

It will also become more and more optimized with your silicone chip in the future. I would suggest contacting adobe support and they can help you troubleshoot. For now, I would reset preferences and clear cache. If that doesn't work maybe give premiere a nice reset- delete it and reinstall it and see how it might improve.

 

In this case I don't think this is an issue with adobe

Jason, Owner at Creando LLC

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 29, 2022 Apr 29, 2022

Copy link to clipboard

Copied

I'm having the same issue with speed of program. PP2021 was fine, I just loaded PP2022 4/28/2022 and I feel like I'm running a 486.

I have:  HP Intel Core i7 @1.80gh with 12 GB RAM Using Windows 11

PP version 22.31 (Build2)

I was only making a 20 sec Intro and to move anything around the screen was choppy at best. Constantly overshooting my mark. When I finally got everything where I thought I needed them, I did an export. For 20 sec spot, took nearly 10 min to export. I exported to 720x480, Format h.264 performance hardware encoding, profile high, level, 4.2, CBR bitrate 4257, and NO AUDIO.  Any suggestions appreciated.

Again, didn't have this problem prior to upgrade.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 07, 2022 May 07, 2022

Copy link to clipboard

Copied

you are not alone im using a razer blade pro 17 maxxed out beast and it takes 44 min to upload a 17minute video  Adobe is expensive and now its obsolete. WTF!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 23, 2022 Jun 23, 2022

Copy link to clipboard

Copied

Also having the same issue. I can't even add fc to a to a 20sexond clip with out the sequence image going black. It's very frustrating. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 27, 2022 May 27, 2022

Copy link to clipboard

Copied

I have the same isuue, a project I have been working the last year perfectly, with the last update the work in timeline is almost imposible and the render is about 5x SLOWER, same sequence that used to take 5 to 7 mins rendering is taking 1 HOUR, moving or editing any graphic is like 0.1 fps, it used to be flawlesly sharp, now I change a text and I have to wait to let it load to see any change. it's nuts. alienware r12 i9 11900kf 96gb ram rtx3070 gtx1060 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 13, 2022 Jun 13, 2022

Copy link to clipboard

Copied

Hi, mi computer is 8 GB RAM, M1, with same issue (Too Slow!). I solved it opening Premiere app with Rosetta. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 19, 2022 Jul 19, 2022

Copy link to clipboard

Copied

Hi! I've had the same issues with all of the Adobe products I use... Premiere, Lightroom and Photoshop. It feels like I am working in a web interface across the internet with all 3 of them.

 

Some of the video effects will not render properly either. When exported, they are fine but it's a real pain trying to edit.

 

I have not used Adobe everyday or even every week the past few months, due to vacations, so I can't say exactly what update changed it, unfortunately. But the interface changes to Premiere are awful. I do not like them.

 

The sluggishness of all of the Adobe programs now make me want to rip my fingernails out.

 

My Premiere version is 22.5.0 (Build 62)

My system specs are as follows:

Processor:  Intel(R) Core(TM) i9-10980HK CPU @ 2.40GHz 3.10 GHz

RAM:  64.0 GB (63.8 GB usable)

Graphics:  NVIDIA GeForce RTX 2080 Super with Max-Q Design

 

Can we roll back to a previous version? Please?

 

Thanks!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 19, 2022 Jul 19, 2022

Copy link to clipboard

Copied

just roll back to a previous version and save yourself the headaches

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 24, 2022 Jul 24, 2022

Copy link to clipboard

Copied

I am having the same issue. Premiere is SO SLOW. I am working on an iMac 2017 with 64 gigs of RAM. I have deleted my media cache, uninstalled and reinstalled Premiere, Mercury Playback GPU does not work AT ALL. What do I need to do? I have a 5-10 second lag every time I click the mouse! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 01, 2022 Aug 01, 2022

Copy link to clipboard

Copied

I am also having horrible timeline playback on an M1 Max, at just about any resolution, even down to 1/8 at times.

This is all 100MBPS 4K H.264 footage straight from a Sony A7iii. Minimal effects/color correction. Timeline freezes, stutters, and crawls. I keep updating and it keeps happening. Renders are blazing fast but actual editing is no fun at all. 

Things I have tried:
- run Premiere under Rosetta
- delete media cache
- reset preferences
- disabled hardware accelerated decoding and hardware accelerated ProRes encoding
- cursing a lot

System:
Mac OS Monterey 12.5
Model Identifier: MacBookPro18,2
Chip: Apple M1 Max
Total Number of Cores: 10 (8 performance and 2 efficiency)
Memory: 32 GB
Premiere Pro version 22.5

I thought I would be able to make a new Jurassic Park sequel on this fancy new computer, but I am struggling with basic editing. Any tips would be greatly appreciated, especially if they come in the form of an update that magically works wonderfully.

Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 01, 2022 Aug 01, 2022

Copy link to clipboard

Copied

Just tried again launching Premiere from Creative Cloud with the Intel option (Rosetta, right?) and it seemed to maybe help but still stuttering through cross dissolves at 1/2 resolution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 05, 2022 Aug 05, 2022

Copy link to clipboard

Copied

Absolutely the same experience! The 2022 update is unusable.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 05, 2022 Aug 05, 2022

Copy link to clipboard

Copied

Same, i'm using two computers and getting the same results, slow choppy play even after creating proxies and just playing back a simple HD video is slow and laggy.  

APPLE MACBOOK PRO M1 PRO 10core with 16GB Ram/16GB GPU

and 

A tricked out Hackentosh with 64GB RAM and 8GB GPU. 

Really disappointed as i paying a lot and finally need Premier and i can't use it because its embarassingly slow.


Tried mulitpule versions on both computers.  What the heck do i do? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 31, 2022 Aug 31, 2022

Copy link to clipboard

Copied

I downgraded BACK to PP21 PP dosent care the upgrade and leave all the kinks in place for us to deal with, were like a focus group thats PAYS them to screw us around. PP never runs smooth ever, and I use a 64 core threadripper or my razer blade pro 17 thats an absolute editing animal. the chokepoint is always PP it sucks. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 01, 2022 Sep 01, 2022

Copy link to clipboard

Copied

Sorry about that, richiefromboston. What kind of media are you working with? 

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines