Premiere Pro crashes if Mercury Playback Engine GPU Acceleration is ON

New Here ,
May 02, 2022 May 02, 2022

Copy link to clipboard

Copied

Hi there, hoping to get some pointers on how to trubleshoot and hopefully avoid Premiere Pro from crashing when Mercury Playback Engine GPU Acceleration is ON.

 

Reatively new to Premiere Pro and have been using Mercury Playback Engine Software only as a quick fix when Pro initially crashed, however rendering is taking excesively long with the 'Software only' option (already cleared cache, updated Bios and GPU driver, allocated most memory to Premiere Pro etc). 

 

Setup:

CPU: Intel i5
GPU: Intel UHD Graphics 620 (running latest driver)
RAM: 32GB

 

Any help will be appreciated.

TOPICS
Crash , Hardware or GPU , How to , Performance

Views

51

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 02, 2022 May 02, 2022

Copy link to clipboard

Copied

Adding to the previous comement,  I am running Premiere Pro 22.3.1 (build 2) version

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 02, 2022 May 02, 2022

Copy link to clipboard

Copied

Hi, I've been having the same issue for awhile now and want to know if our issues are similar. When you render with the Software Only option, does it come out messy? My program crashes when I use the GPU Acceleration option so I tried rendering with Software Only and was happy that it actualy finished but turned out colors were wonky and framerate issues existed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 02, 2022 May 02, 2022

Copy link to clipboard

Copied

LATEST

No issues with the output quality when rendering with Software Only, it just takes too much time, a simple 5 minute source video could take 2 hours to render. I am working on the basis of 1920x1080p 25fps . MOV  as source file (from camera), and getting H.264/mp4 as output after adding some basic editing, graphic elements etc, basic stuff only...for quick/small draft files I would chose Mobile 480p preset, but for the final file I have used Vimeo 1080p HD preset. No issues with quality at this stage.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines