• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
3

Premiere Pro Export Glitched Frames on M1

Community Beginner ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

Hello,

 

We just recently got 2 new m1 macbooks for video eiting and are having a problem where frames have glitches in them while ecporting. Have tried both harware and software encoding while exporting from both premiere directly as well as media encoder. Have also tried different formats for exporting, H.264, Quicktime, etc, and the problem seems to occur no matter what settings we choose. Initially I thought this was a computer specific problem however it is happening to both of our brand new M1 Macbooks.

 

It's usually a 1 frame long glitch that scales/repositions a small portion of the video

It occurs at different points in each export

 

Any ideas to fix?

I've attached samples, AME glitch happens at 0:21; PPHW at 0:06, 0:15 and 0:22; and PPSW happens at 0:10

TOPICS
Error or problem , Export , Formats , Freeze or hang

Views

13.8K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

@JohnjAyala , thank you for posting this and taking the time with Adobe support. Must've been exhaustive.  Although I had issues with both GFX with alpha and clips that were time remapped, my solution was similar. I had to make sure that both PR and AME were setup to run with Rosetta. Afer that, no export issues what so ever. I hope that they can fix this soon because neither is a true solution. Also, fun fact: you can't export an AAF file unless you boot PR with Rosetta on the M1 either.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

Hi @dbjt ,

 

Very sorry for this problem. Can you please try the latest beta once? We have done some export improvements in the latest beta builds. You can download the latest Premiere Pro Beta build from Creative Cloud --> Beta apps --> Premiere Pro (Beta)

https://helpx.adobe.com/x-productkb/global/creative-cloud-public-beta.html

Please try and let us know how it goes in the beta build. If you still see this issue in beta builds, please share your original footage/Project file & export settings. We will check it at our end.

 

Thanks,
Mayjain

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 07, 2022 Apr 07, 2022

Copy link to clipboard

Copied

@mayjain  @JohnjAyala @Matt Tornquist  I just tired the PR BETA and it seems to have fixed my issues.  As I mentioned in my prior post, I had footage that was re-timed (optical flow) and a graphic overlay with alpha. The export glitches were also happening on the footage alone, with no graphic. Using 15.4.1 and 22.2. I've attached a before and after for refrence.

 

Premeire 15.4.1 and 22.2

 

MacBookPro18,2

 Chip: Apple M1 Max

System Firmware Version: 7429.81.3

macOS 12.2 (21D49)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 11, 2022 Apr 11, 2022

Copy link to clipboard

Copied

I have been dealing with this issue for about a year now on 2 different M1 machines and that is the only fix, run premiere in Rosetta. I have posted this issue in many of these discussion forms. I cannot believe after all this time and the money I spend on this software the issue has not been fixed properly. What is going on Adobe? I cannot use GFX, Alpha Graphics, or Frame holds at all in the M1 native version. It gets embarrassing having your clients point out mistakes that cannot be seen while editing. Mistakes not caused by you but the software you trust and pay good money for to make a living. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 11, 2022 Apr 11, 2022

Copy link to clipboard

Copied

Let's hope the Beta version gets an official release soon. I can't use it for work unfortunately until they have an offical release. But @guillaumec44441302  if you can, you should really download the most recent Beta and give that a shot. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 12, 2022 Apr 12, 2022

Copy link to clipboard

Copied

Hi, dbjt,

Has the 22.4 Beta hit your Creative Cloud application yet? When you do, give that a try. Bug fixes are afoot. I hope the new version provides relief once it hits everyone's Creative Cloud app. A bit weird that the Rosetta version seems to work around some of these bugs. Sorry about that. I'll do some testing with the new version and my MacBook Pro M1. I'll let the community know how it goes.

In the meantime, keep in mind that the M1 MacBook Pro has roughly the same GPU power as an NVIDIA 1650 Super, which has around 4 GB VRAM (I read). If you have a lot of GPU-intensive processes, like scaling 4K to HD, Lumetri, GPU accelerated effects, mogrts, essential graphics text, graphics, etc., you need to keep those processes in mind. If you push it too much (like running two or three monitors on top of all these GPU processes), I think it's why you see these issues.

Say, have you tried smart rendering? That could offload many of those processes and make your workflow smoother. Different, and may take a bit more time and way more drive space (temporarily), but smoother—just a thought.

 

Thanks,
Kevin

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 12, 2022 Apr 12, 2022

Copy link to clipboard

Copied

Hi guillaumec44441302,

A new version of Premiere Pro was released today with bug fixes for the M1. It hasn't hit everyone's Creative Cloud app yet, but please try it out once it does. Also, try the latest beta release to see if it provides some relief to your performance issues. 

 

Remember that the M1 baseline Macs have decent performance but only around the same GPU capability as an NVIDIA 1650 Super. If you push accelerated graphics processes hard, you might see some GPU-related issues. 

 

It may take some workflow adjustments to fully work around the issues you are having trouble with, like transcoding or exporting to other codecs (I use smart rendering) while we wait for the software devs to fix more issues. It's what I am doing with my M1 workflow for personal projects.

 

I'm not on the Premiere Pro team, and these are user to user forums, but you can provide feedback directly to the devs on User Voice here: https://adobe-video.uservoice.com/forums/911233-premiere-pro

 

Sorry for all the issues you are experiencing. Frustrating, especially after waiting so long for new hardware from Apple. I am in the same situation with my M1.

 

Thanks,
Kevin

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 14, 2022 Apr 14, 2022

Copy link to clipboard

Copied

I just did the update and the glitches continue to exist while they are not on the Beta

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 14, 2022 Apr 14, 2022

Copy link to clipboard

Copied

Hi @lucau8082445 ,

 

Thanks for checking the fixes in beta. This is on track to be available in normal builds too. I will update you when it is pushed to normal build updates. 

I hope it will help.

Thanks,

Mayjain

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Sep 07, 2022 Sep 07, 2022

Copy link to clipboard

Copied

Did anyone find a solution to this? I just purchased a new M1 Max Macbook and suddenly Premiere Pro isn't exporting properly, using the same sequences/settings as my previous Mac. 

 

I'm this close to sending the computer back...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 08, 2023 Dec 08, 2023

Copy link to clipboard

Copied

LATEST

End of 2023 and now I also strat getting this issue...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines