Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Premiere Pro lag after upgrade to Big Sur

New Here ,
Sep 03, 2021 Sep 03, 2021

Copy link to clipboard

Copied

I am having problems with Premiere being sluggish, previously I could play a video and the play head would smoothly move along the timeline, I could stop playback and the play head would be exactly where I stopped, so I know where to precisely add a video clip, text, or new music for example. In March-ish (not sure exactly when) I had updated to Big Sur, and eventually I started to notice that instead of playing smoothly the playhead would skip along every 1/2 second. All the hardware was the same, just the OS has been updated. I know Adobe is transitioning software to the Big Sur Codebase, maybe eliminating some older code (32bit? I know Big Sur depreciated something?) so I thought maybe the kinks would get worked out with updates, but this is still happening, and now my Illustrator seems slower as well as After Effects is sluggish… It's to the point that I can hardly work!
 
When I did install Big Sur in March, I had booted off a USB drive and erased my internal hard drive, then reinstalled all the software, Yesterday (Sept 2, 2021)  I did the same, wiped the drive and reinstalled Big Sur, upgraded to the latest OS, and downloaded fresh copies of the Adobe software, so in theory this should act like a new machine. And for a moment it did play back smoothly, but they it started doing the same thing!
 
I have previously searched out answers and there was something with deleting preferences, and cache files, and it did fix things for a moment as well, but nothing seems to be a permanent fix... which is what I'm looking for. Most comments include things like a slow hard drive, or not enough RAM, this is a nearly maxed out machine, older now, but still fast.
Any help you can provide Adobe, thanks!

Machine specs
iMacPro1,1 10-core Xeon W 3Ghz, 128GB ram, 1TB SSD (internal drive) Pegasus R-series thunderbolt 2 – 8 drive raid (5) with about 800MB read/write speeds. Running Big Sur 11.5.2 and Premiere Pro 15.4.1/After Effects 18.4.1
TOPICS
Editing, Freeze or hang

Views

27

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 03, 2021 Sep 03, 2021

Copy link to clipboard

Copied

LATEST

I should add, I'm even having this issue playing back a single track of music in Premiere, so it's not that I'm pushing the maching with effects and 12k footage, this is base level editing that is now suddenly a problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines