Premiere Pro Lag and Won't drag clips or effects

New Here ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

Hey there.

 

I am hoping someone has help for this. Running the latest version of PP. My Mac (which has plenty of RAM/memore and a more than sufficient processor and graphics card) is up to date. Cache is cleared. I've tried redoing my sequence settings and project settings NOTHING helps. 


I actually did my latest MAC update when I noticed this issue starting. Nothing helped. 

EVERYTHING is lagging when I try to use the hand/grab tool. I can't place clips in timeline, they stop following the mouse movements. I try to bring effects onto clips, and they won't stick. It takes me like 6 times to get one to apply to clips. 


This is driving me CRAZY. 

 

I've read everything I can find online. Nothing has helped. 

 

At this point, I'm planning on giving up on PP and just using my Davinic Resolve Studio version moving forward. Honestly, it has far better color grading, the editing capability is comparable at this point to PP and I have never had issues like these in the 7 years I've been using that. (on PP for about 2.5) 

The only Adobe featuer I need is the Remix tool in AA. 

 

Any suggestions? I have 4 large projects I am halfway into in PP so I need to finish them before I can jump ship entierly. 

 

Thanks!

TOPICS
Error or problem

Views

87

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

Hi default2xdw06fvbyz9,

Sorry for your issues. First of all, this is chiefly a user-to-user forum. We are in support and try to help here whenever possible. I hope we can do that.

 

My Mac (which has plenty of RAM/memore and a more than sufficient processor and graphics card) is up to date. Cache is cleared. I've tried redoing my sequence settings and project settings NOTHING helps. 

 

Thanks for the info. Is it possible to know the specifics of the Mac, its OS, and the media you are cutting with? Thanks.
 

I actually did my latest MAC update when I noticed this issue starting. Nothing helped. 

 

So everything was fine until you updated to macOS Monterey?

 

EVERYTHING is lagging when I try to use the hand/grab tool. I can't place clips in timeline, they stop following the mouse movements. I try to bring effects onto clips, and they won't stick. It takes me like 6 times to get one to apply to clips. 


That's not normal. I would try this in a brand new project and see if you have the same issues. If so, something else is amiss. Typically, the one thing you see in macOS is that existing projects can go awry after you update.

 

If the behavior is not present in the new project, try importing the previous project into this new one so that your ability to use the tools, etc., will work again.

 

If things are still wonky, you can repair folder permissions, which is good practice for Mac users after updating any version of macOS - at least it's been that way in my experience. Check out this article: Premiere Pro CC freezing on startup or crashing while working (Mac OS X 10.9, and later)

 

I hope it helps you get back on track.

 

I read that you've been using Premiere Pro for a long time with few issues until now. Cool. For me, resetting preferences regularly, clearing media cache with all projects closed, repairing disk permissions, maintaining Scratch Disks, and repairing folder permissions have helped me achieve excellent stability with Premiere Pro on personal projects on all my Macs. 

 

The only Adobe featuer I need is the Remix tool in AA. 

 

Remix is now inside Premiere Pro. There is also a Remix tool available. Pretty cool.

 

Thanks,
Kevin

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 17, 2022 Mar 17, 2022

Copy link to clipboard

Copied

LATEST

Hey Kevin

 

These issues in PP started BEFORE I upgraded to the latest Mac OS. It's why I upgraded early (I usually wait until version .2 or .3 to avoid the first round bugs but was hoping the upgrade might resolve it) The issues persisted after I upgraded so upgrading did nothing to affect it, good or bad. 

 

My Macbook Pro has:

a 2.3 GHz 8-Core intel Core 19 Processor

32 Gb 2667 MHz DDr4 Memory

Intel UHD Graphics 630 1536 MB Card

It's about 2 years old. 

 

No apps are eating up space or bandwidth. There is plenty of memory and ram. I had issues with the Monterey update (being the first rollout) and while that didn't change anything in PP we did a deep dive on my mac to check such things so I know those aren't the problem (it took reinstalling the newer version of Monterey to resolve those bugs) Mac Update is entirely unrelated to this issue. 

 

It got better for about 10 minutes after re setting my preferences (ie holding the option key down when rebooting PP) but then came right back. But that was a huge pain of course as it wiped all my projects from my homebase and I had to reconnect everything. So I'd rather not do that again as it didn't solve it anyway.

 

It's really bad. I'll drag a clip (doesn't matter from what panel it happens in every window) into the sequence timeline and it will stop following the curser (ending up in the wrong place) and I can't move it back or foward so I have to release it then of course it overrides what's under it and I have to undo the action.

 

It's happening with all effects tho as well. I try to grab a tansition or cross fade or whatever, and it looks like it's grabbed it, but I bring it over to the clip and...nothing. I do it again and again and eventually it will drop. But often it's dropping in the wrong file. The one below let's say if it's audio or the one to the left or right if it's video. It's as if someone put cork board down on a roller skating floor on every corner. It just sticks and stops and doesn't follow through on the action.


It's basically this horrible lag and pause that is happening primarily with the curser and not as much (but still) with other controls like ripple delete/all tracks forward etc. But it's the most pronounced and making editing unworkable with the drag and drop.

 

I've cleared the cache every time I open PP to work. It's not that. 


It's a bug. 

 

And it's become unbearable. 

 

Thanks for your insight! 

 

And hope that's more clear. 

 

Lara

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines