• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
3

Premiere Pro Lagging on 64gb RAM, CORE I9 12900H, RTX 3070

Community Beginner ,
Jan 03, 2024 Jan 03, 2024

Copy link to clipboard

Copied

Hello, my premiere pro lags badly, i have changed to several codecs including apple prores and it still lags.

My pc is 64gb ram, core i9 12900h, rtx 3070,the footage is 30fps, 2k, i have converted it to various formats and also converted it to 1080p, it still lags on primere, but davinci resolve plays it buttery smooth, my davinci even plays 4k really smooth.

I have done all possible options and solutions i found on the internet and still nothing. I have downloaded several versions of PR and still lags!

Help please, i have a deadline.

TOPICS
Crash , Editing , Formats , Freeze or hang , Hardware or GPU , Performance

Views

679

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 03, 2024 Jan 03, 2024

Copy link to clipboard

Copied

Hola, al parecer es un problema de actualización de drivers en tu tarjeta gráfica.  Quizás ese sea el problema.
Saludos 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 03, 2024 Jan 03, 2024

Copy link to clipboard

Copied

Hello, i have updated the drivers on my graphics card twice, still the same problem.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 03, 2024 Jan 03, 2024

Copy link to clipboard

Copied

Have you tried setting default audio input to none? That fixes a lot of lagging at this time ...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 03, 2024 Jan 03, 2024

Copy link to clipboard

Copied

Yes, i have tried that, it still lags.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 03, 2024 Jan 03, 2024

Copy link to clipboard

Copied

Delete the Media Cache and Media Cache files:
https://community.adobe.com/t5/premiere-pro/faq-how-to-clear-your-media-cache-in-30-seconds-in-premi...

If that doesn't work, try resetting the preferences:
https://community.adobe.com/t5/premiere-pro/faq-how-to-reset-trash-preferences-in-premiere-pro/td-p/...

If that doesn't work, try resetting the Workspaces:
Reset a workspace
Reset the current workspace to return to its original, saved layout of panels.
1. Do one of the following:
• Click the Workspace menu icon and select Reset to Saved Layout.
• Choose Window > Workspace > Reset to Saved Layout.
from here:
https://helpx.adobe.com/premiere-pro/using/workspaces.html

If that doesn't work, try Preferences > Audio Hardware and set Input to None.

If that doesn’t work, try updating or rolling back your graphics driver directly from the video card manufacturer’s site. If NVIDIA, do a clean installation of the latest Studio Driver (NOT the Game Driver).

If that doesn't work, try creating a new project and import the old one into it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 04, 2024 Jan 04, 2024

Copy link to clipboard

Copied

Hello, i tried all of this and it is still slow and lags, plase help.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 04, 2024 Jan 04, 2024

Copy link to clipboard

Copied

Hi @Oladipupo31207727fygx,

I read your message. How about your storage? Do you have fast internal storage or are you connected to external storage? What are the specs and connectivity of these hard drives? How full are the drives? 

 

Is High Quality Playback engaged in the Settings menu in the Program Monitor? If so, disable it. Have you tried dropping the playback resolution to 1/2? That can help. 

 

Let us know if any of these things work.

 

Thanks,
Kevin

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 04, 2024 Jan 04, 2024

Copy link to clipboard

Copied

Hello Kevin, thank you for your reply.

 

my internal storage is 2tb ssd, and i still have 1.4tb left. High quality playback is not enagaged and i have dropped playback resoution to1/4 and it still lags.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 04, 2024 Jan 04, 2024

Copy link to clipboard

Copied

Are you running any other programs at the same time?

Michael Grenadier
917-362-3396
*www.michaelgrenadier.com <>*
mgrenadier@gmail.com

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 04, 2024 Jan 04, 2024

Copy link to clipboard

Copied

Good point, @Michael Grenadier - Avoid any programs or browsers concurrently with Premiere Pro? The big ones are Google Chrome and Spotify. These will rob your GPU cycles and can ruin performance.

 

Thanks,

Kevin

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 06, 2024 Jan 06, 2024

Copy link to clipboard

Copied

my PC can handle that because it is 64gb of RAM. 

 

My Davini Resolve plays 8k raw footage smoothly no matter how many porgrams i open.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 06, 2024 Jan 06, 2024

Copy link to clipboard

Copied

I am but my PC can handle that because it is 64gb of RAM. 

 

My Davini Resolve plays 8k raw footage smoothly no matter how many porgrams i open.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 05, 2024 Jan 05, 2024

Copy link to clipboard

Copied

Hello Peru Bob

I was also facing this problem I have get solution from your answer 

thanks.,

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 06, 2024 Jan 06, 2024

Copy link to clipboard

Copied

@Muhammad33700102gqms 

You're welcome. icon_smile.gif

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 04, 2024 Jan 04, 2024

Copy link to clipboard

Copied

Have you tried a proxy workflow?  Although that isn't a solution, it can be a simple workaround.   If you need any help implementing it, post back.  I work on a variety of systems (both mac and pc) and provide support for a number of clients, so I usually begin a project by creating medium or low resolution proxies.  I prefer an all i-frame format like prores propxy...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 04, 2024 Jan 04, 2024

Copy link to clipboard

Copied

Yes, i have tried a Proxy workflow and it still lag.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 04, 2024 Jan 04, 2024

Copy link to clipboard

Copied

And do you have multiple monitors connected? If so try working with only
one monitor. This is a troubleshooting step. If that solves the problem we
can figure out how to proceed

Michael Grenadier

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 04, 2024 Jan 04, 2024

Copy link to clipboard

Copied

Agree @Michael Grenadier - multiple monitors can cause degraded performace, especially if there are any overlapping windows, even if it is by only a pixel. Using a single monitor when troubleshooting performance issues is vital. Cheers, good brother.

 

Thanks,
Kevin

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 06, 2024 Jan 06, 2024

Copy link to clipboard

Copied

I use just one monitor.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 06, 2024 Jan 06, 2024

Copy link to clipboard

Copied

Comparing performance between Premiere and Davinci Resolve is not that useful...  These programs are built very differently from the ground up and each has their advantages and disadvantages.   Personally, I've invested many years learning the ins and outs of Premiere and have no desire to start over in Resolve, but I do find it a much better solution for color correction and will often go to resolve for the final touches.  If you find resolve works better for you maybe that's the way to go for you...  but we're here and hoping to get you over the hump.  

 

It's never easy to troubleshoot from a distance and it's very easy to miss a potential cause...  I mainly work on a mac, but do have a windows machine which I use occasionally so I'll try and throw some things out.  Please approach these ideas/questions in a systematic fashion.   And as I said earlier, these are troubleshooting steps.  Once we figure out what's causing the issue, we can try and figure out a solution/workaround.

 

Do you have any peripherals connected besides keyboard and mouse?  If so, try disconnecting them.   If you've installed any software associated with peripherals, let us know about it.

 

Try creating a new windows user account with administrator privileges and see if that helps.  Sometimes apps will add some stuff when you startup your computer that can cause issues...   new user account will usually avoid that.

 

Try disconnecting from the network by pulling ethernet cable and turning off wifi

 

Do you have an external ssd you can try?  Might be useful to get a diskspeed test app and see what your performance on your internal drive is.  Not as much of an issue as it used to be, but back in the day, it was recommended that you keep your media on a seperate drive from your startup drive.  

 

Are you using wireless keyboard and/or mouse?  If so, do you have a wired alternatives you can try and turning off bluetooth?

 

And try restarting your computer and see if you find any difference in performance.   

 

Let us know if you see any differences in performance when you try these things and I'm sure we can come up with some other things to try.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2024 Apr 12, 2024

Copy link to clipboard

Copied

LATEST

Hi all, I'm having the same problems as the OP but with programme hangs & random crashes. Any help would be amazing as it slows down my work significantly.

Core i9 13900K, RTX 3060, 64gb RAM & separate system & video footage drives (both internal)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines