• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Premiere Pro Lags in few minutes

Community Beginner ,
Jan 10, 2023 Jan 10, 2023

Copy link to clipboard

Copied

Hi all,

 

This is the firts time I am seeking help from fellow experts.

 

Issue:

Premiere Pro starts lagging in a few minutes, irrespective of number of layers or effects, be it heavy or light project. The timeline stutters and each command takes about 1-2 secs to execute, any simple command too like go to in, next/previous cut, stop. 

 

Sicne When:

Many months. Had assembled the system in Oct 2019 and it was fine other than normal lag when using 4k. Now it lags even while scrubbing a Zoom recording footage without any edits.

 

System:

Processor-i7 8700k, RAM-32GB Trident Z RGB(replaced last week), C Drive: Samsung 970 Evo Plus (replaced last month), GPU-1060 3 GB, B360M Gaming Motherboard...

 

I replaced my M.2 (boot and application drive) last week of December

Replaced RAM from 16 GB to 32 GB (last week)

Reinstalled OS (by default while changing the M.2)

Kept the system/cabinet open for air to pass

Updated all drivers

Windows 10 is updated - using an OEM Windows 10 license.

 

Really cannot understand and request some expert advice/help on it please please...

 

Regards

Manish Kushalka, [personal info deleted by MOD]

TOPICS
Editing , Freeze or hang , Hardware or GPU , Performance

Views

167

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 10, 2023 Jan 10, 2023

Copy link to clipboard

Copied

Can anyone pl help identify the reason for it, strangely every time I restart Premiere Pro it works smoothly for a minute or so and then suddenly starts lagging again

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Jan 11, 2023 Jan 11, 2023

Copy link to clipboard

Copied

This is a software bug of the new version. Nothing can be done here. It all depends on the engineers when they finally fix this oversight, which has been going on since 2022. My advice is to switch to DaVinci and you will find out the level of the software and how they treat the product there. I'm happy

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 11, 2023 Jan 11, 2023

Copy link to clipboard

Copied

Thank you for your advice, tired of consulting hardware and software experts - was on the verge of changing the Motherboard and GPU next to resolve - but I guess its better to resort to 'Resolve' to resolve it... thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 11, 2023 Jan 11, 2023

Copy link to clipboard

Copied

Hi Manish,

Sorry for the frustration. I wager that the media you are using is H.264 and may have a variable frame rate.  If this is the case, your computer is not outfitted with the components for smooth operation with that format (especially with 4K footage). My advice is to either transcode the footage to ProRes LT or create ProRes Proxy proxies. Let me know if you need help doing so.

 

Thanks,

Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 17, 2023 Jan 17, 2023

Copy link to clipboard

Copied

LATEST

Hi, as mentioned in my query, the sisue is NOT related to variable frame rates. Even with a single clip of 25fps Full HD at times the project lags. It works smoothly immediately after restarting Adobe Premiere Pro. Have formatted my OS, reinstalled Adobe Suite 3 times, changed the RAM entirely, all in a week - still the problem persists. This is purely a BUG IN PREMIERE PRO.

 

NOW STRANGELY - after a lot of experiments, I have noticed that the problem does not arise much if you are using the Default Workspace of Premiere Pro.

 

VERY STRANEG - SO PREMIERE PRO 'SCIENTISTS' NEED TO WORK ON THE BASICS OF IMPROVING AND MAINTAING THE BASIC AESTHETICS FIRST AND THEN THINK OF ADDING MORE TO THE SOFTWARE.

 

At this pace, I believe that Premiere Pro has started dying just what happened with FCP earlier - Fame to Dust in a few months.

 

If Adobe Engineers are reading this - please get your basic functionaries working smoothly within the application. Most users are facing some silly issues since last one year. 

 

And YES - Da Vinci Resolve Ijust tried to learn and was surprised at the speed at which it reads data within the applciation. It is super smooth - I wish it was true for my Premiere Pro.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines