Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Premiere Pro on M1 BlackMagic UltraStudio Monitor 3g

Community Beginner ,
Aug 13, 2021 Aug 13, 2021

Copy link to clipboard

Copied

HELP!

All of Adobe's software works perfect on my 2020 M1 Mac Mini.  I'm running big sur 11.5.1.  I use the BlackMagic UltraStudio Monitor 3g (USM3g) for output through my SDI Flanders Scientific monitor.  

 

My USM3g device works with several apps, including After Effects.  BUT... the latest version of Premiere (15.4.0) will not even SEE the USM3g device in video playback... but it DOES see the USM3g device in Audio Hardware. 

 

*** The only way I can get Premiere to see the USM3g device is if I use a previous version of the software... which of course is completely unacceptable since I have many projects built with the latest software version.***

 

NOTE:  every time I open Premiere I am seeing an event warning:  "A low-level exception occurred inL (Transmit::Startup)

 

All permissions have been released to Premiere.  I have reset preferences in Premiere and have even reinstalled premiere!  Nothing is fixing this issue.  I am running the latest driver for the USM3g device (released in May) and I have called BlackMagic to attempt several reinstalls of the device.  NOTHING.

 

AGAIN... After Effects sees the USM3g device... but not Premiere.  SO, all signs point to some sort of issue with Premiere.

 

Is anyone experienceing this issue?   Please advise.  
Thanks!!

TOPICS
Editing, Error or problem, Export, Hardware or GPU, How to, Performance

Views

338

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Aug 13, 2021 Aug 13, 2021

Copy link to clipboard

Copied

I think the M1 is still going through a trial and error phase. Does the BMD product work on none M1 Macs? It could be an OS issues or it could be Adobe. You can make a bug report to both Apple and Adobe.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 13, 2021 Aug 13, 2021

Copy link to clipboard

Copied

Yes the BMD works on the M1.  The latest driver included M1 upgrades.  Like I said, I am on the M1 Mac Mini.  The 3g device is seen and works great with After Efffects and another app... but premiere doesn't see it.

 

A Big Sur update just released... so I'm updating.  We'll see if that fixed the issue.

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 13, 2021 Aug 13, 2021

Copy link to clipboard

Copied

I updated Big Sur to 11.5.2... and premiere STILL will not see BlackMagic.  

 

Actually, Character Animator will not see BlackMagic UltraStudio Monitor 3g either.  WHY does this work for After Effects but NOT any of the other Adobe apps????

HELP!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Aug 13, 2021 Aug 13, 2021

Copy link to clipboard

Copied

It could be the OS  or it could be Adobe. Go to Best Buy or the Apple store and test it out on a none M1 Mac using BMD's Media Express. If it works on an intel iMac it is the M1 hardware. If it does not work on the Intel Macs it is the OS. On a side note I tested a FireWire DV converter at the Apple Store (video below)

https://www.youtube.com/watch?v=rHWHE3ilBbU


Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 16, 2021 Aug 16, 2021

Copy link to clipboard

Copied

I'm having a similar problem with Ultrastudio 4k mini, + Premiere Pro + M1 MacMini. I am also outputting SDI to a Flanders monitor. It works perfectly with DaVinci Resolve Studio, but not with the latest Premiere Pro, or the Premiere Pro Beta. It's pretty annoying. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 16, 2021 Aug 16, 2021

Copy link to clipboard

Copied

I'm 100% certain the issue is with Adobe.   ALL of the older versions of Adobe see the BMUS3g device.   Everything is updated.  My OS sees the device.  Media Express sees it.  Even the currect version of After Effects sees it.  But none of the other latest-release Adobe products do (Even though they can follow the system audio to the device).  Glad to know I'm not the only one.   

 

ADOBE!  Get on this! LOL

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 16, 2021 Aug 16, 2021

Copy link to clipboard

Copied

Skygate,

I am not seeing Premiere Pro 15.4 on the list of supported applications on the BMD site for M1 Macs. It looks as though the page on their site only lists Beta 2020 as the last functioning supported software for v.12.1 of their software.

Therefore, aside from the fact that it works with one of our other apps, but not others, I would really reach out to their support team as a source of a driver that might work in current versions of Premiere Pro. Let us know what they say. In the meantime, I will make sure a bug is filed.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 16, 2021 Aug 16, 2021

Copy link to clipboard

Copied

Their latest driver was actually from May 20, 2021.  It didn't work with Premiere prior to the latest update a few days ago.  I have been on the phone with BlackMagic a couple of times... and yes... its always a dance between primary apps and the supporting ones.  Growing pains, I'm sure... in the meantime... we're stuck until SOMEONE updates.


Thank you!
Scott

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 24, 2021 Aug 24, 2021

Copy link to clipboard

Copied

Have you tried the Premiere Pro beta yet? Looks like the latest non-beta version of Premiere is not supported.

 

From the BlackMagic site: https://www.blackmagicdesign.com/support/readme/d99c3a1740b546f094ffbb30ddf1f4c1

Third Party Software Support

M1 Macs:

  • DaVinci Resolve 17.
  • Fusion 17.
  • Apple Final Cut Pro X.
  • Adobe Premiere Pro 2020 beta.
  • Adobe Photoshop CC 2021.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

Hi! 

 

Exactly same problem here.

 

All soft M1 apple Silicon compatible:

Mac Mini M1 Big sur v11.4

Ultrastudio Monitor 3G v 12.1

Premiere Pro for M1 v 15.4.0

 

Audio device detected but not video device.

 

Think BMD need to update drivers for Premiere 15.4 M1 or Adobe issue?

 

Thanks,

Mario.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 10, 2021 Sep 10, 2021

Copy link to clipboard

Copied

Exactly the same problem here.

 

Mac Mini M1, 2020

Big Sur 11.4

Adobe Premiere Pro 15.4.1

Blackmagic Ultrastudio 4K Mini

Desktop Video Setup Version 12.1

 

Works great in Resolve, but not in Premiere at all. Audio device detected, but no video device. 

My temporary solution: Open Premiere in Rosetta, then it will see the Ultrastudio as a video playback option again. Of course not a satisfying solution as the performance gain is obsolete. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 10, 2021 Sep 10, 2021

Copy link to clipboard

Copied

Are you running the Premiere beta on your M1 Mac? The Desktop video app is not currently compatible with the latest version of Premiere. It should work in the beta. Please refer to the Desktop Video release notes, I've linked them above.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 10, 2021 Sep 10, 2021

Copy link to clipboard

Copied

I tried also with the latest beta version and it's not working...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 10, 2021 Sep 10, 2021

Copy link to clipboard

Copied

Yeah, hasn't worked for me in the beta either. I think it works a couple Premiere versions back, but we sacrifice the m1 optimization.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Hi!

Agree, video output only work for me on intel Premiere using Rosseta.

We need a workaround for Apple Silicon Video output on Premiere, so we can
jump into latest version.

Thanks,
Mario.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

I am running 15.4.1. All I see when I go to "other versions" in the Creative Cloud are the version numbers. How do I know which one of them is 2020 Beta?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

You have to go into the Beta apps tab of the CC Desktop app. You have to opt into seeing the betas.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 13, 2021 Sep 13, 2021

Copy link to clipboard

Copied

Thanks! Can confirm now... doesn't work for me in Beta either. So until now opening with Rosetta is the only option... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 20, 2021 Sep 20, 2021

Copy link to clipboard

Copied

Just encountered the same problem here with ultrastudio mini 4k.

It is solved on my M1 by open the intel version of premiere 2021. 

the 3 little dots in cloudaplication will give you access to open as intel.

 

good luck.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 20, 2021 Sep 20, 2021

Copy link to clipboard

Copied

Yes indeed!  YES, INDEED!!!!  FANTASTIC!

Thank you, @ulfw61854189 for the heads up!

 

Scott

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 20, 2021 Sep 20, 2021

Copy link to clipboard

Copied

Hi!

 

Yes, that's correct.

 

But using an intel version on a M1 it's just a workaround not a solution.  Performance issue.

Right now all software is final, not beta and video output still not working.

Let's see next Premiere or Blackmagic drivers update...

 

Thanks,

Mario.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 20, 2021 Sep 20, 2021

Copy link to clipboard

Copied

LATEST

@ulfw61854189 Anyway to make the intel veresion the default on open?  I have to open through creative cloud and THEN open the project.


Scott

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines