• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Premiere Pro Poor Performance (tearing, lagging). Nothing Seems to Fix It. Please Help!

New Here ,
Feb 15, 2023 Feb 15, 2023

Copy link to clipboard

Copied

Alright, I feel I've just about run out of every option, so here I am to ask for help from all of ya'll. 

 

For about a year and a few months now, I've been using Premiere Pro to edit my videos (mostly of gaming). For the first year everything went fine- the program worked with no problems, and I started to feel really confident in using the program after a while. Perhaps the reason I’m so devastated now is because of how much I came to love and rely on this program, which I may have to abandon if this last-ditch effort doesn’t work.

 

Over Christmas, I was gifted a new-ish computer. It has far better parts then my old one did, which meant my gameplay was going to be 10x greater than before. After redownloading all that I needed to, I was really excited to get back into editing my new-and-improved gameplay footage that I’d recorded. However, right off the bat, I noticed that something was wrong with Premiere. The playback footage tore like crazy, and there was insane lag whenever the video passed over an effect on the timeline (most notably, the effect I was trying to use was the cross-dissolve transition. It doesn’t seem to be affected by text at all, or moving text).

 

The tearing was more or less ok. It was extremely annoying to me, who had to watch the playback like my eyes were spazzing out- but it was more or less tolerable. Whenever I exported the video, the tearing and lag through transitions would always clear up, so I just don’t understand what’s up. The real problem I guess has to be the lagging problem. I need to be able to see my transitions/edited effects before I export, because I can’t just export long videos every time I want to see how it looks. 

 

Whenever the video goes over a transition (be it big or small), it starts to lag extremely, or just stops altogether. Then, trying to click anywhere else on the video to get clear of the lag, it still takes the program a few seconds to start the playback again, like it’s thinking really hard about it.

 

I can’t stand it any longer. I feel like I’ve exhausted every resource/tip/trick under the sun to get these problems to cease, but nothing’s working. I even called Adobe Tech Support, who did the same things to try to fix the program that I did, and then told me to contact my graphics card provider customer support. I admit, I haven’t done that yet. But since calling Tech Support I did upgrade to a better graphics card, and one I made 100% sure was on the list of Graphics Cards compatible with Premiere Pro (I even drove to a different state to get it). But, to no avail. The problem persisted. If it really is a problem with the graphics card, then I’d be pretty dang surprised, honestly. I’ve got AMD Software: Adrenaline Edition on my computer, which tells me that the Premiere Pro program is running ‘marginally’ as well, if that means anything.

 

I’ve literally tried it all and I’m so, so tired. I’ve been having these problems for over two months now, and at this point I’m about ready to give up. I don’t want to, because I really love this program (and I reallyyyyy don’t want to have get comfortable with a brand new one ;-;). I cannot keep paying for a program that doesn’t work.

 

I’m using Premiere Pro 2023 on Windows 10

CPU: AMD Ryzen 7 1800X Eight-Core Processor

GPU: AMD Radeon RX 7600 XT

 

I’m looking for any and all helpful tips ‘n solutions, but I’ve already tried so much, and I’m not entirely certain how helpful this post is gonna be :’)  If no one has any info on what may help with Premiere, I’m also open to recommendations to other good video editing programs in the meantime :’’)

 

Thanks for reading.

Views

198

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Mar 19, 2024 Mar 19, 2024

Hello @Moth27736748m397,

Thanks for the message. Are you still having this issue? The team will need more info from you to reproduce the bug. Can you provide the information required here? What kind of media are you using? Is it 4K H.264? From which camera? How do I write a bug report?

 

I'll move your post to the Discussions board while we await your information.

 

Thanks,


Kevin

Votes

Translate

Translate
Adobe Employee ,
Mar 19, 2024 Mar 19, 2024

Copy link to clipboard

Copied

LATEST

Hello @Moth27736748m397,

Thanks for the message. Are you still having this issue? The team will need more info from you to reproduce the bug. Can you provide the information required here? What kind of media are you using? Is it 4K H.264? From which camera? How do I write a bug report?

 

I'll move your post to the Discussions board while we await your information.

 

Thanks,


Kevin

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines