• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

PREMIERE PRO RUNNING SLOW. NOT THE VIDEO ITSELF.

New Here ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

I am having a issue with the response of Adobe Premiere Pro ITSELF and not video playback. When I hit the spacebar, it takes about two to three seconds for it to stop/play. cutting is the same. Often I will switch from the cut and selection tool and It cant even keep up. I have absolutely never had this problem ever and this morning it just started happening out of nowhere. Please help. Also I am using a 2021 Imac with 32 GB RAM editing 1920x1080 footage. Simple and easy project. Like I said I have edited over 600 videos without any issues until now and that was on a 2017 Imac with only 16 GB Ram and not the greatest specs.

TOPICS
Freeze or hang , Performance

Views

2.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

Hi OreyBorey5FEE,

 

Sorry for your issue.

Please try the basic maintenance-

  1. Clean media cache: https://community.adobe.com/t5/premiere-pro-discussions/faq-how-to-clear-your-media-cache-in-30-seco... 
  2. Reset the preferences: https://community.adobe.com/t5/premiere-pro-discussions/faq-how-to-reset-trash-preferences-in-premie... 

Let us know if it helps.

 

Thanks,

Nishu

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

This didnt help at all. It still is super laggy. I even actory reset my computer so there was no reason for it to lag because of memory. and it still lags

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 02, 2021 Sep 02, 2021

Copy link to clipboard

Copied

Hi there! Does it happen with a specific project? Can you copy your project and import it in a fresh new one?

 

Let us know how it goes.

Thanks,

Kartika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 09, 2022 May 09, 2022

Copy link to clipboard

Copied

Was this issue resolved for OreyBorey5FEE?

 

I am suffering form the same issue.  It is not specific to any one project.  I have flushed the preferences and media cache and the problem persists. 

 

2.7 GHz 12-Core Intel Xeon E5

64 GB RAM

AMD FirePro D700 6GB

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 10, 2022 May 10, 2022

Copy link to clipboard

Copied

Hi Jay,

Have you tried updating to 22.4? It has performance enhancements for AMD GPUs, macOS and certain kinds of footage, so that could help.

 

Thanks,
Kevin

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 06, 2022 Jun 06, 2022

Copy link to clipboard

Copied

Hello Kevin,

Thank you for the response.

The update to 22.4 did not resolve the issue and I have since experienced this problem on another computer with a different configuration.

MacBook Pro | OS 12.4 | 2.4 8-core i9 | 64 GB ram | AMD Radeon Pro5500M 8GB

I have tried a new Mac Studio and the problem does not occur with Apple Silicon - Just Intel-based Macs.

I’m not sure what sets off the sluggishness. I have tried to determine the cause but it appears to come out of nowhere.
The app also does not like when you have "hide the menu bar” in system preferences - if your cursor gets into the territory where the menu bar appears, it rapidly switches between the standard cursor shape and a resize shape for a second or two, after which you can see a noticeable reduction in UI responsiveness.
That, to me, was the indicator that things weren’t working properly.
I de-selected menu bar hiding in system preferences and quit and restarted the app.
The problem appeared again in any case.
Playback performance does not seem to be affected, nor are keyboard shortcuts (command+s, command+m, etc.) - the sluggishness is relegated to the UI.
Slowdowns occur when trying to drag a clip to a sequence or within a sequence, when trying to switch workspaces, when trying to drag and apply an effect, when trying to adjust effect parameters, when trying to rename sequences.
The delays are such that if you don’t drag a clip and hold steady until you see the clip arrive to your cursor location, the clip will likely land where you don’t want it to creating the need to perform undo and try again.
This makes it difficult to use Premiere efficiently.

The only resolution is temporary - to quit the app and restart - The recurrence of the problem is only a matter of time.

It would be most welcome and beneficial for this issue to be resolved.

Thank you,
Jay

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 18, 2023 Jan 18, 2023

Copy link to clipboard

Copied

I have exactly this same problem.
It is very difficult to work with the program and I'm slowly but surely giving up. I click on something on Timeline and I have to wait a second to catch. I will move the shot and I have to wait until it arrives. I thought my computer went wrong and I would have to buy a new one but I see that I am not alone.

Intel i7
32GB RAM
NVIDIA GeForce 6GB
Project on SSD 1TB 
It does not matter where I have a project on which SSD. Premiere is still slow.

 

Everything worked nicely until one day slowly slowed down. In addition, I have a problem with the render, I have to give software encoding because if I give hardware so H264 can not play and has 24bit. I am simply completely destroyed from this program. I also use Davinci for Coloring but I am already learning to editing as well because ...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 19, 2023 Jan 19, 2023

Copy link to clipboard

Copied

I'm suffering from the same symptoms too on a 2020 i5 27" iMac. Editing in ProRes LT. Heavy and slow editing performance, a delay of at least 2 seconds on any action. It's executiating!! Adobe PLEASE help, the Intel machines need good performance too!! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 23, 2023 Jan 23, 2023

Copy link to clipboard

Copied

Hi, I started having the same issue. I was stuck. However, I noticed that the top menus were working perfectly fine, so I decided to switch the workspace from vertical to essential, and that fixed it up. Try switching workspace and see if it works. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 23, 2023 Jan 23, 2023

Copy link to clipboard

Copied

LATEST

Having the same issue, timeline in focus and pressing the space at during playback does not stop the play head at the right spot. I'm also having an issue where I can do 4 or 5 shortcuts in a row and the timeline keeps playing, then a few seconds later the app executes the commands. 

Moving back to PrPro from resolve has been an exercise in patience. Rebooting the app seems to solve temporarily. 

I'm working with proxy media with one single track and the only effects are primate 6. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines