• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Premiere Pro Suddenly Starting to Lag!

New Here ,
Dec 19, 2022 Dec 19, 2022

Copy link to clipboard

Copied

Hi there,

 

I just started using PP this year as as wedding videographer. I film on a C200 all in 4K across the board (drones, second cams, etc) 3 months ago I got practically a maxed out Mac Studio with 128GB ram, M1 Ultra chip, etc. For the first few months with PP it worked effortlessly.....cutting through 4K footage like butter. I generally don't have a massive amount of footage from a wedding since sometimes I'm filming solo with 1 camera, but even on certain shoots where I had multiple cameras, drones, audio, etc PP would work just fine with pratically zero issues.

 

However, the last few days I have experienced extreme lag when playing back any footage when logging it or editing it. I can't even scrub through it....and wehn I play a clip it starts fine but then starts to show lag and skip around, dropping frames, audio, etc. I know the usual steps on lower playback res, proxies, etc. But honestly with my Mac I never had to do any of it since it could handle it so well nor should I. The specs should be more than enough to handle my workflow.

 

Just wanted to ask the question here on why all of a sudden PP is showing lag when it never did before? I've probably edited almost 10-15 full 4K wedding videos, highlight films with ease so not sure what happened over the last week? I checked my file settings and project settings and all is the same as usual.....editing in PR422. Any help would be greatly aprpeciated since the lag makes it almost impossible to work through. Thank you!

TOPICS
Editing , Freeze or hang , Performance

Views

134

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Dec 19, 2022 Dec 19, 2022

Yeah, I'm editing off a 4TB Sandisk SSD V2 drive. About 3TB left on it.

 

*Update - I updated my OS and PP software and now it seems to be working fine. Maybe it was a simple update fix? Either way it seems to be back to normal....for now! Thanks!

Likes

Translate

Translate
Community Expert ,
Dec 19, 2022 Dec 19, 2022

Copy link to clipboard

Copied

Do you have enough free hard drive space?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 19, 2022 Dec 19, 2022

Copy link to clipboard

Copied

Yeah, I'm editing off a 4TB Sandisk SSD V2 drive. About 3TB left on it.

 

*Update - I updated my OS and PP software and now it seems to be working fine. Maybe it was a simple update fix? Either way it seems to be back to normal....for now! Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 27, 2022 Dec 27, 2022

Copy link to clipboard

Copied

LATEST

I'm awaiting a Mac Studio M1 Ultra box at this time and researching gitcha's. On the avive issue, I see no version numberes to compare. Are you on Ventura, using Premiere in native M1 or in Rosetta II emulation? What version of Premiere Pro did you update to that eliminated your lag issues? 

It sounds like your Sandisk NVMe media drive has plenty of overhead. So it's really just understanding your from-to PP and MacOS version numbers which could be very valuable.

Thank you in advance!

 

Best as always,
Loren

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines