Rotating timecode, not simple at all

Community Beginner ,
Jul 18, 2022 Jul 18, 2022

Copy link to clipboard

Copied

Guys

 

I have GoPro footage, recorded upside down. The goal is to export it into individual frames WITH the original timecode... but

- when adding timecode from the effects, it's always upside down (as originally recoded), even if I rotated the clip itself - still upside down

- a friend of mine advised rotating first, exporting and re-importing and adding timecode - but by doing so my time is set to 0

- we also tried 'nest', this also set the timecode to 0

 

Has anyone had a similar experience?

When adding a timecode to the clip, I can control a lot but no option to rotate it... 

Massive thanks for all your time while we dig into this

j

TOPICS
Editing

Views

85

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct answers

Adobe Community Professional , Jul 18, 2022 Jul 18, 2022

This might work:

I assume you are using the Rotation Property to rotate your clip, using the Vertical Flip effect might produce a better result.

Apply Video Effects > Transform > Vertical Flip from the Effects panel.

Apply Video Effects > Video > Timecode

Applied in that order the transform should resolve first and then the timecode effect should apply.

 

Likes

Translate

Translate
Adobe Community Professional , Jul 18, 2022 Jul 18, 2022

 edit: add the "transform" effect and use its rotation to rotate the clip 180 degrees, after that add the timecode effect

Likes

Translate

Translate
Adobe Community Professional , Jul 18, 2022 Jul 18, 2022

I may be wrong, but I believe you reversed the order of effects. If Timecode is added first it will end up reversed when you apply the Transform effect.

So the I suggest the  right order would be:

Apply Transform effect. Set to 180

Apply Timecode

Likes

Translate

Translate
Adobe Community Professional ,
Jul 18, 2022 Jul 18, 2022

Copy link to clipboard

Copied

Hola si exportas imagenes individuales (secuencia PNG) no podras invertir el codigo de tiempo.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 18, 2022 Jul 18, 2022

Copy link to clipboard

Copied

This might work:

I assume you are using the Rotation Property to rotate your clip, using the Vertical Flip effect might produce a better result.

Apply Video Effects > Transform > Vertical Flip from the Effects panel.

Apply Video Effects > Video > Timecode

Applied in that order the transform should resolve first and then the timecode effect should apply.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 18, 2022 Jul 18, 2022

Copy link to clipboard

Copied

 edit: add the "transform" effect and use its rotation to rotate the clip 180 degrees, after that add the timecode effect

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 18, 2022 Jul 18, 2022

Copy link to clipboard

Copied

I may be wrong, but I believe you reversed the order of effects. If Timecode is added first it will end up reversed when you apply the Transform effect.

So the I suggest the  right order would be:

Apply Transform effect. Set to 180

Apply Timecode

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 18, 2022 Jul 18, 2022

Copy link to clipboard

Copied

Yes, you are right, I noticed that and edited my post just after submitting the reply. Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 19, 2022 Jul 19, 2022

Copy link to clipboard

Copied

It worked... amazing thank you. 

But may I ask, pls see below - in the video there is already a rotation option but that didn't do the tick, what's the difference?

 

 

Joolek_0-1658223563789.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 19, 2022 Jul 19, 2022

Copy link to clipboard

Copied

Some effects work on original clip and ignore the "Motion" in effects control panel, so adding the "Transform" effect solves that problem

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 19, 2022 Jul 19, 2022

Copy link to clipboard

Copied

LATEST

There is an order or operations when it comes to Effects.

It's the same reason why if you apply Timecode and then Transform (or flip) you will get one result and if you reverse the order and say apply Transform and then Timecode you will get a different result. 

In general Effects apply in order from top down and they affect not only the source clip but also each other. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines