Slow Performance with subtitles Premiere 2021

Community Beginner ,
Jul 30, 2021 Jul 30, 2021

Copy link to clipboard

Copied

Is anyone having an issues editing with the subtitles layer on?

Every time I try to make an edit or playback my edit. I get the mac beach ball. 

Is there another way to improve performance?

 

I am working with mac os Mojave Macbook Pro 2019

2.4 GHz Intel Core I9 Radeon Pro 560X 4GB 32GB RAM

TOPICS
Editing , Effects and Titles , Freeze or hang , Hardware or GPU , Performance

Views

3.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 02, 2022 Jan 02, 2022

Copy link to clipboard

Copied

Maybe the fact we use an SRT to import them?

 

In my case, I imported the SRT and dropped it on the timeline on this place: 

Susanne22475423uk9x_0-1641155599624.png

Please find the used SRT file, here if you want to test with that 🙂

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 02, 2022 Jan 02, 2022

Copy link to clipboard

Copied

The srt has 965 captions; imports fine to a new project. I placed it on a sequence created from a 26 minute 1920x1080 h.264 file. I added a second instance of the video to fill extend the length of the captions. I get DELAYS in simple selection/editing of captions. (This is the first time I have been able to create this problem.) The delays do not always happen, but a large percentage of the time. Some are very short delays. Others are long enough that I see the spinning cursor circle. I can get a delay when simply clicking to another point in the timeline - the previous caption stays on the screen until the switch occurs. Double clicking to edit may result in a delay before the text is highlighted.

 

I get the delays whether editing in the Text Panel or the Timeline. Some users have reported that avoiding the Text Panel helps.

 

I'll try to experiment further now that I can replicate this.

 

Stan

 

 

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 05, 2022 Jan 05, 2022

Copy link to clipboard

Copied

Thank you for this. Closing the text panel solved this lag for me. Just switching to another tab in the same panel doesn't work, the entire panel needs to be completely closed. I was doing a workaround where I only worked with about 100 caption segments at a time in a duplicate sequence, and cut/paste those back to the original sequence when done, or it would become too laggy. With hundreds of captions on the same timeline it would take 2+ seconds after I typed anything before the text would even appear on screen, which is obviously a major problem. 

 

Since I have a keyboard shortcut for adding a new caption, I was able to safely close the panel until I need it again for exporting, and there's no lag at all anymore. Not with adding, typing, trimming, moving, etc. It all works perfectly again. So it's clearly the panel that's causing this issue. Hopefully this helps the team isolate what they need to patch to fix this issue. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 05, 2022 Jan 05, 2022

Copy link to clipboard

Copied

morphinapg,

 

Thanks for stating that this workaround requires closing the text panel and not just switching tabs. I don't think that has always been clear as the way to work around the text panel.

 

I just demonstrated this in the project I was using that shows the delays. Unrelated to this, I had just reset my PR preferences, so the Text Panel was not open when I started the new test. No delays! I switch to the Editing workspace, and even though I was not in the Text Panel, it was open as a tab. Delays! Closed the text panel; NO delays!

 

It is probably unrelated, but there is a long standing bug (from the beginning of introducing the Text Panel) that Window -> Text works, but does not show a check mark there to indicate whether it is open or not.

 

Stan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

Thank you for the workaround, indeed..

 

However, since the subtitles themselves are still in rough shape themselves, I still need to merge/split/change subtitles quite often, so having the text panel open is paramount for this. 

 

Not in the least place that changing subtitles themselves (merge/split/change) also causing delays. So it'a a partial workaround at best 😉

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

There are a number of unassigned keyboard shortcuts that will work in the timeline. I assign split (using Ctrl+Alt+y) and merge (using Ctrl+Alt+u). Various of the caption shortcuts have broken off and on, mostly in the Beta versions, and my custom assignments have disappeared more than once - but probably because I reset preferences to test something.

 

Does that work for you?

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

Well, it turns out this solution only helped temporarily. My project has reached 900 captions and I'm starting to notice considerable lag even with the text panel closed now, especially noticeable when typing longer lines of text. Going back to my previous workaround until this gets fixed. 

 

For reference, my system is:


Ryzen 7 2700x
GTX 970
64 GB DDR4 RAM

 

(just got lucky enough to buy a GPU upgrade to RTX 3080Ti, so I'll have that soon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

morphinapg,

 

Disappointing, for sure. And thanks for reporting.

 

Is this entering text for new captions, or editing existing captions? What is a longer line: 2 lines, 3 lines? Or just maxing characters for a single line?

 

And the delays I was noting would be, for example, click from one caption to another, there would be a delay before the new caption appeared. Or double click to enter edit mode, then click to a cursor position, pause before it "took."

 

Just clarifying for when I have a chance to do more tests.

 

Stan

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

I'm typing new captions, but when I go back to edit existing captions, the same problem is present.

 

At this point I'm noticing the lag/delays most when captions are nearing the end of one line and starting the next. The longer the caption, the more noticeable the lag. In the past, as my caption tracks got longer, the effects became more noticeable even with very short captions. The main lag I'm seeing is the time it takes between when I press a key, and when that character appears on screen. In the past, at its worst, it was taking 2 or 3 seconds between key press and character appearing, which is obviously unusable, hence why I came up with the workaround to have a second identical sequence where I just do about an hour of my time transcribing before cut/pasting that back to the main sequence, usually around 100 captions or so at a time to avoid the lag. 

 

Yes I also see the type of delays you're referring to, but only with the text panel open. Even on my 900+ caption track, I still don't see those click delays when the text panel is closed, but the typing delay is still there. The typing lag does appear to be considerably worse with the text panel open than when closed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 05, 2022 Jan 05, 2022

Copy link to clipboard

Copied

I was seeing this all the time on a very complicated project, a restoration of a '80's documentary.   I'm working on both a windows machine and a couple of Macs... May not be an option for you, but I always duplicate my sequence when I start my days work so by the time I got around to doing the captions the project was about 28 mbs.  I did a save as and deleted most of the backup sequences and anything that I no longer needed to reference on a daily basis and my performance improved a great deal...  Also, I saw much improved performance when I updated to Premiere 2022...  Since the main element was the output from resolve (for restoration and colorcorrection) I also did an edit detcct on the sequence which made adjusting timing of captions much easier...    

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 07, 2022 Jan 07, 2022

Copy link to clipboard

Copied

fortunately for me, it's been a few months since I had to deal with captions in Premiere, but I'm starting to remember a few things that may have impacted performance.  Maybe try a proxy workflow with creating the proxy in an all i-frame format like prores proxy...  And I also found that I had some serious performance hits when I was working in a two monitor setup.  If possible try working with just a single monitor..  Also, because I needed to adjust vertical placement and add formatting for italics for the streaming platform the film festival used and the only way to get that formatting to hold was to convert the .srt file to a web vtt file and then apply these attributes, I did this in a program called Subtitle Edit recommended by some guy named ... Stan Jones, if I remember correctly (thanks again Stan, you're a life-saver).    There were a few quirks in Subtitle Edit but you might find it a better platform for this work...  Obviously, the new caption workflow in Premiere was a great place to start but Subtitle Edit was a life saver for my workflow.  

 

Next, I'm gonna have to deal with the DVD workflow which will be a whole other mess.  I went crazy figuring out how to work with Encore to author the dvd and blu-ray but now it appears that blu-ray is being delayed and the authoring for the dvd will probably be done by the distributor.  I'm assuming they'll be using Scenarist but haven't had that conversation with them yet...   

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 11, 2022 Aug 11, 2022

Copy link to clipboard

Copied

I've been dealing with this same problem for a very long time. Not only with captions tracks, but also with essential graphics text. On one doc, we had EG text rather than captions, for hours of dailies subtitles. Even if the captions track is turned off, or even if ALL video tracks are turned off, every single click gets the wheel of death. Also, even if all captions or EGs are disabled, same situation. Black screen, everything disabled, still the same. I've been searching for over a year for a solution, and I have found a workaround! (thanks to this thread). Disable duplicate frame markers. 100% total fix. Back to normal editing, with all tracks turned on, all captions enabled (thousands of captions and EGs on a 2-hour sequence with multiple layers of video). I'll miss my duplicate frame markers, but for now, worth the trade-off. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 11, 2022 Aug 11, 2022

Copy link to clipboard

Copied

thanks for posting your workaround.  while always nice if the is fixed, but it's about getting the work done...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 11, 2022 Aug 11, 2022

Copy link to clipboard

Copied

LATEST

I've never had duplicate frame markers enabled

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines